Page MenuHomeFreeBSD

Do not force WITH_OPENSSL_PORT on < 11.x unless using options that actually require it
Needs ReviewPublic

Authored by alex_kaworu.ch on May 10 2016, 9:30 AM.

Details

Reviewers
None
Group Reviewers
portmgr
Summary

Before this patch on < 11.x, having HTTP_SSL or MAIL_SSL would set
WITH_OPENSSL_PORT=yes but neither option need it.

This patch attempt to ensure that WITH_OPENSSL_PORT=yes is set if and only if
an options having '(SSL req.)' in its description is wanted on < 11.x.

see https://reviews.freebsd.org/rP414353

Test Plan

tested on 10.3-RELEASE-p2 with HTTP_SSL and without CT, HTTV2 nor
STREAM_SSL.

Diff Detail

Repository
rP FreeBSD ports repository
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 4136
Build 4179: arc lint + arc unit

Event Timeline

alex_kaworu.ch retitled this revision from to Do not force WITH_OPENSSL_PORT on < 11.x unless using options that actually require it.
alex_kaworu.ch updated this object.
alex_kaworu.ch edited the test plan for this revision. (Show Details)
alex_kaworu.ch added a reviewer: portmgr.
alex_kaworu.ch added a subscriber: bapt.

Test OPSYS when testing OSVERSION.

Thanks to @bapt for pointing out the DragonFly potential break.

rene added a subscriber: rene.Nov 3 2019, 11:17 AM

This one can be closed, 10.X has been end-of-life for a year now.