Presumably this was a hacky alternative way to write that pm_classes contained a PMC_CLASS_TSC? I imagine this check is now redundant.
Should we have an equivalent of this for the classes case? Also for the ARMV7/8 switches we now have? I guess continuing with the subset libpmc has been taught about is helpful, but silently not getting a set of counters also isn't...