Page MenuHomeFreeBSD

www/py-django: Deprecate and set to expire
ClosedPublic

Authored by kai on Mar 5 2022, 10:20 AM.

Details

Summary
This port was last used as a metaport and has only Django 2.2 as the
only option knob.  The use of this port as a dependency for several
consumers has in the past also repeatedly led to some problems with
conflicting transitive dependencies.

So there is no longer any use for this metaport thus let it expire
together with www/py-django22.

PR: 261313
Test Plan
  • No consumers exist that depend on www/py-django.

Diff Detail

Repository
R11 FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

kai requested review of this revision.Mar 5 2022, 10:20 AM
kai created this revision.

Please let me know if one of you have some more info (e.g. history, use cases) about this port. As far as I can recall, I haven't used the metaport very often so I might oversee something.

In D34453#780621, @kai wrote:

Please let me know if one of you have some more info (e.g. history, use cases) about this port. As far as I can recall, I haven't used the metaport very often so I might oversee something.

Hi.

I don't remember using this meta-port, IMHO, deprecating it makes sense, as it can confound users.

Regards.

This revision was not accepted when it landed; it landed in state Needs Review.Mar 25 2022, 4:08 PM
This revision was automatically updated to reflect the committed changes.