Page MenuHomeFreeBSD

sysutils/rubygem-hiera: update to 3.0.1
ClosedPublic

Authored by mmoll on Aug 11 2015, 12:57 PM.

Details

Summary

This is needed for Puppet 4. D3347 is also included here. @robak, would you be OK if sysutils/rubygem-hiera is maintained by ruby@?

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

mmoll updated this revision to Diff 7866.Aug 11 2015, 12:57 PM
mmoll retitled this revision from to sysutils/rubygem-hiera: update to 3.0.1.
mmoll updated this object.
mmoll edited the test plan for this revision. (Show Details)
mmoll added reviewers: bapt, robak, swills.
mmoll added a subscriber: robak.
robak accepted this revision.Aug 11 2015, 1:11 PM
robak edited edge metadata.

No, I dont mind switchin it to ruby@, and I do like the fact that you're keeping hiera-1.x around, since there's a lot of Puppet 3.x users that are not planning migration to 4.x anytime soon.

I am accepting these two aspects of that revision, with the sidenote, that I haven't actually reviewed nor tested the new hiera ports.

This revision is now accepted and ready to land.Aug 11 2015, 1:11 PM
mmoll added a comment.EditedAug 11 2015, 1:27 PM

As a sidenote: I plan to keep 3.x as sysutils/puppet, as it will take a long time until 4.x can be the default for most users. Another pain point will be facter 3.

mmoll updated this revision to Diff 7874.Aug 11 2015, 2:42 PM
mmoll edited edge metadata.

also change sysutils/rubygem-hiera - see https://github.com/adrienthebo/hiera-file/issues/13

This revision now requires review to proceed.Aug 11 2015, 2:42 PM
matthew accepted this revision.Aug 11 2015, 2:59 PM
matthew edited edge metadata.

Fine by me re. changes to rubygem-hiera-file

This revision is now accepted and ready to land.Aug 11 2015, 2:59 PM
This revision was automatically updated to reflect the committed changes.