Page MenuHomeFreeBSD

net-im/py-matrix-synapse: Update to 1.25.0
ClosedPublic

Authored by rhurlin on Jan 23 2021, 7:17 AM.

Details

Summary

Update from 1.24.0 to 1.25.0. The biggest change in the source is the ending support for Python 3.5 and Postgres 9.5. Several features are deprecated now, which means:

  • This is the last release which guarantees support for Python 3.5
  • Support for PostgreSQL 9.5 will end early in Februar 2021
  • Support for Python 3.6 and PostgreSQL 9.6 will end near the end of 2021

The deprecation notices for python and postgres are not yet relevant for v1.25.0, so the update should be fine regardless of the python version supported by the port or the postgres version currently available in FreeBSD.

Changelog: https://github.com/matrix-org/synapse/releases/tag/v1.25.0

Against the patch from maintainer, I reordered some Makefile vars (like portclippy suggest) and removed DOCS from OPTIONS_DEFAULT.

Submitted by Sascha Biberhofer <ports@skyforge.at> (maintainer) in PR 252912.

Tested on Poudriere (amd64, i386). 'portlint -AC' is fine.

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.