@imp Opening a diff for feedback/discussion
Added the duplication to a new file
Would it make more sense to create sys/x86/include/x86_ieeefp.h and include it in amd64/include/ieeefp.h and i386/include/ieeefp.h?
BTW, please consider submitting/updating patch with arc tool: https://wiki.freebsd.org/Phabricator
Move duplicated code under x86/include
@lwhsu Thank you, i moved the duplicated code under x86/include/x86_ieeefp.h and i was able to arc to update the diff.
Add new line and space after #include
Space after #include
@imp : ping, do you think this makes sense? It looks good to me but I'm not sure the convention is naming it x86_ieeefp.h or _ieeefp.h, I saw both under x86/include.
I think this is fine
One final question, is the "Deprecated historical FPU control interface" comment also applicable to the remaining codes in amd64 and i386?