Page MenuHomeFreeBSD

Rename devel/py-dialog to devel/py-pythondialog and merge it with devel/py-dialog3
Needs ReviewPublic

Authored by jkim on Sep 21 2019, 5:08 AM.

Details

Reviewers
koobs
Summary

This patch renames devel/py-dialog to devel/py-pythondialog and merges it with devel/py-dialog3. As a side effect, it updates devel/py-dialog to 3.5.1 and reassign the maintainer to me.

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Lint Skipped
Unit
Unit Tests Skipped

Event Timeline

jkim created this revision.Sep 21 2019, 5:08 AM
jkim retitled this revision from Rename devel/py-dialog to devel/py-pythondialog and merge with devel/py-dialog3 to Rename devel/py-dialog to devel/py-pythondialog and merge it with devel/py-dialog3.Sep 21 2019, 5:09 AM
jkim updated this revision to Diff 66461.Tue, Jan 7, 9:30 PM
jkim edited the summary of this revision. (Show Details)

Now the patch is updated to 3.5.1.

koobs requested changes to this revision.Wed, Jan 8, 3:54 AM
koobs added inline comments.
devel/py-pythondialog/Makefile
6–7

Ports SHOULD use MASTER_SITES=CHEESESHOP if a Python package is registered on PyPI, unless there is a compelling (temporary) case not to. [1]

https://wiki.freebsd.org/Python/PortsPolicy#MASTER_SITES

7–8

This (likely) shouldnt be necessary after updating to use PyPI as MASTER_SITES

16–17

setup.py contains python_requires=">=3" which means it (apparently) only supports Python 3.x

"Python ports MUST declare USES=python :<version-spec> as completely and accurately as possible, without being incorrect, given existing syntax constraints." [1]

[1] https://wiki.freebsd.org/Python/PortsPolicy#USES.3Dpython

17

What is/was pythonprefix required for? The vast majority of ports don't require this, so it would be informative to know the reason

19

What port/package does this conflict refer to?

If there is indeed a conflicting port/package, it probably only CONFLICTS_INSTALL (CONFLICTS means conflicts at install *and* build time)

23

This shouldnt be necessary after updating to use PyPI as MASTER_SITES

28

What is this block needed for?

This revision now requires changes to proceed.Wed, Jan 8, 3:54 AM
jkim added inline comments.Tue, Jan 14, 12:02 AM
devel/py-pythondialog/Makefile
6–7

Okay.

7–8

Well, pythondialog has two projects unfortunately.

https://pypi.org/project/pythondialog
https://pypi.org/project/python2-pythondialog

Unless you prefer two separate projects, it is necessary.

16–17

Okay.

17

Oops, it was copied from an old port.

19

Basically, this port replaces devel/py-dialog and devel/py-dialog3. Don't we have to check the old packages? Anyway, you're right. CONFLICTS_INSTALL is better.

23

Yes, you're right.

28

This port uses cdialog from devel/cdialog instead of dialog(1) because our fork is incompatible.

jkim updated this revision to Diff 66711.Tue, Jan 14, 12:07 AM
koobs added inline comments.Tue, Jan 14, 2:37 AM
devel/py-pythondialog/Makefile
7–8

Hmm. Still a little confused

I can see:

  • python2-pythondialog package, which is Python >=3, and
  • pythondialog (Python >=2.6, <3 )

I can't see a package for python3-pythondialog, so how will/does this port work for Python 3 ?

28

Ahh thanks, would be great to have a comment above this block for our future selves

jkim added inline comments.Tue, Jan 14, 8:15 PM
devel/py-pythondialog/Makefile
7–8

Actually, it's the opposite.

https://pypi.org/project/pythondialog/

Requirements

  • As of version 2.12, the reference implementation of pythondialog (which this file belongs to) requires Python 3.0 or later in the 3.x series. pythondialog 3.5.1 has been tested with Python 3.8.
  • Versions of pythondialog up to and including 3.5.1 had a backport to Python 2, however this outdated Python dialect isn’t supported anymore. You may find pointers to the old packages with Python 2 support on the pythondialog home page.

https://pypi.org/project/python2-pythondialog/

Requirements

  • This now unsupported backport of pythondialog requires Python 2.6 or later in the 2.x series. It has been tested with Python 2.7.

In other words,

  • pythondialog package, which is Python >=3, and
  • python2-pythondialog (Python >=2.6, <3)
jkim updated this revision to Diff 66755.Tue, Jan 14, 8:56 PM