Page MenuHomeFreeBSD

devel/py-fabric: Update to 2.5.0
ClosedPublic

Authored by dbaio on Jun 18 2019, 2:04 PM.

Details

Summary

Note: This needs to take place after a D21304 lands

devel/py-fabric: Update to 2.5.0

Fabric 2 is not at 100% feature parity with 1.x! Some features have been
explicitly dropped, but others simply have not been ported over yet,
either due to time constraints or because said features need to be
re-examined in a modern context.

More information at:
https://www.fabfile.org/upgrading.html#upgrading
https://www.fabfile.org/upgrading.html#upgrade-specifics

Changelog:      https://www.fabfile.org/changelog.html

Reviewed_by: koobs (maintainer)
Approved by: koobs (maintainer)
Differential_Revision: D20683
Test Plan
devel/py-fabric:
        portlint: OK (looks fine.)
        testport: OK (poudriere: 11,12,CURRENT, amd64 and i386, py27 and py36)
        maketest: OK (315 passed, 7 skipped, 1 deselected, 1150 warnings in 2.91 second)

devel/py-fabric1:
        portlint: OK (looks fine.)
        testport: OK (poudriere: 11,12,CURRENT, amd64 and i386, py27)
        maketest: 
                Ran 416 tests in 240.040s / FAILED (errors=6, failures=1) devel/py-fabric1 (1.14.1)
                Ran 416 tests in 243.216s / FAILED (errors=6, failures=2) devel/py-fabric  (1.14.1) before upgrading

It was also executed a simple runtime test in all consumers, checking fabric1 connections.

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

koobs created this revision.Jun 18 2019, 2:04 PM
koobs added a comment.Aug 14 2019, 4:44 AM

@dbaio Can you add these to the diff please:

  • Copies py-fabric -> py-fabric1
  • Updates dependents that require fabric < 2 to devel/py-fabric1

Alternatively, create a separate differential for them, and set this as dependent (child) of it

dbaio added a comment.Aug 15 2019, 7:25 PM

@dbaio Can you add these to the diff please:

  • Copies py-fabric -> py-fabric1
  • Updates dependents that require fabric < 2 to devel/py-fabric1

Alternatively, create a separate differential for them, and set this as dependent (child) of it

To update this review I'll need to get it with the Commandeer Revision, is that ok ?

koobs added a comment.Aug 16 2019, 2:49 AM

@dbaio Can you add these to the diff please:

  • Copies py-fabric -> py-fabric1
  • Updates dependents that require fabric < 2 to devel/py-fabric1

Alternatively, create a separate differential for them, and set this as dependent (child) of it

To update this review I'll need to get it with the Commandeer Revision, is that ok ?

Go nuts :)

dbaio commandeered this revision.Aug 17 2019, 1:15 PM
dbaio edited reviewers, added: koobs; removed: dbaio.
dbaio updated this revision to Diff 60934.Aug 17 2019, 1:19 PM
dbaio retitled this revision from devel/py-fabric: Update to 2.4.0 to devel/py-fabric: Update to 2.5.0.
dbaio edited the summary of this revision. (Show Details)
dbaio edited the test plan for this revision. (Show Details)
dbaio updated this revision to Diff 61381.Aug 27 2019, 11:08 PM
dbaio edited the summary of this revision. (Show Details)
koobs accepted this revision.Sep 6 2019, 3:10 PM
koobs edited the summary of this revision. (Show Details)
koobs edited the summary of this revision. (Show Details)

Thank you for taking care of this @dbaio

This revision is now accepted and ready to land.Sep 6 2019, 3:12 PM
This revision was automatically updated to reflect the committed changes.