Page MenuHomeFreeBSD

Switch default version of python to 3.6
ClosedPublic

Authored by antoine on Jan 4 2019, 9:31 AM.

Details

Summary

Switch default version of python to 3.6
This has to happen sometime in 2019

Diff Detail

Repository
rP FreeBSD ports repository
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 21831
Build 21095: arc lint + arc unit

Event Timeline

antoine created this revision.Jan 4 2019, 9:31 AM
mat added a comment.Jan 5 2019, 9:51 AM

I wonder if the .if FLAVOR should not be changed to checks on PYTHON_VER, so that people who change the default Python version get the correct behavior.

miwi added a subscriber: miwi.EditedJan 6 2019, 12:59 PM

Please consider of switching llvm60/70 to use python3 with the flip too.

https://people.freebsd.org/~miwi/py3/llvm60.diff
https://people.freebsd.org/~miwi/py3/llvm70.diff

i started updating the wiki page around the same day u started this pr:

https://wiki.freebsd.org/Python/Python3Default

the idea was to start looking in to this ports and see what can be updated or moved to python3 as well.

Switching default version of python is orthogonal to removing python27.

mat added a comment.Jan 9 2019, 12:17 PM

Switching LLVM's Python should probably be discussed with LLVM's maintainer, and not here. It has nothing to do with switching the default version of Python.

This revision was not accepted when it landed; it landed in state Needs Review.Apr 10 2019, 5:47 AM
This revision was automatically updated to reflect the committed changes.