Add a device_delete_children(9) manual page based on the comments in code.
(here and below) I'm not a native speaker so could very wrong.. Shouldn't this read "child devices" instead?
Add double quotes around device_t dev.
It's usually written as the following even if there's only one function discussed.
The .Fn device_delete_children function ...
You are correct. I did some checking on various English grammar fora and it seems to be a mistaken use of children, indeed. You talk about "deleting the children from a device", but "deleting the child devices".