Page MenuHomeFreeBSD

net-im/rubygem-earthquake: Remove port
ClosedPublic

Authored by meta on May 15 2018, 2:33 AM.

Details

Summary

This port has been broken for years and no longer maintained by upstream.

Also, remove security/rubygem-jugyo_twtter_oauth. It is a fork of
twitter_oauth[1] and required only by net-im/rubygem-earthquake.

[1] https://rubygems.org/gems/twitter_oauth

Approved by: TO_BE_FILLED_IN (mentor)

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

meta created this revision.May 15 2018, 2:33 AM
hrs added inline comments.May 15 2018, 3:01 AM
MOVED
10189 ↗(On Diff #42561)

One question: is termitter upper-compatible with earthquake? If termitter is another software that is not compatible, it should not be listed here because this entry will force the users to upgrade earthquake.

meta added inline comments.May 15 2018, 4:49 AM
MOVED
10189 ↗(On Diff #42561)

Likely no. AFAIR, earthquake was developed to replace termtter and then termtter had been obsoleted at the time. After the original author quit development of both, people support termtter rather than earthquake and community-driven development revived termtter.

Based on this fact, I think termtter is the most similar software to earthquake but not a drop-in replacement. Will remove it from "moved to".

meta updated this revision to Diff 42563.May 15 2018, 5:57 AM

termtter might not be a replacement of earthquake

meta edited the summary of this revision. (Show Details)May 15 2018, 5:59 AM
hrs accepted this revision.May 15 2018, 6:24 AM
This revision is now accepted and ready to land.May 15 2018, 6:24 AM
This revision was automatically updated to reflect the committed changes.