Page MenuHomeFreeBSD

Unbreak devel/fuel and update to 1.0.1
ClosedPublic

Authored by rezny on Mar 30 2017, 12:49 PM.

Details

Summary

From PR 217824: This port got marked broken due to google code while there are newer released on the website. Fix fetch, update to current release, update WWW and description, add option to select QT4 or QT5; there is no KDE integration so the latter is the default, and install a working .desktop file with icon. Maintainer timed out.

Test Plan

Poudriere 10.3/11.0 amd64/i386 QT4/QT5 OK, both variants run verified on 11amd64

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

devel/fuel/Makefile
15 ↗(On Diff #26818)

This should probably be RUN_DEPENDS= fossil:devel/fossil.

Simplify RUN_DEPENDS as mat suggested.

This revision is now accepted and ready to land.Mar 31 2017, 12:36 AM
This revision was automatically updated to reflect the committed changes.