HomeFreeBSD

www/py-soupsieve: Add missing dependency

Description

www/py-soupsieve: Add missing dependency

soupsieve depends on backports.functools_lru_cache [1] on Python versions <
3, add the dependency accordingly.

While I'm here:

  • Add TEST_DEPENDS and test target to improve future QA

Note: soupsieve 'requires' [2] beautifulsoup4, but beautifulsoup4 depends

on soupsieve via install_requires, causing a technical circular
dependency, which is why soupsieve doesn't seem to explicitly
install_requires on it ... anymore [3]. This seems bizzare.

[1] requirements/project.txt: backports.functools_lru_cache ; python_version < '3'
[2] https://github.com/facelessuser/soupsieve#installation
[3] https://github.com/facelessuser/soupsieve/commit/9a792216ea1ffce018c7968105540c08b82b96db

QA: 624 passed, 2 skipped, 6 warnings in 35.70 seconds

PR: 240490
Reported by: jbeich
Approved by: portmgr (blanket: missing dependencies, ports compliance)
MFH: 2019Q3 (blanket(s): run-time bugfix)

Details

Committed
koobsSep 11 2019, 11:04 AM
Parents
rP511813: Update to the 20190907 snapshot of GCC 9.2.1.
Branches
Unknown
Tags
Unknown