HomeFreeBSD

devel/py-virtualenvwrapper: Allow Python 3 builds

Description

devel/py-virtualenvwrapper: Allow Python 3 builds

virtualenvwrapper supports Python 3, remove unnecessary limitation on 2.7
accordingly.

A dependency (sphinxcontrib-bitbucket) Python 3 build/run error was
fixed in ports r508699, which is required by virtualenvwrapper for its
DOCS option/build.

While I'm here:

  • Level up ports compliance (NO_ARCH, USES/USE order)
  • Remove unecessary DOCS_VARS DOCSDIR override (concurrent does this)
  • Patch virtualenvwrapper command invocations (virtualenv, virtualenv-clone) to use Python version-specific filenames

Approved by: portmgr (blanket(s): ports compliance, python compliance)
MFH: 2019Q3

Details

Committed
koobsAug 12 2019, 1:33 AM
Parents
rP508700: MFH: r508699 textproc/py-sphinxcontrib-bitbucket: Fix Python 3 build/run
Branches
Unknown
Tags
Unknown