HomeFreeBSD

Update to 2.6.1:

Description

Update to 2.6.1:

  • Update the embedded SQLite library from 3.18.0 to 3.26.0 to address a remote code execution vulnerability ("Magellan").
  • Uses a bundled version of the actor-framework (caf) library so we can remove the port-local build for caf.

Replace broctl-config.sh absolute symlink with a relative one.

Approved by: ler (mentor, implicit)
MFH: 2018Q4
Security: b80f039d-579e-4b82-95ad-b534a709f220

Details

Committed
leresDec 20 2018, 1:25 AM
Parents
rP487822: x11-wm/stumpwm: Update to 18.11 (plus fixes for issues #538, #541)
Branches
Unknown
Tags
Unknown