HomeFreeBSD

Update the Qt5 ports to 5.10.1.

Description

Update the Qt5 ports to 5.10.1.

The work was done by tcberner and myself, with thanks to antoine for the
exp-run.

Not a lot to report compared to other Qt5 updates:

  • net/qt5-network is still broken with LibreSSL. I said this in a commit message ages ago but it bears repeating: upstream is open to adding support for LibreSSL, but someone needs to step up to maintain it upstream, otherwise things will continue to be broken all the time.
  • www/qt5-webengine is a huge monster that is terrible to update, just like www/chromium itself is. We (kde@) have decided to keep using the 5.9 series for the time being, as it should be compatible with the rest of Qt anyway. It was updated to 5.9.5, the latest 5.9 release at the time of writing.

PR: 228213

Details

Committed
rakucoMay 18 2018, 12:27 PM
Parents
rP470287: MFH: r469248
Branches
Unknown
Tags
Unknown