HomeFreeBSD

Update to 2.4.78 and remove the dependency on libdevq

Description

Update to 2.4.78 and remove the dependency on libdevq

The functionality previously provided by libdevq is now implemented directly
in libdrm. This direct implementation should be more robust than the prior
integration. Initial testing has shown improvements in some scenarios while
remaining on-par elsewhere. The ultimate goal of this effort is to have our
platform support integrated upstream, which will be easier without the extra
dependency. With that in mind, please quickly report any regressions found.

Reviewed by: dumbbell (x11), bapt (x11)
Approved by: swills (mentor), dumbbell (x11)
Differential Revision: https://reviews.freebsd.org/D10184

Details

Committed
reznyApr 8 2017, 3:49 PM
Reviewer
dumbbell
Differential Revision
D10184: Update libdrm to 2.4.78 and remove the dependency on libdevq
Parents
rP438050: Now builds on powerpc64.
Branches
Unknown
Tags
Unknown