HomeFreeBSD

graphics/darktable: Update to 2.2.2

Description

graphics/darktable: Update to 2.2.2

Use devel/openmp to provide OpenMP runtime instead of the entire LLVM
(submitted by mandree@). This allows to use LLVM 3.9 at build time,
without fearing any dependency to multiple LLVM versions at runtime
(Mesa pulls LLVM 3.7 for instance).

Change COMPILER_TYPE to CHOSEN_COMPILER_TYPE, (submitted by
mandree@). This was blocking bug 199098.

Include the following patch from upstream, which fixes a regression
(suggested by upstream):
https://github.com/darktable-org/darktable/commit/f7bc2b3338832a42629cdfaa691b5c921df0701c.patch

PR: 216561
Submitted by: mandree (CHOSEN_COMPILER_TYPE and devel/openmp dep.)
Approved by: bapt (mentor)
Differential Revision: https://reviews.freebsd.org/D9363

Details

Committed
dumbbellJan 30 2017, 9:14 PM
Differential Revision
D9363: graphics/darktable: Update to 2.2.2
Parents
rP432870: MFH: r432866
Branches
Unknown
Tags
Unknown