Page MenuHomeFreeBSD
Paste P475

Simplified diff (i.e. without removed ports themselves) of no-py27 against r566185, INDEX builds (for real)
ActivePublic

Authored by rene on Jan 19 2021, 9:08 PM.
diff --git a/MOVED b/MOVED
index b564ea39f845..40f6a75ebf22 100644
--- a/MOVED
+++ b/MOVED
@@ -16175,3 +16175,15 @@ sysutils/uefi-edk2-bhyve-devel|sysutils/uefi-edk2-bhyve|2021-02-17|Development v
graphics/py-graph-core|graphics/py-pygraph|2021-02-19|Is outdated and broken with python3, use graphics/py-pygraph instead
devel/llvm60||2021-02-19|Has expired: Uses Python 2.7 which is EOLed upstream, no more consumers left
devel/allegro-devel|devel/allegro5|2021-02-20|Rename to better match upstream name
+#### PYTHON 2.7 ####
+devel/godot2|devel/godot|9999-12-31|Move to suported version
+devel/godot2-tools|devel/godot-tools|9999-12-31|Move to suported version
+devel/llvm70|devel/llvm80|9999-12-31|Move to suported version
+devel/subversion-lts|devel/subversion|9999-12-31|Move to suported version
+devel/viewvc|devel/viewvc-devel|9999-12-31|Move to suported version
+lang/spidermonkey185|lang/spidermonkey78|9999-12-31|Move to suported version
+lang/spidermonkey52|lang/spidermonkey78|9999-12-31|Move to suported version
+lang/spidermonkey60|lang/spidermonkey78|9999-12-31|Move to suported version
+www/node10|www/node14|9999-12-31|Move to suported version
+www/node12|www/node14|9999-12-31|Move to suported version
+#### PYTHON 2.7 ####
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index 8d34d0ccdf02..4a988e1cc36c 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -50,7 +50,7 @@ shebangonefile() {
/bin/rc)
# whitelist some interpreters
;;
- ${LOCALBASE}/bin/python|${PREFIX}/bin/python|${LOCALBASE}/bin/python2|${PREFIX}/bin/python2|${LOCALBASE}/bin/python3|${PREFIX}/bin/python3)
+ ${LOCALBASE}/bin/python|${PREFIX}/bin/python|${LOCALBASE}/bin/python3|${PREFIX}/bin/python3)
badinterp="${interp}"
;;
${LINUXBASE}/*) ;;
@@ -71,7 +71,7 @@ shebangonefile() {
/usr/bin/env)
interparg=$(sed -n -e '1s/^#![[:space:]]*[^[:space:]]*[[:space:]]*\([^[:space:]]*\).*/\1/p;2q' "${f}")
case "${interparg}" in
- python|python2|python3)
+ python|python3)
badinterp="${interp} ${interparg}"
;;
esac
@@ -962,7 +962,7 @@ depends_blacklist()
instead=""
case "$origin" in
- lang/python|lang/python2|lang/python3)
+ lang/python|lang/python3)
# lang/python depends on lang/pythonX, but it's
# ok, it is also in the blacklist.
if [ ${PKGORIGIN} != lang/python ]; then
diff --git a/Mk/Uses/fortran.mk b/Mk/Uses/fortran.mk
index 212acd7db889..850343c33b6f 100644
--- a/Mk/Uses/fortran.mk
+++ b/Mk/Uses/fortran.mk
@@ -4,7 +4,7 @@
#
# Feature: fortran
# Usage: USES=fortran
-# Valid ARGS: flang, gfortran (default)
+# Valid ARGS: gfortran (default)
#
# MAINTAINER: fortran@FreeBSD.org
@@ -15,17 +15,7 @@ _INCLUDE_USES_FORTRAN_MK= yes
fortran_ARGS= ${FORTRAN_DEFAULT}
.endif
-.if ${fortran_ARGS} == flang
-.if ${ARCH} == amd64
-BUILD_DEPENDS+= flang>0:devel/flang
-RUN_DEPENDS+= flang>0:devel/flang
-F77= flang
-FC= flang
-LDFLAGS+= -L${LOCALBASE}/flang/lib -Wl,--as-needed -lflang -lexecinfo -Wl,--no-as-needed
-.else
-IGNORE= USES=fortran: flang argument only available for amd64
-.endif
-.elif ${fortran_ARGS} == gfortran
+.if ${fortran_ARGS} == gfortran
_GCC_VER= ${GCC_DEFAULT:S/.//}
BUILD_DEPENDS+= gfortran${_GCC_VER}:lang/gcc${_GCC_VER}
RUN_DEPENDS+= gfortran${_GCC_VER}:lang/gcc${_GCC_VER}
diff --git a/Mk/Uses/pyqt.mk b/Mk/Uses/pyqt.mk
index 7cddc81935ee..ec9a0ee8676c 100644
--- a/Mk/Uses/pyqt.mk
+++ b/Mk/Uses/pyqt.mk
@@ -89,7 +89,7 @@ _USE_PYQT_MULTIMEDIA= multimedia multimediawidgets
_USE_PYQT_NET= network networkauth
_USE_PYQT_PRINT= printsupport
_USE_PYQT_TEXTPROC= xml xmlpatterns
-_USE_PYQT_WWW= webchannel webengine webkit webkitwidgets websockets
+_USE_PYQT_WWW= webchannel webkit webkitwidgets websockets
_USE_PYQT_X11= opengl
_USE_PYQT_X11-TOOLKITS= chart gui widgets quick quick3d quickwidgets
@@ -173,7 +173,6 @@ py-sql_DESC= Python bindings for QtSql module
py-svg_DESC= Python bindings for QtSvg module
py-test_DESC= Python bindings for QtTest module
py-webchannel_DESC= Python bindings for QtWebChannel module
-py-webengine_DESC= Python bindings for QtWebEngine module
py-webkit_DESC= Python bindings for QtWebKit module
py-webkitwidgets_DESC= Python bindings for QtWebKitWidgets module
py-widgets_DESC= Python bindings for QTWidgets module
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 8fe19724fde7..f83679030b7b 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -18,7 +18,6 @@
#
# Examples:
#
-# USES=python:2.7 # Supports Python 2.7 Only
# USES=python:3.6+ # Supports Python 3.6 or later
# USES=python:3.6-3.9 # Supports Python 3.6 to 3.9
# USES=python:-3.8 # Supports Python up to 3.8
@@ -31,7 +30,7 @@
#
# Not specifying a <version-spec> should only be used when a more specific
# <version-spec> cannot be specified due to syntax limitations, for
-# example: 2.7,3.4-3.6, but even in this case, X.Y+ (2.7+), or -X.Y (-3.6)
+# example: 3.6,3.8-3.9, but even in this case, X.Y+ (3.6+), or -X.Y (-3.9)
# is preferred and likely more correct.
#
# patch Python is needed at patch time. Adds dependency to PATCH_DEPENDS.
@@ -52,7 +51,7 @@
# Exported variables:
#
# PYTHON_VERSION - The chosen Python interpreter including the version,
-# e.g. python2.7, python3.5, etc.
+# e.g. python3.6, python3.7, etc.
#
# Variables, which can be set by the port:
#
@@ -82,13 +81,13 @@
#
# are linked from the prefixed version to the
# prefix-less original name, e.g.
-# bin/foo-2.7 --> bin/foo.
+# bin/foo-3.6 --> bin/foo.
#
# cython - Depend on lang/cython at build-time.
#
# cython_run - Depend on lang/cython at run-time.
#
-# flavors - Force creation of flavors for Python 2 and 3 default
+# flavors - Force creation of flavors for Python 3 default
# versions, where applicable.
#
# noflavors - Disable automatic creation of flavors if they would
@@ -109,7 +108,7 @@
# port that uses distutils when defined.
# requires: distutils
#
-# py3kplist - Automatically generates Python 3.x compatible
+# *** py3kplist *** - Automatically generates Python 3.x compatible
# __pycache__ entries from a Python 2.x packaging list
# when defined. Use this for ports that do *not* use
# standard Python packaging mechanisms such as
@@ -176,17 +175,17 @@
# PYTHON_PORTSDIR - The port directory of the chosen Python interpreter
#
# PYTHON_REL - The release number of the chosen Python interpreter
-# without dots, e.g. 2706, 3401, ...
+# without dots, e.g. 3709, 3807, ...
#
# PYTHON_SUFFIX - The major-minor release number of the chosen Python
-# interpreter without dots, e.g. 27, 36, ...
+# interpreter without dots, e.g. 36, 38, ...
# Used for prefixes and suffixes.
#
# PYTHON_MAJOR_VER - The major release version of the chosen Python
-# interpreter, e.g. 2, 3, ...
+# interpreter, e.g. 3, ...
#
# PYTHON_VER - The major-minor release version of the chosen Python
-# interpreter, e.g. 2.7, 3.6, ...
+# interpreter, e.g. 3.7, 3.8, ...
#
# PYTHON_ABIVER - Additional ABI flags set by the chosen Python
# interpreter, e.g. md
@@ -234,11 +233,6 @@
# PYTHON_VER=${PYTHON_VER}
# PYTHON_VERSION=${PYTHON_VERSION}
#
-# and PYTHON2 and PYTHON3 will be set according to the Python version:
-#
-# PYTHON2="" PYTHON3="@comment " for Python 2.x
-# PYTHON2="@comment " PYTHON3="" for Python 3.x
-#
# PYDISTUTILS_INSTALLNOSINGLE
# - Deprecated without replacement
#
@@ -250,8 +244,8 @@ _INCLUDE_USES_PYTHON_MK= yes
# What Python version and what Python interpreters are currently supported?
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-_PYTHON_VERSIONS= 2.7 3.7 3.8 3.9 3.6 # preferred first
-_PYTHON_PORTBRANCH= 2.7 # ${_PYTHON_VERSIONS:[1]}
+_PYTHON_VERSIONS= 3.7 3.8 3.9 3.6 # preferred first
+_PYTHON_PORTBRANCH= 3.7 # ${_PYTHON_VERSIONS:[1]}
_PYTHON_BASECMD= ${LOCALBASE}/bin/python
_PYTHON_RELPORTDIR= lang/python
@@ -320,17 +314,13 @@ _PYTHON_RUN_DEP= yes
_PYTHON_TEST_DEP= yes
.endif
-.if ${PYTHON2_DEFAULT} != ${PYTHON_DEFAULT} && ${PYTHON3_DEFAULT} != ${PYTHON_DEFAULT}
-WARNING+= "PYTHON_DEFAULT must be a version present in PYTHON2_DEFAULT or PYTHON3_DEFAULT, if you want more Python flavors, set BUILD_ALL_PYTHON_FLAVORS in your make.conf"
+.if ${PYTHON3_DEFAULT} != ${PYTHON_DEFAULT}
+WARNING+= "PYTHON_DEFAULT must be a version present in PYTHON3_DEFAULT, if you want more Python flavors, set BUILD_ALL_PYTHON_FLAVORS in your make.conf"
.endif
-.if ${_PYTHON_ARGS} == 2.7
-DEV_WARNING+= "lang/python27 reached End of Life and will be removed on 2020-12-31, consider converting to a modern version of python"
-.elif ${_PYTHON_ARGS} == 2
-DEV_ERROR+= "USES=python:2 is no longer supported, use USES=python:2.7"
-.elif ${_PYTHON_ARGS} == 3
+.if ${_PYTHON_ARGS} == 3
DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.6+ or an appropriate version range"
-.endif # ${_PYTHON_ARGS} == 2.7
+.endif # ${_PYTHON_ARGS} == 3
_PYTHON_VERSION:= ${PYTHON_DEFAULT}
@@ -362,7 +352,7 @@ _PYTHON_VERSION_NONSUPPORTED= ${_PYTHON_VERSION_MAXIMUM} at most
# If we have an unsupported version of Python, try another.
.if defined(_PYTHON_VERSION_NONSUPPORTED)
.undef _PYTHON_VERSION
-.for ver in ${PYTHON2_DEFAULT} ${PYTHON3_DEFAULT} ${_PYTHON_VERSIONS}
+.for ver in ${PYTHON3_DEFAULT} ${_PYTHON_VERSIONS}
__VER= ${ver}
.if !defined(_PYTHON_VERSION) && \
!(!empty(_PYTHON_VERSION_MINIMUM) && ( \
@@ -380,7 +370,7 @@ IGNORE= needs an unsupported version of Python
# Automatically generates FLAVORS if empty
.if empty(FLAVORS) && defined(_PYTHON_FEATURE_FLAVORS)
. undef _VALID_PYTHON_VERSIONS
-. for ver in ${PYTHON_DEFAULT} ${PYTHON2_DEFAULT} ${PYTHON3_DEFAULT} ${_PYTHON_VERSIONS}
+. for ver in ${PYTHON_DEFAULT} ${PYTHON3_DEFAULT} ${_PYTHON_VERSIONS}
__VER= ${ver}
. if !(!empty(_PYTHON_VERSION_MINIMUM) && ( \
${__VER} < ${_PYTHON_VERSION_MINIMUM})) && \
@@ -402,7 +392,7 @@ _ALL_PYTHON_FLAVORS= ${_PYTHON_VERSIONS:S/.//:S/^/py/}
. if defined(BUILD_ALL_PYTHON_FLAVORS) || defined(_PYTHON_FEATURE_ALLFLAVORS)
FLAVORS= ${_ALL_PYTHON_FLAVORS}
. else
-. for _v in ${PYTHON_DEFAULT} ${PYTHON2_DEFAULT} ${PYTHON3_DEFAULT}
+. for _v in ${PYTHON_DEFAULT} ${PYTHON3_DEFAULT}
_f= py${_v:S/.//}
. if ${_ALL_PYTHON_FLAVORS:M${_f}} && !${FLAVORS:M${_f}}
.if !empty(FLAVORS)
@@ -418,7 +408,7 @@ FLAVOR= ${FLAVORS:[1]}
. endif
.endif
-.if ${FLAVOR:Mpy[23][0-9]}
+.if ${FLAVOR:Mpy3[0-9]}
_PYTHON_VERSION= ${FLAVOR:S/py//:C/(.)/\1./}
.endif
@@ -465,19 +455,12 @@ PYTHON_REL= ${PYTHON_PORTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/:C/\.([0-9]+)$
# Might be overridden by calling ports
PYTHON_CMD?= ${_PYTHON_BASECMD}${_PYTHON_VERSION}
-.if ${PYTHON_VER} != 2.7
.if exists(${PYTHON_CMD}-config)
PYTHON_ABIVER!= ${PYTHON_CMD}-config --abiflags
.elif ${PYTHON_REL} < 3800
# Default ABI flags for lang/python3[67] ports
PYTHON_ABIVER= m
.endif
-.endif
-
-.if ${PYTHON_MAJOR_VER} == 2
-DEPRECATED?= Uses Python 2.7 which is EOLed upstream
-EXPIRATION_DATE?= 2020-12-31
-.endif
.if !defined(PYTHONBASE)
PYTHONBASE!= (${PYTHON_CMD} -c 'import sys; print(sys.prefix)' \
@@ -528,8 +511,8 @@ RUN_DEPENDS+= cython-${PYTHON_VER}:lang/cython@${PY_FLAVOR}
.endif
.if defined(_PYTHON_FEATURE_CONCURRENT)
-.if !defined(_PYTHON_FEATURE_FLAVORS) && (${_PYTHON_VERSION_MINIMUM:M3*} || ${_PYTHON_VERSION_MAXIMUM:M2*})
-DEV_WARNING+= "USE_PYTHON=concurrent when only one of Python 2 or 3 is supported AND not using flavors does not make any sense"
+.if !defined(_PYTHON_FEATURE_FLAVORS) && ${_PYTHON_VERSION_MINIMUM:M3*}
+DEV_WARNING+= "USE_PYTHON=concurrent when only Python 3 is supported AND not using flavors does not make any sense"
.endif
_USES_POST+= uniquefiles:dirs
.if defined(_PYTHON_FEATURE_FLAVORS) && ${FLAVOR} == ${FLAVORS:[1]}
@@ -616,8 +599,8 @@ add-plist-pymod:
${_PYTHONPKGLIST} | ${SORT} >> ${TMPPLIST}
.else
-.if ${PYTHON_REL} >= 3200 && defined(_PYTHON_FEATURE_PY3KPLIST)
-# When Python version is 3.2+ we rewrite all the filenames
+.if defined(_PYTHON_FEATURE_PY3KPLIST)
+# We rewrite all the filenames
# of TMPPLIST that end with .py[co], so that they conform
# to PEP 3147 (see https://www.python.org/dev/peps/pep-3147/)
PYMAGICTAG= ${PYTHON_CMD} -c 'import sys; print(sys.implementation.cache_tag)'
@@ -632,7 +615,7 @@ add-plist-python:
pc="__pycache__" mt="$$(${PYMAGICTAG})" pyo="opt-1.pyc" \
${TMPPLIST} > ${TMPPLIST}.pyc_tmp
@${MV} ${TMPPLIST}.pyc_tmp ${TMPPLIST}
-.endif # ${PYTHON_REL} >= 3200 && defined(_PYTHON_FEATURE_PY3KPLIST)
+.endif # defined(_PYTHON_FEATURE_PY3KPLIST)
.endif # defined(_PYTHON_FEATURE_AUTOPLIST) && defined(_PYTHON_FEATURE_DISTUTILS)
# Fix for programs that build python from a GNU auto* environment
@@ -647,18 +630,10 @@ PYGAME= ${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game@${PY_FLAVOR}
PYNUMPY= ${PYTHON_PKGNAMEPREFIX}numpy>=1.16,1<1.20,1:math/py-numpy@${PY_FLAVOR}
# Common Python modules that can be needed but only for some versions of Python.
-.if ${PYTHON_REL} < 3500
-PY_PYGMENTS= ${PYTHON_PKGNAMEPREFIX}pygments-25>=2.5.1<3:textproc/py-pygments-25@${PY_FLAVOR}
-.else
PY_PILLOW= ${PYTHON_PKGNAMEPREFIX}pillow>=7.0.0:graphics/py-pillow@${PY_FLAVOR}
PY_PYGMENTS= ${PYTHON_PKGNAMEPREFIX}pygments>=2.5.1<3:textproc/py-pygments@${PY_FLAVOR}
-.endif
-.if ${PYTHON_REL} < 3400
-PY_ENUM34= ${PYTHON_PKGNAMEPREFIX}enum34>=1.1<2.0:devel/py-enum34@${PY_FLAVOR}
-.else
PY_ENUM34=
-.endif
.if ${PYTHON_VER} != ${PYTHON_DEFAULT}
PY_MERCURIAL= ${PYTHON_PKGNAMEPREFIX}mercurial>=5.5:devel/mercurial@${PY_FLAVOR}
@@ -693,11 +668,6 @@ PLIST_SUB+= PYTHON_INCLUDEDIR=${PYTHONPREFIX_INCLUDEDIR:S;${PREFIX}/;;} \
PYTHON_EXT_SUFFIX=${PYTHON_EXT_SUFFIX} \
PYTHON_VER=${PYTHON_VER} \
PYTHON_VERSION=${PYTHON_VERSION}
-.if ${PYTHON_REL} < 3000
-PLIST_SUB+= PYTHON2="" PYTHON3="@comment "
-.else
-PLIST_SUB+= PYTHON2="@comment " PYTHON3=""
-.endif
_USES_POST+= python
.endif # _INCLUDE_USES_PYTHON_MK
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index 5cfbd3356a73..0aa0ed895bc2 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -28,7 +28,7 @@ _QT5_DISTS= 3d activeqt androidextras base charts connectivity datavis3d \
lottie macextras multimedia networkauth purchasing quick3d quickcontrols \
quickcontrols2 quicktimeline remoteobjects script scxml sensors serialbus \
serialport speech svg tools translations virtualkeyboard wayland \
- webchannel webengine webglplugin websockets webview winextras \
+ webchannel webglplugin websockets webview winextras \
x11extras xmlpatterns
_QT_DISTS= ${_QT${_QT_VER}_DISTS}
@@ -73,12 +73,7 @@ DESTDIRNAME= INSTALL_ROOT
. if ${_QT_VER:M5}
MASTER_SITE_SUBDIR?= official_releases/qt/${_QT_VERSION:R}/${_QT_VERSION}/submodules/
-# www/qt5-webengine hackery: The tarballs of 5.9.5 had a different naming scheme.
-. if ${QT5_VERSION} == "5.9.5"
-DISTNAME= ${_QT_DIST:S,^,qt,:S,$,-opensource-src-${DISTVERSION},}
-. else
DISTNAME= ${_QT_DIST:S,^,qt,:S,$,-everywhere-src-${DISTVERSION},}
-. endif
DISTFILES= ${DISTNAME:S,$,${EXTRACT_SUFX},}
DIST_SUBDIR= KDE/Qt/${_QT_VERSION}
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index 3cf09bd62bae..746abc633a9a 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -142,7 +142,7 @@ _USE_QT5_ONLY= 3d buildtools charts concurrent connectivity \
qdbus qdoc qdoc-data qev quick3d quickcontrols quickcontrols2 \
quicktimeline remoteobjects scxml sensors serialbus serialport speech \
sql-tds uiplugin uitools virtualkeyboard wayland webchannel webglplugin \
- webengine websockets websockets-qml webview widgets x11extras
+ websockets websockets-qml webview widgets x11extras
# Dependency tuples: _LIB should be preferred if possible.
qt-3d_PORT= graphics/${_QT_RELNAME}-3d
@@ -330,9 +330,6 @@ qt-wayland_LIB= libQt${_QT_LIBVER}WaylandClient.so
qt-webchannel_PORT= www/${_QT_RELNAME}-webchannel
qt-webchannel_LIB= libQt${_QT_LIBVER}WebChannel.so
-qt-webengine_PORT= www/${_QT_RELNAME}-webengine
-qt-webengine_LIB= libQt${_QT_LIBVER}WebEngine.so
-
qt-webglplugin_PORT= www/${_QT_RELNAME}-webglplugin
qt-webglplugin_PATH= ${LOCALBASE}/${QT_PLUGINDIR_REL}/platforms/libqwebgl.so
diff --git a/Mk/Uses/scons.mk b/Mk/Uses/scons.mk
index 2c2eaf7a3f0c..b6b63f2bfcc8 100644
--- a/Mk/Uses/scons.mk
+++ b/Mk/Uses/scons.mk
@@ -4,9 +4,8 @@
#
# Feature: scons
# Usage: USES=scons[:ARGS]
-# Valid ARGS: python2 python3
+# Valid ARGS: python3
#
-# python2: Use default python 2.x to run scons
# python3: Use default python 3.x to run scons (default)
#
# MAINTAINER: python@FreeBSD.org
@@ -20,10 +19,6 @@ scons_ARGS= python3
.if ${scons_ARGS} == python3
_SCONS_PYTHON_VER= ${PYTHON3_DEFAULT}
-.elif ${scons_ARGS} == python2
-_SCONS_PYTHON_VER= ${PYTHON2_DEFAULT}
-DEPRECATED?= Uses Python 2.7 version of scons, and Python 2.7 which is EOLed upstream
-EXPIRATION_DATE?= 2020-12-31
.else
IGNORE= Incorrect 'USES+= scons:${scons_ARGS}' usage
.endif
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 84e3fd52e93f..eb2c690f41f5 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -20,8 +20,8 @@ _INCLUDE_BSD_DEFAULT_VERSIONS_MK= yes
LOCALBASE?= /usr/local
.for lang in APACHE BDB COROSYNC EMACS FIREBIRD FORTRAN FPC GCC GHOSTSCRIPT \
- IMAGEMAGICK JAVA JULIA LAZARUS LIBRSVG2 LINUX LLVM LUA MYSQL PERL5 \
- PGSQL PHP PYTHON PYTHON2 PYTHON3 RUBY RUST SAMBA SSL TCLTK VARNISH
+ IMAGEMAGICK JAVA LAZARUS LIBRSVG2 LINUX LLVM LUA MYSQL PERL5 \
+ PGSQL PHP PYTHON PYTHON3 RUBY RUST SAMBA SSL TCLTK VARNISH
.if defined(${lang}_DEFAULT)
ERROR+= "The variable ${lang}_DEFAULT is set and it should only be defined through DEFAULT_VERSIONS+=${lang:tl}=${${lang}_DEFAULT} in /etc/make.conf"
.endif
@@ -71,7 +71,7 @@ LIBRSVG2_DEFAULT?= legacy
.endif
# Possible values: c7
LINUX_DEFAULT?= c7
-# Possible values: 70, 80, 90, 10, 11, -devel (to be used when non-base compiler is required)
+# Possible values: 80, 90, 10, 11, -devel (to be used when non-base compiler is required)
# Please give notice to the Graphics Team (x11@FreeBSD.org) in advance before
# bumping the LLVM version.
LLVM_DEFAULT?= 90
@@ -102,8 +102,6 @@ PGSQL_DEFAULT?= 12
PHP_DEFAULT?= 7.4
# Possible values: 2.7, 3.6, 3.7, 3.8, 3.9
PYTHON_DEFAULT?= 3.7
-# Possible values: 2.7
-PYTHON2_DEFAULT?= 2.7
# Possible values: 3.6, 3.7, 3.8, 3.9
PYTHON3_DEFAULT?= 3.7
# Possible values: 2.5, 2.6, 2.7, 3.0
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index 7202c3bfb40f..d8ed5bd8c30b 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -416,7 +416,6 @@ PTH_DESC?= Threading/multiprocessing via GNU Pth
PULSEAUDIO_DESC?= PulseAudio sound server support
PYMALLOC_DESC?= Use Python's internal malloc()
PYTHON_DESC?= Python bindings or support
-PYTHON2_DESC?= Python 2.x bindings or support
PYTHON3_DESC?= Python 3.x bindings or support
QT5_DESC?= Qt 5 toolkit support
QUICKTIME_DESC?= QuickTime media support
diff --git a/Tools/scripts/checkcats.py b/Tools/scripts/checkcats.py
index c00812c8cc01..4573d2fbc215 100755
--- a/Tools/scripts/checkcats.py
+++ b/Tools/scripts/checkcats.py
@@ -33,10 +33,10 @@ if __name__ == '__main__':
try:
mastercat = categories.split()[0]
except IndexError:
- print '%s: categories list is empty' % dirname
+ print('%s: categories list is empty' % dirname)
continue
mastercat_real = os.path.basename(os.path.dirname(dirname))
if mastercat != mastercat_real:
- print '%s: specified master category `%s\' doesn\'t match real one `%s\'' \
- % (dirname, mastercat, mastercat_real)
+ print('%s: specified master category `%s\' doesn\'t match real one `%s\'' \
+ % (dirname, mastercat, mastercat_real))
diff --git a/Tools/scripts/getpatch b/Tools/scripts/getpatch
index 4799c6aa5a4c..7b4e4f5fd218 100755
--- a/Tools/scripts/getpatch
+++ b/Tools/scripts/getpatch
@@ -37,7 +37,7 @@ import sys
if sys.version_info.major == 3:
import urllib.request as urllib2
else:
- import urllib2
+ import urllib.request, urllib.error, urllib.parse
"""
FreeBSD getpatch handles Gnats and Bugzilla patch attachments
@@ -89,7 +89,7 @@ class GetPatch(object):
url = patch['url']
p = patch['name']
- data = urllib2.urlopen(url, context=self.ssl_context).read()
+ data = urllib.request.urlopen(url, context=self.ssl_context).read()
if self.output_stdout:
sys.stdout.write(data.decode(self.default_locale))
@@ -119,7 +119,7 @@ class GnatsGetPatch(GetPatch):
"{}".format(self.pr))[category == '']
self.out("[+] Fetching patch for pr {}".format(target))
pattern = re.compile(self.REGEX)
- u = urllib2.urlopen("{}{}".format(self.URL, target),
+ u = urllib.request.urlopen("{}{}".format(self.URL, target),
context=self.ssl_context)
data = u.read()
if data is None:
@@ -143,7 +143,7 @@ class BzGetPatch(GetPatch):
GetPatch.__init__(self, pr, category)
def _get_patch_name(self, url):
- data = urllib2.urlopen(url, context=self.ssl_context).read()
+ data = urllib.request.urlopen(url, context=self.ssl_context).read()
match = re.search(self.REGEX, str(data))
if match is None:
return None
@@ -180,7 +180,7 @@ class BzGetPatch(GetPatch):
target = ("{}/{}".format(category, self.pr),
"{}".format(self.pr))[category == '']
self.out("[+] Fetching patch for pr {}".format(target))
- u = urllib2.urlopen("{}{}".format(self.URL_SHOW, self.pr),
+ u = urllib.request.urlopen("{}{}".format(self.URL_SHOW, self.pr),
context=self.ssl_context)
data = u.read()
@@ -193,7 +193,7 @@ class BzGetPatch(GetPatch):
self.out("[-] No patch found")
sys.exit(os.EX_UNAVAILABLE)
- for url, file_name in patch_urls.items():
+ for url, file_name in list(patch_urls.items()):
self.add_patch(url, file_name)
diff --git a/Tools/scripts/patchtool.py b/Tools/scripts/patchtool.py
index 201b64bfbb96..1ddf8cb5e24c 100755
--- a/Tools/scripts/patchtool.py
+++ b/Tools/scripts/patchtool.py
@@ -33,7 +33,7 @@ if sys.version_info < (3,):
def isStr(obj):
try:
- return isinstance(obj, basestring)
+ return isinstance(obj, str)
except NameError:
return isinstance(obj, str)
@@ -277,7 +277,7 @@ def query_yn(message, default = False):
return False
elif reply == '' and default in (True, False):
return default
- print('Wrong answer "%s", please try again' % reply)
+ print(('Wrong answer "%s", please try again' % reply))
return default
@@ -467,13 +467,13 @@ class PatchesCollection:
def lookupbytarget(self, wrksrc, relpath):
wrksrc = os.path.abspath(wrksrc)
- for patch in self.patches.values():
+ for patch in list(self.patches.values()):
if wrksrc == patch.wrksrc and relpath == patch.plus3file:
return patch
return None
def getpatchobjs(self):
- return self.patches.values()
+ return list(self.patches.values())
#
diff --git a/astro/Makefile b/astro/Makefile
index b7c60d2af8dd..9f2d92e43a7b 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -92,7 +92,6 @@
SUBDIR += py-ro
SUBDIR += py-spacetrack
SUBDIR += pyweather
- SUBDIR += qmapshack
SUBDIR += readosm
SUBDIR += rmap
SUBDIR += roadmap
diff --git a/astro/gpsbabel/Makefile b/astro/gpsbabel/Makefile
index 6d2a0d9d4b96..bae38b4468c0 100644
--- a/astro/gpsbabel/Makefile
+++ b/astro/gpsbabel/Makefile
@@ -20,23 +20,13 @@ CONFLICTS= gpsbabel14-[0-9]*
USE_GITHUB= yes
GNU_CONFIGURE= yes
-OPTIONS_DEFINE= GUI
OPTIONS_SUB= yes
-GUI_USES= gl
-GUI_USE= GL=gl \
- QT=declarative,gui,location,network,printsupport,webchannel \
- QT=webengine,widgets,xml,buildtools_build,linguisttools_build
-GUI_ALL_TARGET= gui
-GUI_VARS= MAKE_JOBS_UNSAFE=yes
-
CONFIGURE_ENV= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
MAKE_ENV= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
do-build:
(cd ${WRKSRC}; ${CONFIGURE_ENV} ${CONFIGURE_CMD}; ${MAKE_ENV} ${GMAKE})
-do-build-GUI-on:
- (cd ${WRKSRC}/gui; ${QMAKE} USE_GUI=qt5; ${LRELEASE} *.ts; ${GMAKE})
post-patch:
@${REINPLACE_CMD} '/langPath_ = / \
@@ -47,14 +37,4 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gpsbabel ${STAGEDIR}${PREFIX}/bin/
-do-install-GUI-on:
- ${INSTALL_PROGRAM} ${WRKSRC}/gui/objects/gpsbabelfe \
- ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/gui/gpsbabel.desktop \
- ${STAGEDIR}${PREFIX}/share/applications/
- ${MKDIR} ${STAGEDIR}${DATADIR}/translations
- ${INSTALL_DATA} ${WRKSRC}/gui/*.qm ${STAGEDIR}${DATADIR}/translations/
- ${INSTALL_DATA} ${WRKSRC}/gui/images/appicon.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/gpsbabel.png
-
.include <bsd.port.mk>
diff --git a/astro/gpsbabel/pkg-plist b/astro/gpsbabel/pkg-plist
index 461eeea22ba9..eaa15cceb5dd 100644
--- a/astro/gpsbabel/pkg-plist
+++ b/astro/gpsbabel/pkg-plist
@@ -1,10 +1 @@
bin/gpsbabel
-%%GUI%%bin/gpsbabelfe
-%%GUI%%share/applications/gpsbabel.desktop
-%%GUI%%%%DATADIR%%/translations/gpsbabelfe_de.qm
-%%GUI%%%%DATADIR%%/translations/gpsbabelfe_es.qm
-%%GUI%%%%DATADIR%%/translations/gpsbabelfe_fr.qm
-%%GUI%%%%DATADIR%%/translations/gpsbabelfe_hu.qm
-%%GUI%%%%DATADIR%%/translations/gpsbabelfe_it.qm
-%%GUI%%%%DATADIR%%/translations/gpsbabelfe_ru.qm
-%%GUI%%share/pixmaps/gpsbabel.png
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index 9078ba41597d..d531fcdb5f68 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -26,20 +26,15 @@ USE_LDCONFIG= yes
MAKE_ENV= XDG_CONFIG_HOME=/dev/null
# We have to set QT_IMPORTS_PATH, as it does not get picked up
CMAKE_ARGS= -DMOBILE:BOOL=FALSE \
- -DQT_IMPORTS_DIR:PATH=${QT_IMPORTDIR}
+ -DQT_IMPORTS_DIR:PATH=${QT_IMPORTDIR} \
+ CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
-OPTIONS_DEFINE= GPS DOCS WEBENGINE
+OPTIONS_DEFINE= GPS DOCS
OPTIONS_DEFAULT=GPS
-OPTIONS_DEFAULT_amd64= WEBENGINE
-OPTIONS_DEFAULT_i386= WEBENGINE
OPTIONS_SUB= yes
GPS_DESC= Support for GPS position provider
GPS_LIB_DEPENDS= libgps.so:astro/gpsd
GPS_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_libgps
-WEBENGINE_DESC= Add dependency on qt5-webengine
-WEBENGINE_USE= QT=webengine
-WEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
-
.include <bsd.port.mk>
diff --git a/astro/marble/pkg-plist b/astro/marble/pkg-plist
index df1e29d29009..47ea13de996e 100644
--- a/astro/marble/pkg-plist
+++ b/astro/marble/pkg-plist
@@ -106,12 +106,11 @@ include/marble/MarbleMap.h
include/marble/MarbleMath.h
include/marble/MarbleModel.h
include/marble/MarbleNavigator.h
-%%WEBENGINE%%include/marble/MarbleWebView.h
include/marble/MarbleWidget.h
include/marble/MarbleWidgetInputHandler.h
include/marble/MarbleWidgetPopupMenu.h
-%%NO_WEBENGINE%%include/marble/NullMarbleWebView.h
-%%NO_WEBENGINE%%include/marble/NullTinyWebBrowser.h
+include/marble/NullMarbleWebView.h
+include/marble/NullTinyWebBrowser.h
include/marble/OsmcSymbol.h
include/marble/ParseRunnerPlugin.h
include/marble/ParsingRunner.h
@@ -156,7 +155,6 @@ include/marble/TileCreator.h
include/marble/TileCreatorDialog.h
include/marble/TileId.h
include/marble/TileLevelRangeWidget.h
-%%WEBENGINE%%include/marble/TinyWebBrowser.h
include/marble/TourControlEditWidget.h
include/marble/TourItemDelegate.h
include/marble/TourPlayback.h
@@ -220,12 +218,10 @@ lib/marble/plugins/NominatimReverseGeocodingPlugin.so
lib/marble/plugins/NominatimSearchPlugin.so
lib/marble/plugins/NotesPlugin.so
lib/marble/plugins/OSRMPlugin.so
-%%WEBENGINE%%lib/marble/plugins/OpenDesktopPlugin.so
lib/marble/plugins/OpenLocationCodeSearchPlugin.so
lib/marble/plugins/OpenRouteServicePlugin.so
lib/marble/plugins/OsmPlugin.so
lib/marble/plugins/OverviewMap.so
-%%WEBENGINE%%lib/marble/plugins/Photo.so
lib/marble/plugins/Pn2Plugin.so
lib/marble/plugins/PntPlugin.so
lib/marble/plugins/PositionMarker.so
@@ -238,8 +234,6 @@ lib/marble/plugins/SatellitesPlugin.so
lib/marble/plugins/Speedometer.so
lib/marble/plugins/StarsPlugin.so
lib/marble/plugins/SunPlugin.so
-%%WEBENGINE%%lib/marble/plugins/Weather.so
-%%WEBENGINE%%lib/marble/plugins/Wikipedia.so
lib/marble/plugins/YoursPlugin.so
lib/plugins/designer/LatLonEditPlugin.so
lib/plugins/designer/MarbleNavigatorPlugin.so
diff --git a/audio/Makefile b/audio/Makefile
index 6c62fa9c89ed..ab7d6c041d35 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -81,7 +81,6 @@
SUBDIR += cdplay
SUBDIR += celt
SUBDIR += checkmate
- SUBDIR += cheesecutter
SUBDIR += chordpack
SUBDIR += chromaprint
SUBDIR += clementine-player
@@ -291,7 +290,6 @@
SUBDIR += guitarix-lv2
SUBDIR += guspat
SUBDIR += gvolwheel
- SUBDIR += gxmms2
SUBDIR += gxplugins-lv2
SUBDIR += harp
SUBDIR += headsetcontrol
@@ -451,7 +449,6 @@
SUBDIR += lv2lint
SUBDIR += lv2proc
SUBDIR += lvtk
- SUBDIR += lxmusic
SUBDIR += mac
SUBDIR += madfufw
SUBDIR += madplay
@@ -843,7 +840,6 @@
SUBDIR += xmix
SUBDIR += xmixer
SUBDIR += xmmix
- SUBDIR += xmms2
SUBDIR += xmp
SUBDIR += xmradio
SUBDIR += xoscope
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index 24488dd388a6..4dccc214ea78 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -42,16 +42,15 @@ KDE_INVENT= 3e11ccdd1417e70486eaaa84d8475182eec44c20 multimedia
CONFIGURE_ENV= MYSQL_DIR=${LOCALBASE}
SHEBANG_FILES= src/kconf_update/amarok-2.4.1-tokens_syntax_update.pl
-CMAKE_ARGS= -DOPENSSL_ROOT_DIR=${OPENSSLBASE}
+CMAKE_ARGS= -DOPENSSL_ROOT_DIR=${OPENSSLBASE} \
+ CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine
CMAKE_ON= WITH_DESKTOP_UI
CMAKE_OFF= WITH_FFmpeg
BROKEN_sparc64= does not build (GCC-related error)
-OPTIONS_DEFINE= IPOD MP3TUNES MTP QTWEBENGINE
+OPTIONS_DEFINE= IPOD MP3TUNES MTP
OPTIONS_DEFAULT= IPOD MP3TUNES MTP
-OPTIONS_DEFAULT_amd64= QTWEBENGINE
-OPTIONS_DEFAULT_i386= QTWEBENGINE
OPTIONS_SUB= yes
IPOD_DESC= Apple iPod support
@@ -75,10 +74,6 @@ MP3TUNES_CMAKE_BOOL_OFF= WITH_Libgcrypt
MTP_LIB_DEPENDS= libmtp.so:multimedia/libmtp
MTP_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Mtp
-QTWEBENGINE_DESC= Add dependency on qt5-webengine
-QTWEBENGINE_USE= qt=webengine
-QTWEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
${WRKSRC}/cmake/modules/FindLoudmouth.cmake
diff --git a/audio/amarok/pkg-plist b/audio/amarok/pkg-plist
index 4ab3bfeec210..dd193756e2ce 100644
--- a/audio/amarok/pkg-plist
+++ b/audio/amarok/pkg-plist
@@ -58,12 +58,8 @@ lib/libampache_account_login.so
%%QT_QMLDIR%%/org/kde/amarok/qml/AppletHeader.qml
%%QT_QMLDIR%%/org/kde/amarok/qml/libqml_plugin.so
%%QT_QMLDIR%%/org/kde/amarok/qml/qmldir
-%%QTWEBENGINE%%%%QT_QMLDIR%%/org/kde/amarok/wikipedia/libamarok_context_applet_wikipedia.so
-%%QTWEBENGINE%%%%QT_QMLDIR%%/org/kde/amarok/wikipedia/qmldir
%%DATADIR%%/data/DefaultPlaylistLayouts.xml
%%DATADIR%%/data/InfoParserLoading.html
-%%QTWEBENGINE%%%%DATADIR%%/data/WikipediaCustomStyle.css
-%%QTWEBENGINE%%%%DATADIR%%/data/bullet.gif
%%DATADIR%%/data/first_run_jingle.ogg
%%DATADIR%%/data/hover_info_template.html
%%DATADIR%%/data/podcast_directory.opml
@@ -662,8 +658,6 @@ share/kpackage/amarok/org.kde.amarok.lyrics/contents.rcc
share/kpackage/amarok/org.kde.amarok.lyrics/metadata.json
share/kpackage/amarok/org.kde.amarok.photos/contents.rcc
share/kpackage/amarok/org.kde.amarok.photos/metadata.json
-%%QTWEBENGINE%%share/kpackage/amarok/org.kde.amarok.wikipedia/contents.rcc
-%%QTWEBENGINE%%share/kpackage/amarok/org.kde.amarok.wikipedia/metadata.json
share/kpackage/genericqml/org.kde.amarok.context/contents.rcc
share/kpackage/genericqml/org.kde.amarok.context/metadata.json
share/kservices5/ServiceMenus/amarok_append.desktop
diff --git a/audio/musescore/Makefile b/audio/musescore/Makefile
index bcda601ea2f9..9e93bfc59448 100644
--- a/audio/musescore/Makefile
+++ b/audio/musescore/Makefile
@@ -42,14 +42,8 @@ CMAKE_OFF= BUILD_PORTMIDI BUILD_PCH MSCORE_UNSTABLE
CMAKE_ON= USE_SYSTEM_FREETYPE
CMAKE_BUILD_TYPE= release
-# WebEngine is only available on i386/amd64, amd ppc64 starting FreeBSD 13.0.
-# If enabled on arches that don't have WebEngine, the build breaks.
-OPTIONS_DEFINE= ALSA JACK PORTAUDIO PULSEAUDIO WEBENGINE
+OPTIONS_DEFINE= ALSA JACK PORTAUDIO PULSEAUDIO
OPTIONS_DEFAULT= PORTAUDIO
-OPTIONS_DEFAULT_amd64= WEBENGINE
-OPTIONS_DEFAULT_i386= WEBENGINE
-
-WEBENGINE_DESC= Use WebEngine in the welcome panel
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CMAKE_BOOL= BUILD_ALSA
@@ -59,8 +53,6 @@ PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
PORTAUDIO_CMAKE_BOOL= BUILD_PORTAUDIO
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CMAKE_BOOL= BUILD_PULSEAUDIO
-WEBENGINE_USE= qt=webengine
-WEBENGINE_CMAKE_BOOL= BUILD_WEBENGINE
.include <bsd.port.pre.mk>
diff --git a/audio/supercollider/Makefile b/audio/supercollider/Makefile
index 840d5c1d5c0d..1c94ecc3a2ec 100644
--- a/audio/supercollider/Makefile
+++ b/audio/supercollider/Makefile
@@ -33,7 +33,8 @@ CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE}/lib/qt5 \
-DLIBSCSYNTH=ON \
-DSYSTEM_BOOST=ON \
-DSYSTEM_YAMLCPP=ON \
- -DSC_ABLETON_LINK=OFF
+ -DSC_ABLETON_LINK=OFF \
+ -DSC_USE_QTWEBENGINE:BOOL=FALSE
DESKTOP_ENTRIES="SuperCollider IDE" "" "${LOCALBASE}/share/pixmaps/sc_ide.svg" \
"scide" "" false
@@ -54,9 +55,7 @@ SUPERNOVA_CMAKE_BOOL= SUPERNOVA
.include <bsd.port.pre.mk>
.if ! ${ARCH} == amd64 && ! ${ARCH} == i386
-CMAKE_ARGS+= -DSSE:BOOL=FALSE -DSSE2:BOOL=FALSE -DSC_USE_QTWEBENGINE:BOOL=FALSE
-.else
-USE_QT+= webengine
+CMAKE_ARGS+= -DSSE:BOOL=FALSE -DSSE2:BOOL=FALSE
.endif
.include <bsd.port.post.mk>
diff --git a/biology/Makefile b/biology/Makefile
index 3aa380367185..f67b8161886c 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -138,8 +138,6 @@
SUBDIR += py-loompy
SUBDIR += py-macs2
SUBDIR += py-multiqc
- SUBDIR += py-orange3-bioinformatics
- SUBDIR += py-orange3-single-cell
SUBDIR += py-pandas-charm
SUBDIR += py-pyfaidx
SUBDIR += py-pysam
diff --git a/chinese/Makefile b/chinese/Makefile
index 465da7bcc5b1..7edd8e62c6b0 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -34,7 +34,6 @@
SUBDIR += fcitx-configtool
SUBDIR += fcitx-libpinyin
SUBDIR += fcitx-rime
- SUBDIR += fcitx-sunpinyin
SUBDIR += fcitx-table-extra
SUBDIR += fcitx-ui-light
SUBDIR += fcitx5-chewing
@@ -130,7 +129,6 @@
SUBDIR += sourcehansans-tc-otf
SUBDIR += sourcehanserif-sc-otf
SUBDIR += sourcehanserif-tc-otf
- SUBDIR += sunpinyin
SUBDIR += taipeisanstc
SUBDIR += tin
SUBDIR += tintin++
diff --git a/chinese/fcitx-libpinyin/Makefile b/chinese/fcitx-libpinyin/Makefile
index 5eaadd726179..869be35e6040 100644
--- a/chinese/fcitx-libpinyin/Makefile
+++ b/chinese/fcitx-libpinyin/Makefile
@@ -27,21 +27,7 @@ INSTALLS_ICONS= yes
_MODEL_VER= 20161206
-OPTIONS_DEFINE= QT5
-OPTIONS_DEFAULT=QT5
-QT5_DESC= Enable Qtr for dictmanager
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MQT5}
-USES+= qt:5
-USE_QT= qmake_build gui webengine buildtools_build
-USE_LDCONFIG= ${PREFIX}/lib/fcitx/qt
-PLIST_SUB+= QT5=""
-.else
CMAKE_ARGS+= -DENABLE_QT=OFF
-PLIST_SUB+= QT5="@comment "
-.endif
post-patch:
@${CP} ${_DISTDIR}/model.text.${_MODEL_VER}.tar.gz ${WRKSRC}/data/.
diff --git a/chinese/fcitx-libpinyin/pkg-plist b/chinese/fcitx-libpinyin/pkg-plist
index a871227f3375..6dd302628eb8 100644
--- a/chinese/fcitx-libpinyin/pkg-plist
+++ b/chinese/fcitx-libpinyin/pkg-plist
@@ -1,5 +1,4 @@
lib/fcitx/fcitx-libpinyin.so
-%%QT5%%lib/fcitx/qt/libfcitx-libpinyin-dictmanager.so
share/fcitx/addon/fcitx-libpinyin.conf
share/fcitx/configdesc/fcitx-libpinyin.desc
share/fcitx/imicon/bopomofo.png
diff --git a/comms/hamlib/pkg-plist b/comms/hamlib/pkg-plist
index 33726f2a8773..5bc817d294a9 100644
--- a/comms/hamlib/pkg-plist
+++ b/comms/hamlib/pkg-plist
@@ -51,8 +51,7 @@ share/aclocal/hamlib.m4
%%PORTDOCS%%%%DOCSDIR%%/README.developer
%%PORTDOCS%%%%DOCSDIR%%/README.win32
%%PORTDOCS%%%%DOCSDIR%%/THANKS
-%%PYTHON2%%%%PORTDOCS%%%%DOCSDIR%%/examples/pytest.py
-%%PYTHON3%%%%PORTDOCS%%%%DOCSDIR%%/examples/py3test.py
+%%PORTDOCS%%%%DOCSDIR%%/examples/py3test.py
%%PORTDOCS%%%%DOCSDIR%%/examples/perltest.pl
%%PORTDOCS%%%%DOCSDIR%%/examples/tcltest.tcl
%%PORTDOCS%%%%DOCSDIR%%/html/Hamlib_design.png
diff --git a/converters/py-webencodings/Makefile b/converters/py-webencodings/Makefile
index f8c3b035db27..4b0df133bb1d 100644
--- a/converters/py-webencodings/Makefile
+++ b/converters/py-webencodings/Makefile
@@ -11,7 +11,7 @@ COMMENT= Character encoding aliases for legacy web content
LICENSE= BSD3CLAUSE
-USES= python:2.7+
+USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/databases/Makefile b/databases/Makefile
index a149212ee649..9c652f7a9222 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -41,8 +41,6 @@
SUBDIR += cegobridge
SUBDIR += clickhouse
SUBDIR += cockroach
- SUBDIR += couchdb2
- SUBDIR += couchdb3
SUBDIR += courier-authlib-mysql
SUBDIR += courier-authlib-pgsql
SUBDIR += courier-authlib-sqlite
@@ -244,7 +242,6 @@
SUBDIR += p5-Amazon-SimpleDB
SUBDIR += p5-Amon2-DBI
SUBDIR += p5-AnyEvent-BDB
- SUBDIR += p5-AnyEvent-CouchDB
SUBDIR += p5-AnyEvent-DBD-Pg
SUBDIR += p5-AnyEvent-Memcached
SUBDIR += p5-AnyEvent-Redis
@@ -829,8 +826,6 @@
SUBDIR += py-xapian
SUBDIR += py-zodbpickle
SUBDIR += pymongo
- SUBDIR += pypy-gdbm
- SUBDIR += pypy-sqlite3
SUBDIR += qdbm
SUBDIR += qdbm-plus
SUBDIR += qof
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index 8084c479c92e..2cf206bb8b25 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -24,16 +24,9 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
widgetsaddons windowsystem xmlgui
USE_QT= concurrent core dbus declarative gui location network \
printsupport webchannel widgets xml xmlpatterns \
- buildtools_build qmake_build
+ buildtools_build qmake_build webkit
USE_LDCONFIG= yes
-OPTIONS_DEFINE= WEBENGINE
-OPTIONS_DEFAULT_amd64= WEBENGINE
-OPTIONS_DEFAULT_i386= WEBENGINE
-
-WEBENGINE_DESC= Add dependency on qt5-webengine
-WEBENGINE_USE= QT=webengine
-WEBENGINE_USE_OFF= QT=webkit
-WEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
+CMAKE_ARGS+= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets:BOOL=true
.include <bsd.port.mk>
diff --git a/databases/postgresql10-server/pkg-plist-plpython b/databases/postgresql10-server/pkg-plist-plpython
index 592925659278..4883fd4eec2a 100644
--- a/databases/postgresql10-server/pkg-plist-plpython
+++ b/databases/postgresql10-server/pkg-plist-plpython
@@ -1,17 +1,10 @@
include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
%%DOCSDIR%%/README-plpython
-%%PYTHON2%%lib/postgresql/plpython2.so
-%%PYTHON3%%lib/postgresql/plpython3.so
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u.control
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u.control
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu.control
+lib/postgresql/plpython3.so
+%%DATADIR%%/extension/plpython3u--1.0.sql
+%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
+%%DATADIR%%/extension/plpython3u.control
lib/postgresql/hstore_plpython3.so
lib/postgresql/ltree_plpython3.so
%%DATADIR%%/extension/hstore_plpython2u--1.0.sql
diff --git a/databases/postgresql11-server/pkg-plist-plpython b/databases/postgresql11-server/pkg-plist-plpython
index 8ecdbbea15a3..17de39cb5cef 100644
--- a/databases/postgresql11-server/pkg-plist-plpython
+++ b/databases/postgresql11-server/pkg-plist-plpython
@@ -13,17 +13,10 @@ include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
lib/postgresql/pgxs/src/pl/plpython/regress-python3-mangle.mk
%%DOCSDIR%%/README-plpython
-%%PYTHON2%%lib/postgresql/plpython2.so
-%%PYTHON3%%lib/postgresql/plpython3.so
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u.control
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u.control
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu.control
+lib/postgresql/plpython3.so
+%%DATADIR%%/extension/plpython3u--1.0.sql
+%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
+%%DATADIR%%/extension/plpython3u.control
lib/postgresql/hstore_plpython3.so
lib/postgresql/jsonb_plpython3.so
lib/postgresql/ltree_plpython3.so
diff --git a/databases/postgresql12-server/pkg-plist-plpython b/databases/postgresql12-server/pkg-plist-plpython
index 8ecdbbea15a3..17de39cb5cef 100644
--- a/databases/postgresql12-server/pkg-plist-plpython
+++ b/databases/postgresql12-server/pkg-plist-plpython
@@ -13,17 +13,10 @@ include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
lib/postgresql/pgxs/src/pl/plpython/regress-python3-mangle.mk
%%DOCSDIR%%/README-plpython
-%%PYTHON2%%lib/postgresql/plpython2.so
-%%PYTHON3%%lib/postgresql/plpython3.so
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u.control
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u.control
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu.control
+lib/postgresql/plpython3.so
+%%DATADIR%%/extension/plpython3u--1.0.sql
+%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
+%%DATADIR%%/extension/plpython3u.control
lib/postgresql/hstore_plpython3.so
lib/postgresql/jsonb_plpython3.so
lib/postgresql/ltree_plpython3.so
diff --git a/databases/postgresql13-server/pkg-plist-plpython b/databases/postgresql13-server/pkg-plist-plpython
index c7e8217d6332..1609ef7150b7 100644
--- a/databases/postgresql13-server/pkg-plist-plpython
+++ b/databases/postgresql13-server/pkg-plist-plpython
@@ -13,14 +13,9 @@ include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
lib/postgresql/pgxs/src/pl/plpython/regress-python3-mangle.mk
%%DOCSDIR%%/README-plpython
-%%PYTHON2%%lib/postgresql/plpython2.so
-%%PYTHON3%%lib/postgresql/plpython3.so
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u.control
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u.control
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu.control
+lib/postgresql/plpython3.so
+%%DATADIR%%/extension/plpython3u--1.0.sql
+%%DATADIR%%/extension/plpython3u.control
lib/postgresql/hstore_plpython3.so
lib/postgresql/jsonb_plpython3.so
lib/postgresql/ltree_plpython3.so
diff --git a/databases/postgresql95-server/pkg-plist-plpython b/databases/postgresql95-server/pkg-plist-plpython
index 592925659278..4883fd4eec2a 100644
--- a/databases/postgresql95-server/pkg-plist-plpython
+++ b/databases/postgresql95-server/pkg-plist-plpython
@@ -1,17 +1,10 @@
include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
%%DOCSDIR%%/README-plpython
-%%PYTHON2%%lib/postgresql/plpython2.so
-%%PYTHON3%%lib/postgresql/plpython3.so
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u.control
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u.control
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu.control
+lib/postgresql/plpython3.so
+%%DATADIR%%/extension/plpython3u--1.0.sql
+%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
+%%DATADIR%%/extension/plpython3u.control
lib/postgresql/hstore_plpython3.so
lib/postgresql/ltree_plpython3.so
%%DATADIR%%/extension/hstore_plpython2u--1.0.sql
diff --git a/databases/postgresql96-server/pkg-plist-plpython b/databases/postgresql96-server/pkg-plist-plpython
index 592925659278..4883fd4eec2a 100644
--- a/databases/postgresql96-server/pkg-plist-plpython
+++ b/databases/postgresql96-server/pkg-plist-plpython
@@ -1,17 +1,10 @@
include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
%%DOCSDIR%%/README-plpython
-%%PYTHON2%%lib/postgresql/plpython2.so
-%%PYTHON3%%lib/postgresql/plpython3.so
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpython2u.control
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
-%%PYTHON3%%%%DATADIR%%/extension/plpython3u.control
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu--unpackaged--1.0.sql
-%%PYTHON2%%%%DATADIR%%/extension/plpythonu.control
+lib/postgresql/plpython3.so
+%%DATADIR%%/extension/plpython3u--1.0.sql
+%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
+%%DATADIR%%/extension/plpython3u.control
lib/postgresql/hstore_plpython3.so
lib/postgresql/ltree_plpython3.so
%%DATADIR%%/extension/hstore_plpython2u--1.0.sql
diff --git a/databases/py-sqlite3/Makefile b/databases/py-sqlite3/Makefile
index e113296d6d03..5284ac1d11bb 100644
--- a/databases/py-sqlite3/Makefile
+++ b/databases/py-sqlite3/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libsqlite3.so:databases/sqlite3
PORTSCOUT= ignore:1
-USES= compiler:c11 python:2.7+ tar:xz
+USES= compiler:c11 python tar:xz
USE_PYTHON= autoplist distutils allflavors
DISTINFO_FILE= ${PORTSDIR}/lang/python${PYTHON_SUFFIX}/distinfo
@@ -28,16 +28,10 @@ WRKSRC= ${WRKDIR}/Python-${PORTVERSION}/Modules
PYDISTUTILS_INSTALLARGS+= --install-lib ${PYTHON_LIBDIR}/lib-dynload
-.include <bsd.port.pre.mk>
-
post-extract:
-.if ${PYTHON_REL} < 3000
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}
-.else
@${CP} ${FILESDIR}/setup3.py ${WRKSRC}/setup.py
-.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_LIBDIR}/lib-dynload/_sqlite3*.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/py-xapian/pkg-plist b/databases/py-xapian/pkg-plist
index a5027b4685bc..1fa08a52ca13 100644
--- a/databases/py-xapian/pkg-plist
+++ b/databases/py-xapian/pkg-plist
@@ -1,7 +1,5 @@
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/xapian/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/xapian/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/xapian/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/xapian/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/xapian/__init__.py
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/xapian/__init__.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/xapian/__init__.pyo
%%PYTHON_SITELIBDIR%%/xapian/_xapian.a
%%PYTHON_SITELIBDIR%%/xapian/_xapian.so
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 961940822c9a..2ac2aeee94ab 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -4,10 +4,6 @@
COMMENT = Things that used to be on the desktop before computers were invented
SUBDIR += affiche
- SUBDIR += akonadi-calendar-tools
- SUBDIR += akonadi-import-wizard
- SUBDIR += akonadiconsole
- SUBDIR += akregator
SUBDIR += alarm-clock-applet
SUBDIR += anydesk
SUBDIR += appwrapper
@@ -28,7 +24,6 @@
SUBDIR += calcurse
SUBDIR += calendar
SUBDIR += calendar-data
- SUBDIR += calibre
SUBDIR += calindori
SUBDIR += cartotheque
SUBDIR += cfiles
@@ -101,7 +96,6 @@
SUBDIR += go-for-it
SUBDIR += goesimage
SUBDIR += gpicker
- SUBDIR += grantlee-editor
SUBDIR += grantleetheme
SUBDIR += griffith
SUBDIR += growl-for-linux
@@ -126,22 +120,12 @@
SUBDIR += jjclient
SUBDIR += jlj
SUBDIR += just
- SUBDIR += kaddressbook
- SUBDIR += kalarm
SUBDIR += kcharselect
SUBDIR += kchmviewer
SUBDIR += kdeconnect-kde
- SUBDIR += kdepim
- SUBDIR += kdepim-addons
- SUBDIR += kdepim-runtime
SUBDIR += keditbookmarks
SUBDIR += kfind
- SUBDIR += kmail
- SUBDIR += kmail-account-wizard
- SUBDIR += knotes
SUBDIR += kongress
- SUBDIR += kontact
- SUBDIR += korganizer
SUBDIR += kruler
SUBDIR += ktimetracker
SUBDIR += kuserfeedback
@@ -162,7 +146,6 @@
SUBDIR += mate-indicator-applet
SUBDIR += mate-notification-daemon
SUBDIR += mate-utils
- SUBDIR += mbox-importer
SUBDIR += mencal
SUBDIR += menumaker
SUBDIR += meteo
@@ -171,7 +154,6 @@
SUBDIR += myitcrm
SUBDIR += nautilus-actions
SUBDIR += nautilus-sendto
- SUBDIR += nextcloudclient
SUBDIR += note
SUBDIR += noti
SUBDIR += notification-daemon
@@ -186,8 +168,6 @@
SUBDIR += peaclock
SUBDIR += pet
SUBDIR += phpicalendar
- SUBDIR += pim-data-exporter
- SUBDIR += pim-sieve-editor
SUBDIR += pinot
SUBDIR += plan
SUBDIR += plans
@@ -218,7 +198,6 @@
SUBDIR += rubrica
SUBDIR += rubygem-shellplay
SUBDIR += rubygem-taskjuggler
- SUBDIR += semantik
SUBDIR += showdown
SUBDIR += shutter
SUBDIR += simpleagenda
@@ -265,7 +244,6 @@
SUBDIR += xpostitPlus
SUBDIR += xwrits
SUBDIR += ydotool
- SUBDIR += zanshin
SUBDIR += zim
SUBDIR += znotes
SUBDIR += zorro
diff --git a/deskutils/syncthingtray/Makefile b/deskutils/syncthingtray/Makefile
index e696812d3881..53b6feea52f0 100644
--- a/deskutils/syncthingtray/Makefile
+++ b/deskutils/syncthingtray/Makefile
@@ -28,8 +28,9 @@ USE_KDE= plasma-framework
USE_QT= concurrent core dbus declarative gui location network \
printsupport qdbus quickcontrols2 svg webchannel \
widgets x11extras buildtools_build doc_build linguist_build \
- qmake_build
+ qmake_build webkit
+CMAKE_ARGS= -DWEBVIEW_PROVIDER=webkit
CMAKE_OFF= USE_STANDARD_FILESYSTEM
CONFIGURE_WRKSRC= ${WRKDIR}
@@ -37,15 +38,6 @@ BUILD_WRKSRC= ${WRKDIR}
INSTALL_WRKSRC= ${WRKDIR}
CMAKE_SOURCE_PATH= ${WRKDIR}/subdirs/syncthingtray
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64 || ${ARCH} == i386
-USE_QT+= webengine
-.else
-CMAKE_ARGS+= -DWEBVIEW_PROVIDER=webkit
-USE_QT+= webkit
-.endif
-
post-install:
${RM} -r \
${STAGEDIR}${PREFIX}/include/c++utilities \
@@ -75,4 +67,4 @@ post-install:
${STAGEDIR}${QT_PLUGINDIR} \
${STAGEDIR}${QT_LIBDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/Makefile b/devel/Makefile
index dd615a0f6d86..95ac1b2c7152 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -383,7 +383,6 @@
SUBDIR += configkit
SUBDIR += cons
SUBDIR += cons-test
- SUBDIR += containers
SUBDIR += cook
SUBDIR += corrade
SUBDIR += courier-unicode
@@ -456,7 +455,6 @@
SUBDIR += cxxtest
SUBDIR += cxxtools
SUBDIR += d-feet
- SUBDIR += d-scanner
SUBDIR += darts
SUBDIR += dash.el
SUBDIR += datadraw
@@ -468,8 +466,6 @@
SUBDIR += dbus-sharp
SUBDIR += dbus-sharp-glib
SUBDIR += dbus-tcl
- SUBDIR += dcd-client
- SUBDIR += dcd-server
SUBDIR += dconf
SUBDIR += dconf-editor
SUBDIR += debugedit
@@ -480,8 +476,6 @@
SUBDIR += delve
SUBDIR += dep
SUBDIR += deployer
- SUBDIR += derelict-sdl2
- SUBDIR += derelict-util
SUBDIR += desed
SUBDIR += desktop-file-utils
SUBDIR += dev86
@@ -497,7 +491,6 @@
SUBDIR += distel
SUBDIR += distorm
SUBDIR += djgpp-binutils
- SUBDIR += dlib
SUBDIR += dmake
SUBDIR += dmalloc
SUBDIR += dmlc-core
@@ -512,9 +505,7 @@
SUBDIR += dparser
SUBDIR += dragon
SUBDIR += ds2
- SUBDIR += dsymbol
SUBDIR += dtool
- SUBDIR += dub
SUBDIR += dulwich
SUBDIR += dupl
SUBDIR += duplo
@@ -537,7 +528,6 @@
SUBDIR += efl
SUBDIR += egypt
SUBDIR += eiffelstudio
- SUBDIR += electron11
SUBDIR += elf
SUBDIR += elfio
SUBDIR += elfkickers
@@ -590,7 +580,6 @@
SUBDIR += entt
SUBDIR += epl.el
SUBDIR += epm
- SUBDIR += eric6
SUBDIR += eris
SUBDIR += erlang-backoff
SUBDIR += erlang-bbmustache
@@ -630,7 +619,6 @@
SUBDIR += erlang-ssl_verify_fun
SUBDIR += erlang-syslog
SUBDIR += erlang-unicode_util_compat
- SUBDIR += es-eric6
SUBDIR += estd
SUBDIR += etcd
SUBDIR += etcd31
@@ -655,8 +643,6 @@
SUBDIR += fire-hpp
SUBDIR += firmware-utils
SUBDIR += fistgen
- SUBDIR += flang
- SUBDIR += flang-clang
SUBDIR += flatbuffers
SUBDIR += flatcc
SUBDIR += flatzebra
@@ -724,7 +710,6 @@
SUBDIR += ga
SUBDIR += gaa
SUBDIR += gamin
- SUBDIR += gammaray
SUBDIR += gauche-readline
SUBDIR += gaul
SUBDIR += gb
@@ -841,7 +826,6 @@
SUBDIR += glui
SUBDIR += gmake
SUBDIR += gn
- SUBDIR += gnatpython
SUBDIR += gnome-builder
SUBDIR += gnome-common
SUBDIR += gnome-vfs
@@ -862,8 +846,6 @@
SUBDIR += gocheese
SUBDIR += godot
SUBDIR += godot-tools
- SUBDIR += godot2
- SUBDIR += godot2-tools
SUBDIR += goffice
SUBDIR += gogs
SUBDIR += golangci-lint
@@ -917,7 +899,6 @@
SUBDIR += heimdall
SUBDIR += hexcompare
SUBDIR += hexd
- SUBDIR += hgreviewboard
SUBDIR += hgsvn
SUBDIR += hhdate
SUBDIR += highlighterkit
@@ -959,7 +940,6 @@
SUBDIR += ice37
SUBDIR += icestorm
SUBDIR += icmake
- SUBDIR += icontheme
SUBDIR += icu
SUBDIR += icu-le-hb
SUBDIR += icu-lx
@@ -974,9 +954,7 @@
SUBDIR += inastemp
SUBDIR += include-what-you-use
SUBDIR += indicators
- SUBDIR += inifiled
SUBDIR += inilib
- SUBDIR += inilike
SUBDIR += iniparser
SUBDIR += initutil
SUBDIR += injeqt
@@ -987,7 +965,6 @@
SUBDIR += ipython5
SUBDIR += ireport
SUBDIR += isa-l
- SUBDIR += isfreedesktop
SUBDIR += isl
SUBDIR += ispc
SUBDIR += itext
@@ -1126,7 +1103,6 @@
SUBDIR += libcii
SUBDIR += libcircllhist
SUBDIR += libcjson
- SUBDIR += libclc
SUBDIR += libcli
SUBDIR += libconcurrent
SUBDIR += libconfig
@@ -1140,7 +1116,6 @@
SUBDIR += libdatrie
SUBDIR += libdbusmenu
SUBDIR += libdbusmenu-qt
- SUBDIR += libddoc
SUBDIR += libdevq
SUBDIR += libdfui
SUBDIR += libdill
@@ -1151,7 +1126,6 @@
SUBDIR += libdlna
SUBDIR += libdnsres
SUBDIR += libdombey
- SUBDIR += libdparse
SUBDIR += libds
SUBDIR += libdsp
SUBDIR += libdwarf
@@ -1218,7 +1192,6 @@
SUBDIR += libgudev
SUBDIR += libgutenfetch
SUBDIR += libhash
- SUBDIR += libhid
SUBDIR += libhoard
SUBDIR += libhtp
SUBDIR += libhyve-remote
@@ -1271,8 +1244,6 @@
SUBDIR += libopkele
SUBDIR += liborcus
SUBDIR += libosinfo
- SUBDIR += libosmo-abis
- SUBDIR += libosmocore
SUBDIR += libowfat
SUBDIR += libpafe
SUBDIR += libpafe-ruby
@@ -1421,7 +1392,6 @@
SUBDIR += llvm-devel
SUBDIR += llvm10
SUBDIR += llvm11
- SUBDIR += llvm70
SUBDIR += llvm80
SUBDIR += llvm90
SUBDIR += lm4tools
@@ -1518,7 +1488,6 @@
SUBDIR += mips-xtoolchain-gcc
SUBDIR += mips64-gcc
SUBDIR += mips64-xtoolchain-gcc
- SUBDIR += mir-core
SUBDIR += mk-configure
SUBDIR += mm
SUBDIR += mm-common
@@ -1531,7 +1500,6 @@
SUBDIR += mph
SUBDIR += msbuild
SUBDIR += msgpack
- SUBDIR += msgpack-d
SUBDIR += msgpuck
SUBDIR += msitools
SUBDIR += msp430-debug-stack
@@ -4368,7 +4336,6 @@
SUBDIR += py-enlighten
SUBDIR += py-entrypoints
SUBDIR += py-enum-compat
- SUBDIR += py-enum34
SUBDIR += py-envisage
SUBDIR += py-epdb
SUBDIR += py-epsilon
@@ -5383,7 +5350,6 @@
SUBDIR += rapidjson
SUBDIR += raylib
SUBDIR += rbenv
- SUBDIR += rbtools
SUBDIR += rclint
SUBDIR += rcs
SUBDIR += rcs57
@@ -6803,7 +6769,6 @@
SUBDIR += statik
SUBDIR += statsvn
SUBDIR += stb
- SUBDIR += stdx-allocator
SUBDIR += stfl
SUBDIR += stlfilt
SUBDIR += stlink
@@ -6814,7 +6779,6 @@
SUBDIR += stxxl
SUBDIR += subversion
SUBDIR += subversion-book
- SUBDIR += subversion-lts
SUBDIR += subversive
SUBDIR += svk
SUBDIR += svn2git
@@ -6923,7 +6887,6 @@
SUBDIR += vcglib
SUBDIR += vera++
SUBDIR += vexcl
- SUBDIR += viewvc
SUBDIR += viewvc-devel
SUBDIR += violet
SUBDIR += vitables
@@ -6948,7 +6911,6 @@
SUBDIR += xcscope.el
SUBDIR += xdg-user-dirs
SUBDIR += xdg-utils
- SUBDIR += xdgpaths
SUBDIR += xeus
SUBDIR += xeus-cling
SUBDIR += xfce4-dev-tools
diff --git a/devel/RStudio/Makefile b/devel/RStudio/Makefile
index 698ab9d5b1c9..d1dd8b5f4a76 100644
--- a/devel/RStudio/Makefile
+++ b/devel/RStudio/Makefile
@@ -32,7 +32,7 @@ LIB_DEPENDS= libR.so:math/R \
libinotify.so:devel/libinotify \
libuuid.so:misc/e2fsprogs-libuuid
-FLAVORS= desktop server
+FLAVORS= server
FLAVOR?= ${FLAVORS:[1]}
server_PKGNAMESUFFIX= -server
@@ -60,16 +60,6 @@ MAKE_ENV= HOME=${WRKDIR} \
GWT_VERSION= 2.8.1
GIN_VERSION= 2.1.2
-.if ${FLAVOR:U} == desktop
-COMMENT+= (desktop UI version)
-USES+= desktop-file-utils qt:5 shared-mime-info
-USE_QT= core dbus declarative gui location network opengl printsupport quickcontrols sensors \
- sql svg webchannel webengine webkit widgets xml xmlpatterns buildtools_build qmake_build
-CMAKE_ARGS+= -DRSTUDIO_TARGET=Desktop
-INSTALL_SUBDIR= ${PORTNAME:tl}
-EXECUTABLE= ${PORTNAME:tl}
-.endif
-
.if ${FLAVOR:U} == server
COMMENT+= (web UI version)
CMAKE_ARGS+= -DRSTUDIO_TARGET=Server
@@ -117,9 +107,6 @@ post-install:
echo "LD_PRELOAD=${PREFIX}/lib/gcc${GCC_DEFAULT}/libgcc_s.so JAVA_HOME=${JAVA_HOME} ${PREFIX}/lib/${INSTALL_SUBDIR}/bin/${EXECUTABLE} \"$$"@"\"" \
) > ${STAGEDIR}${PREFIX}/bin/${EXECUTABLE}
@${CHMOD} +x ${STAGEDIR}${PREFIX}/bin/${EXECUTABLE}
-.if ${FLAVOR:U} == desktop
- ${REINPLACE_CMD} -e 's|^Exec=.*/rstudio|Exec=${PREFIX}/bin/${EXECUTABLE}|' ${STAGEDIR}${PREFIX}/share/applications/${EXECUTABLE}.desktop
-.endif
.if ${FLAVOR:U} == server
${RM} ${STAGEDIR}${LOCALBASE}/lib/${INSTALL_SUBDIR}/bin/rstudio-server # not compatible with FreeBSD
.endif
diff --git a/devel/kdevelop/Makefile b/devel/kdevelop/Makefile
index 06cacdae34fc..7b992ec7cfc6 100644
--- a/devel/kdevelop/Makefile
+++ b/devel/kdevelop/Makefile
@@ -37,24 +37,18 @@ USE_KDE= archive attica auth bookmarks codecs completion config configwidgets \
runner service solid sonnet texteditor textwidgets threadweaver \
widgetsaddons windowsystem xmlgui
USE_QT= concurrent core dbus declarative gui help network \
- script sql widgets xml buildtools_build qmake_build
+ script sql widgets xml buildtools_build qmake_build webkit
SHEBANG_FILES= kdevplatform/util/kdevplatform_shell_environment.sh \
kdevplatform/util/.zshrc
-CMAKE_ARGS= -DCMAKE_POLICY_DEFAULT_CMP0074=NEW -DLLVM_ROOT=${LOCALBASE}/llvm${LLVM_DEFAULT}
+CMAKE_ARGS= -DCMAKE_POLICY_DEFAULT_CMP0074=NEW -DLLVM_ROOT=${LOCALBASE}/llvm${LLVM_DEFAULT} \
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets:BOOL=TRUE
# Versioning values, to reduce plist churn
PLATFORM_VER= 34
SO_VER= 56
PLIST_SUB+= PLATFORM_VER=${PLATFORM_VER} SO_VER=${SO_VER} SO_VER_LONG=${DISTVERSION}
-OPTIONS_DEFINE= WEBENGINE
-WEBENGINE_DESC= Use WebEngine as help reader
-WEBENGINE_USES= qt:5
-WEBENGINE_USE= QT=location,webchannel,webengine
-WEBENGINE_USE_OFF= QT=webkit
-WEBENGINE_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets:BOOL=TRUE
-
SHEBANG_LANG= zsh
zsh_OLD_CMD= /bin/zsh
zsh_CMD= ${LOCALBASE}/bin/zsh
diff --git a/devel/mercurial/pkg-plist b/devel/mercurial/pkg-plist
index 147e99370cc0..0e4d6db6265e 100644
--- a/devel/mercurial/pkg-plist
+++ b/devel/mercurial/pkg-plist
@@ -1,8 +1,6 @@
%%PYTHON_SITELIBDIR%%/mercurial/__modulepolicy__.py
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/mercurial/__modulepolicy__.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/mercurial/__modulepolicy__.pyo
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/mercurial/__pycache__/__modulepolicy__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/mercurial/__pycache__/__modulepolicy__.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/mercurial/__pycache__/__modulepolicy__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/mercurial/__pycache__/__modulepolicy__.cpython-%%PYTHON_SUFFIX%%.pyc
%%DATA%%%%DATADIR%%/contrib/bash_completion
%%DATA%%%%DATADIR%%/contrib/casesmash.py
%%DATA%%%%DATADIR%%/contrib/check-code.py
diff --git a/devel/omniORB/pkg-plist b/devel/omniORB/pkg-plist
index 3eb259dd3877..3344471b8622 100644
--- a/devel/omniORB/pkg-plist
+++ b/devel/omniORB/pkg-plist
@@ -263,12 +263,9 @@ man/man8/omniMapper.8.gz
man/man8/omniNames.8.gz
man/man1/omnicpp.1.gz
man/man1/omniidl.1.gz
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omniidlmodule.so
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omniidlmodule.so.4
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omniidlmodule.so.4.2
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omniidl.so
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omniidl.so.4
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omniidl.so.4.2
+%%PYTHON_SITELIBDIR%%/_omniidl.so
+%%PYTHON_SITELIBDIR%%/_omniidl.so.4
+%%PYTHON_SITELIBDIR%%/_omniidl.so.4.2
%%PYTHON_SITELIBDIR%%/omniidl/__init__.py
%%PYTHON_SITELIBDIR%%/omniidl/__init__.pyc
%%PYTHON_SITELIBDIR%%/omniidl/idlast.py
diff --git a/devel/py-Jinja2/Makefile b/devel/py-Jinja2/Makefile
index 2220902af803..81900c9475d6 100644
--- a/devel/py-Jinja2/Makefile
+++ b/devel/py-Jinja2/Makefile
@@ -20,7 +20,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markupsafe>=0.23:textproc/py-markupsafe@${P
NO_ARCH= yes
.if empty(PKGNAMESUFFIX)
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
.endif
.if ${PKGNAMESUFFIX} == -doc
diff --git a/devel/py-babel/Makefile b/devel/py-babel/Makefile
index b3588848e21e..0658c44fbefd 100644
--- a/devel/py-babel/Makefile
+++ b/devel/py-babel/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR}
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/devel/py-dbus/pkg-plist b/devel/py-dbus/pkg-plist
index 71d2a86a8dd7..8d271d9f6d3c 100644
--- a/devel/py-dbus/pkg-plist
+++ b/devel/py-dbus/pkg-plist
@@ -30,9 +30,6 @@
%%PYTHON_SITELIBDIR%%/dbus/glib.py
%%PYTHON_SITELIBDIR%%/dbus/glib.pyc
%%PYTHON_SITELIBDIR%%/dbus/glib.pyo
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/dbus/gobject_service.py
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/dbus/gobject_service.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/dbus/gobject_service.pyo
%%PYTHON_SITELIBDIR%%/dbus/lowlevel.py
%%PYTHON_SITELIBDIR%%/dbus/lowlevel.pyc
%%PYTHON_SITELIBDIR%%/dbus/lowlevel.pyo
diff --git a/devel/py-future/Makefile b/devel/py-future/Makefile
index 7ec3306509d8..1133158cd037 100644
--- a/devel/py-future/Makefile
+++ b/devel/py-future/Makefile
@@ -8,12 +8,12 @@ MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= bofh@FreeBSD.org
-COMMENT= Clean single-source support for Python 3 and 2
+COMMENT= Clean single-source support for Python 3
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/devel/py-game_sdl2/Makefile b/devel/py-game_sdl2/Makefile
index a80b5e877571..ca6d08279a35 100644
--- a/devel/py-game_sdl2/Makefile
+++ b/devel/py-game_sdl2/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libpng.so:graphics/png
# Upstream tends to reroll distfiles before moving under /release/
PORTSCOUT= site:http://www.renpy.org/dl/release/
-USES= jpeg python:2.7+ sdl
+USES= jpeg python sdl
USE_SDL= image2 mixer2 ttf2
USE_PYTHON= autoplist distutils cython
EXCLUDE= gen gen3 PKG-INFO '*.egg-info'
diff --git a/devel/py-omniorb/pkg-plist b/devel/py-omniorb/pkg-plist
index 6759fe873d98..b87c1b2637a7 100644
--- a/devel/py-omniorb/pkg-plist
+++ b/devel/py-omniorb/pkg-plist
@@ -12,36 +12,21 @@ include/omniORBpy.h
%%PYTHON_SITELIBDIR%%/PortableServer.pyc
%%PYTHON_SITELIBDIR%%/PortableServer__POA.py
%%PYTHON_SITELIBDIR%%/PortableServer__POA.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omniConnMgmtmodule.so
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omniConnMgmtmodule.so.4
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omniConnMgmtmodule.so.4.%%SONUM%%
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omniConnMgmt.so
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omniConnMgmt.so.4
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omniConnMgmt.so.4.2
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omniZIOPmodule.so
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omniZIOPmodule.so.4
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omniZIOPmodule.so.4.%%SONUM%%
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omniZIOP.so
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omniZIOP.so.4
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omniZIOP.so.4.2
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omnicodesetsmodule.so
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omnicodesetsmodule.so.4
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omnicodesetsmodule.so.4.%%SONUM%%
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omnicodesets.so
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omnicodesets.so.4
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omnicodesets.so.4.2
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omnipymodule.so
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omnipymodule.so.4
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omnipymodule.so.4.%%SONUM%%
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omnipy.so
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omnipy.so.4
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omnipy.so.4.2
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omnisslTPmodule.so
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omnisslTPmodule.so.4
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/_omnisslTPmodule.so.4.%%SONUM%%
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omnisslTP.so
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omnisslTP.so.4
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/_omnisslTP.so.4.2
+%%PYTHON_SITELIBDIR%%/_omniConnMgmt.so
+%%PYTHON_SITELIBDIR%%/_omniConnMgmt.so.4
+%%PYTHON_SITELIBDIR%%/_omniConnMgmt.so.4.2
+%%PYTHON_SITELIBDIR%%/_omniZIOP.so
+%%PYTHON_SITELIBDIR%%/_omniZIOP.so.4
+%%PYTHON_SITELIBDIR%%/_omniZIOP.so.4.2
+%%PYTHON_SITELIBDIR%%/_omnicodesets.so
+%%PYTHON_SITELIBDIR%%/_omnicodesets.so.4
+%%PYTHON_SITELIBDIR%%/_omnicodesets.so.4.2
+%%PYTHON_SITELIBDIR%%/_omnipy.so
+%%PYTHON_SITELIBDIR%%/_omnipy.so.4
+%%PYTHON_SITELIBDIR%%/_omnipy.so.4.2
+%%PYTHON_SITELIBDIR%%/_omnisslTP.so
+%%PYTHON_SITELIBDIR%%/_omnisslTP.so.4
+%%PYTHON_SITELIBDIR%%/_omnisslTP.so.4.2
%%PYTHON_SITELIBDIR%%/omniORB.pth
%%PYTHON_SITELIBDIR%%/omniORB/BiDirPolicy.py
%%PYTHON_SITELIBDIR%%/omniORB/BiDirPolicy.pyc
diff --git a/devel/py-ply/Makefile b/devel/py-ply/Makefile
index b1e0d5a1e39e..67ab48778224 100644
--- a/devel/py-ply/Makefile
+++ b/devel/py-ply/Makefile
@@ -12,7 +12,7 @@ COMMENT= Python Lex-Yacc
LICENSE= BSD3CLAUSE
-USES= python:2.7+
+USES= python
USES+= shebangfix
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/devel/py-pycparser/Makefile b/devel/py-pycparser/Makefile
index d4451aff59c6..73e23b1380bb 100644
--- a/devel/py-pycparser/Makefile
+++ b/devel/py-pycparser/Makefile
@@ -13,7 +13,7 @@ COMMENT= C parser in Python
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/devel/py-pytz/Makefile b/devel/py-pytz/Makefile
index da3a8900390e..70b76271c68d 100644
--- a/devel/py-pytz/Makefile
+++ b/devel/py-pytz/Makefile
@@ -14,7 +14,7 @@ COMMENT= World Timezone Definitions for Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py-setuptools/Makefile b/devel/py-setuptools/Makefile
index 755931347f1f..13e4a1369a8b 100644
--- a/devel/py-setuptools/Makefile
+++ b/devel/py-setuptools/Makefile
@@ -17,7 +17,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
NO_ARCH= yes
-USES= python:2.7+ zip
+USES= python zip
USE_PYTHON= allflavors autoplist concurrent distutils
PYDISTUTILS_SETUP= ${PYSETUP}
@@ -37,9 +37,6 @@ SUB_LIST+= PYTHON_VER=${PYTHON_VER}
# These create dependency loops in redports/poudriere, because setuptools
# is currently an explicit BUILD & RUN dependency in Uses/python.mk.
#TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-#.if ${PYTHON_REL} < 3300
-#TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
-#.endif
# pkg install -y py36-pytest py36-mock py36-pytest-fixture-config py36-pytest-virtualenv py36-paver
post-install:
diff --git a/devel/py-setuptools_scm/Makefile b/devel/py-setuptools_scm/Makefile
index 16b878ac950b..d33aea4049e1 100644
--- a/devel/py-setuptools_scm/Makefile
+++ b/devel/py-setuptools_scm/Makefile
@@ -18,7 +18,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
git:devel/git \
${PY_MERCURIAL}
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py-six/Makefile b/devel/py-six/Makefile
index 14e3d421035b..6a5f7f1f0bad 100644
--- a/devel/py-six/Makefile
+++ b/devel/py-six/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/devel/py-subversion/Makefile b/devel/py-subversion/Makefile
index 129091bd0784..0521de00e911 100644
--- a/devel/py-subversion/Makefile
+++ b/devel/py-subversion/Makefile
@@ -8,7 +8,7 @@ COMMENT= Python bindings for version control system
BUILD_DEPENDS= ${LOCALBASE}/include/py3c.h:devel/py3c
-USES= python:2.7+
+USES= python
USE_PYTHON= flavors py3kplist
# There is bug in python bindings Makefile
diff --git a/devel/pyside2-tools/Makefile b/devel/pyside2-tools/Makefile
index 26d44c08d3a6..f6f549b552c9 100644
--- a/devel/pyside2-tools/Makefile
+++ b/devel/pyside2-tools/Makefile
@@ -35,8 +35,4 @@ CMAKE_ARGS+= "-DUSE_PYTHON_VERSION=${PYTHON_VER}"
WRKSRC= ${WRKDIR}/pyside-setup-opensource-src-${DISTVERSION:C/^([0-9].[0-9]+.[0-9])(.[0-9])?/\1/}/sources/pyside2-tools
-.if ${ARCH} == amd64 || ${ARCH} == i386
-USE_QT+= webengine
-.endif
-
.include <bsd.port.post.mk>
diff --git a/devel/pyside2/Makefile b/devel/pyside2/Makefile
index aa735888a249..65cf27cbd07b 100644
--- a/devel/pyside2/Makefile
+++ b/devel/pyside2/Makefile
@@ -36,13 +36,6 @@ PLIST_SUB+= DISTVERSION=${DISTVERSION}
WRKSRC= ${WRKDIR}/pyside-setup-opensource-src-${DISTVERSION:C/^([0-9].[0-9]+.[0-9])(.[0-9])?/\1/}/sources/pyside2
-.if ${ARCH} == amd64 || ${ARCH} == i386
-PLIST_SUB+= WEBENGINE=""
-USE_QT+= webengine
-.else
-PLIST_SUB+= WEBENGINE="@comment "
-.endif
-
# AVOID a build_fs_violation with poudriere
post-build:
${RM} -r ${PYTHON_SITELIBDIR}/shiboken2/files.dir/shibokensupport/__pycache__
diff --git a/devel/pyside2/pkg-plist b/devel/pyside2/pkg-plist
index dfe47bf2c999..6af707c81c61 100644
--- a/devel/pyside2/pkg-plist
+++ b/devel/pyside2/pkg-plist
@@ -35,9 +35,6 @@ include/PySide2/QtTest/pyside2_qttest_python.h
include/PySide2/QtTextToSpeech/pyside2_qttexttospeech_python.h
include/PySide2/QtUiTools/pyside2_qtuitools_python.h
include/PySide2/QtWebChannel/pyside2_qtwebchannel_python.h
-%%WEBENGINE%%include/PySide2/QtWebEngine/pyside2_qtwebengine_python.h
-%%WEBENGINE%%include/PySide2/QtWebEngineCore/pyside2_qtwebenginecore_python.h
-%%WEBENGINE%%include/PySide2/QtWebEngineWidgets/pyside2_qtwebenginewidgets_python.h
include/PySide2/QtWebSockets/pyside2_qtwebsockets_python.h
include/PySide2/QtWidgets/pyside2_qtwidgets_python.h
include/PySide2/QtX11Extras/pyside2_qtx11extras_python.h
@@ -101,9 +98,6 @@ lib/libpyside2%%PYVERSTR%%.so.%%DISTVERSION%%
%%PYTHON_SITELIBDIR%%/PySide2/QtTextToSpeech%%PYVERSTR%%.so
%%PYTHON_SITELIBDIR%%/PySide2/QtUiTools%%PYVERSTR%%.so
%%PYTHON_SITELIBDIR%%/PySide2/QtWebChannel%%PYVERSTR%%.so
-%%WEBENGINE%%%%PYTHON_SITELIBDIR%%/PySide2/QtWebEngine%%PYVERSTR%%.so
-%%WEBENGINE%%%%PYTHON_SITELIBDIR%%/PySide2/QtWebEngineCore%%PYVERSTR%%.so
-%%WEBENGINE%%%%PYTHON_SITELIBDIR%%/PySide2/QtWebEngineWidgets%%PYVERSTR%%.so
%%PYTHON_SITELIBDIR%%/PySide2/QtWebSockets%%PYVERSTR%%.so
%%PYTHON_SITELIBDIR%%/PySide2/QtWidgets%%PYVERSTR%%.so
%%PYTHON_SITELIBDIR%%/PySide2/QtX11Extras%%PYVERSTR%%.so
@@ -125,7 +119,6 @@ share/PySide2/glue/qtqml.cpp
share/PySide2/glue/qtquick.cpp
share/PySide2/glue/qtscript.cpp
share/PySide2/glue/qtuitools.cpp
-%%WEBENGINE%%share/PySide2/glue/qtwebenginewidgets.cpp
share/PySide2/glue/qtwidgets.cpp
share/PySide2/glue/qtxml.cpp
share/PySide2/glue/qtxmlpatterns.cpp
@@ -207,9 +200,6 @@ share/PySide2/typesystems/typesystem_test.xml
share/PySide2/typesystems/typesystem_texttospeech.xml
share/PySide2/typesystems/typesystem_uitools.xml
share/PySide2/typesystems/typesystem_webchannel.xml
-%%WEBENGINE%%share/PySide2/typesystems/typesystem_webengine.xml
-%%WEBENGINE%%share/PySide2/typesystems/typesystem_webenginecore.xml
-%%WEBENGINE%%share/PySide2/typesystems/typesystem_webenginewidgets.xml
share/PySide2/typesystems/typesystem_websockets.xml
share/PySide2/typesystems/typesystem_widgets.xml
share/PySide2/typesystems/typesystem_widgets_common.xml
diff --git a/devel/qt5/Makefile b/devel/qt5/Makefile
index 997be9942b10..7ead9e2bee6c 100644
--- a/devel/qt5/Makefile
+++ b/devel/qt5/Makefile
@@ -9,7 +9,8 @@ COMMENT= Cross-platform application and UI framework (metaport)
# * phonon4 is not part of Qt itself.
# * we don't want to pull in wayland just yet.
-USE_QT= ${_USE_QT_ALL:Nphonon4:Ndeclarative:Nwayland:S/$/_run/}
+# XXX(rene) drop webengine
+USE_QT= ${_USE_QT_ALL:Nphonon4:Ndeclarative:Nwayland:Nwebengine:S/$/_run/}
USES= metaport qt:5
.include <bsd.port.mk>
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index 4d1106db532d..3ab3a0f5d3bc 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -34,7 +34,9 @@ USE_QT= buildtools concurrent core declarative designer gui help \
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/src/shared/qbs'
# Set QBS_INSTALL_DIR for QBS plugin build and set config parameter to build
# the qbsprojectmanager plugin without compile error
-QMAKE_ARGS+= QBS_INSTALL_DIR=${PREFIX} CONFIG+=qbs_enable_project_file_updates
+QMAKE_ARGS+= QBS_INSTALL_DIR=${PREFIX} CONFIG+=qbs_enable_project_file_updates \
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine:BOOL=false
+
# Enforce installation to ${PREFIX}.
QMAKE_ARGS+= QTC_PREFIX=${PREFIX} LLVM_INSTALL_DIR=${PREFIX}/llvm${LLVM_DEFAULT}
@@ -44,19 +46,13 @@ DESKTOP_ENTRIES="Qt Creator" "" "QtProject-qtcreator" \
PORTDOCS= *
-OPTIONS_DEFINE= DOCS EXAMPLES QTWEBENGINE
+OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_SUB= yes
DOCS_DESC= Install the Qt5 api documentation
DOCS_USE= QT=doc_run
EXAMPLES_DESC= Install the Qt5 example projects
EXAMPLES_USE= QT=examples_run
OPTIONS_DEFAULT= DOCS EXAMPLES
-OPTIONS_DEFAULT_amd64= QTWEBENGINE
-OPTIONS_DEFAULT_i386= QTWEBENGINE
-
-QTWEBENGINE_DESC= Add dependency on qt5-webengine
-QTWEBENGINE_USE= qt=webengine
-QTWEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine
ALL_TARGET= all
INSTALL_TARGET= install
diff --git a/devel/scons/Makefile b/devel/scons/Makefile
index 4d733ee2a8f1..d21a28b38152 100644
--- a/devel/scons/Makefile
+++ b/devel/scons/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= gm4:devel/m4
-USES= python:2.7+ shebangfix
+USES= python shebangfix
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/devel/tortoisehg/pkg-plist b/devel/tortoisehg/pkg-plist
index 21e92ac1d0c9..baf1f14b007f 100644
--- a/devel/tortoisehg/pkg-plist
+++ b/devel/tortoisehg/pkg-plist
@@ -1,7 +1,5 @@
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/tortoisehg/util/__pycache__/config.cpython-37.opt-1.pyc
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/tortoisehg/util/__pycache__/config.cpython-37.pyc
+%%PYTHON_SITELIBDIR%%/tortoisehg/util/__pycache__/config.cpython-37.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/tortoisehg/util/__pycache__/config.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/tortoisehg/util/config.py
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/tortoisehg/util/config.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/tortoisehg/util/config.pyo
share/applications/tortoisehg.desktop
%%DATADIR%%/mergetools.rc
diff --git a/dns/py-dnspython/Makefile b/dns/py-dnspython/Makefile
index a45807bf8d74..88e99c0484ca 100644
--- a/dns/py-dnspython/Makefile
+++ b/dns/py-dnspython/Makefile
@@ -13,7 +13,7 @@ COMMENT= DNS toolkit for Python
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:2.7+ zip
+USES= python zip
USE_PYTHON= autoplist concurrent cython distutils
NO_ARCH= yes
diff --git a/editors/Makefile b/editors/Makefile
index ac203792d6bb..60d5ce224d3c 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -51,7 +51,6 @@
SUBDIR += gedit
SUBDIR += gedit-plugins
SUBDIR += ghex
- SUBDIR += ghostwriter
SUBDIR += gmanedit
SUBDIR += gnome-latex
SUBDIR += gobby
@@ -255,7 +254,6 @@
SUBDIR += vim
SUBDIR += vim-console
SUBDIR += vim-tiny
- SUBDIR += vscode
SUBDIR += web-mode
SUBDIR += with-editor
SUBDIR += wordgrinder
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index c30930a83a45..b778cdfc2b4b 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -55,7 +55,7 @@ TEST_TARGET= test
OPTIONS_DEFINE= ALSA PULSEAUDIO JACK SNDIO VULKAN
OPTIONS_DEFAULT=PULSEAUDIO JACK SNDIO VULKAN
OPTIONS_MULTI= GUI
-OPTIONS_MULTI_GUI= QT5 SDL
+OPTIONS_MULTI_GUI= SDL
OPTIONS_SLAVE?= SDL
OPTIONS_EXCLUDE:= ${OPTIONS_MULTI_GUI}
@@ -75,14 +75,6 @@ SDL_CMAKE_BOOL= ENABLE_SDL2
SDL_PLIST_FILES=bin/${PORTNAME}-cmd \
bin/${PORTNAME}-tester
-QT5_USES= desktop-file-utils qt:5 shared-mime-info
-QT5_USE= QT=qmake_build,buildtools_build,linguisttools_build,concurrent_build,core,gui,webengine,widgets
-QT5_CMAKE_BOOL= ENABLE_QT ENABLE_QT_TRANSLATION YUZU_USE_QT_WEB_ENGINE
-QT5_PLIST_FILES=bin/${PORTNAME} \
- share/applications/${PORTNAME}.desktop \
- share/icons/hicolor/scalable/apps/${PORTNAME}.svg \
- share/mime/packages/${PORTNAME}.xml
-
VULKAN_DESC= Vulkan renderer
VULKAN_RUN_DEPENDS= ${LOCALBASE}/lib/libvulkan.so:graphics/vulkan-loader
diff --git a/finance/kmymoney/Makefile b/finance/kmymoney/Makefile
index 2bbd156888a9..c645d389162d 100644
--- a/finance/kmymoney/Makefile
+++ b/finance/kmymoney/Makefile
@@ -35,7 +35,7 @@ OPTIONS_GROUP= PLUGINS
OPTIONS_GROUP_PLUGINS= CALENDAR KBANKING OFX SQLCIPHER WEBOOB
WEB_DESC= Web content renderer
OPTIONS_SINGLE= WEB
-OPTIONS_SINGLE_WEB= KDEWEBKIT QTWEBENGINE
+OPTIONS_SINGLE_WEB= KDEWEBKIT
OPTIONS_DEFINE= ADDRESSBOOK GNUPG HOLIDAYS QUOTES
OPTIONS_DEFAULT= CALENDAR GNUPG HOLIDAYS KBANKING KDEWEBKIT OFX QUOTES
OPTIONS_SUB= yes
@@ -75,10 +75,6 @@ OFX_DESC= OFX (Open Financial Exchange) importer
OFX_LIB_DEPENDS= libofx.so:finance/libofx
OFX_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_LibOfx
-QTWEBENGINE_DESC= Web content rendering via QtWebEngine
-QTWEBENGINE_USE= qt=location,webchannel,webengine
-QTWEBENGINE_CMAKE_BOOL= ENABLE_WEBENGINE
-
QUOTES_DESC= Online stock and currency price quotes
QUOTES_USES= perl5
QUOTES_USE= PERL5=run
diff --git a/games/Makefile b/games/Makefile
index 68ec5bc54efd..1936b5e10bd7 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -3,7 +3,6 @@
COMMENT = Games and related software
- SUBDIR += 0ad
SUBDIR += 0verkill
SUBDIR += 2048
SUBDIR += 2048-qt
@@ -47,7 +46,6 @@
SUBDIR += amoebax
SUBDIR += an
SUBDIR += angband
- SUBDIR += anki
SUBDIR += antipolix
SUBDIR += aop
SUBDIR += apoolGL
@@ -606,7 +604,6 @@
SUBDIR += minerbold
SUBDIR += minetest
SUBDIR += minetest_game
- SUBDIR += minilens
SUBDIR += mirrormagic
SUBDIR += miscom
SUBDIR += mkhexgrid
@@ -769,7 +766,6 @@
SUBDIR += pvpgn
SUBDIR += py-cbeams
SUBDIR += py-fife
- SUBDIR += py-mnemosyne
SUBDIR += py-pychess
SUBDIR += py-pysol-cards
SUBDIR += py-sgflib
@@ -824,7 +820,6 @@
SUBDIR += redorblack
SUBDIR += regoth
SUBDIR += reminiscence
- SUBDIR += renpy
SUBDIR += rescue
SUBDIR += residualvm
SUBDIR += retroarch
@@ -910,7 +905,6 @@
SUBDIR += stonesoup
SUBDIR += stormbaancoureur
SUBDIR += stransball2
- SUBDIR += stratagus
SUBDIR += stuntrally
SUBDIR += sudsol
SUBDIR += super_methane_brothers
@@ -924,7 +918,6 @@
SUBDIR += taisei
SUBDIR += tali
SUBDIR += tanglet
- SUBDIR += tanks-of-freedom
SUBDIR += tbclock
SUBDIR += tecnoballz
SUBDIR += teeworlds
@@ -1004,7 +997,6 @@
SUBDIR += vultures-eye
SUBDIR += vvvvvv
SUBDIR += wanderer
- SUBDIR += wargus
SUBDIR += warmux
SUBDIR += warzone2100
SUBDIR += wesnoth
@@ -1021,8 +1013,6 @@
SUBDIR += worldofpadman
SUBDIR += wtf
SUBDIR += wxlauncher
- SUBDIR += wyrmgus
- SUBDIR += wyrmsun
SUBDIR += xasteroids
SUBDIR += xataxx
SUBDIR += xbat
diff --git a/german/Makefile b/german/Makefile
index 4377cfde658b..55b2a484c686 100644
--- a/german/Makefile
+++ b/german/Makefile
@@ -10,7 +10,6 @@
SUBDIR += dict
SUBDIR += ding
SUBDIR += dtaus
- SUBDIR += eric6
SUBDIR += geonext
SUBDIR += hunspell
SUBDIR += hyphen
diff --git a/graphics/Makefile b/graphics/Makefile
index 9ccaaf9cff1a..41f90584521b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -127,7 +127,6 @@
SUBDIR += deegree-wps
SUBDIR += deegree-wpvs
SUBDIR += delaboratory
- SUBDIR += derelict-gl3
SUBDIR += devil
SUBDIR += dia
SUBDIR += diff-pdf
@@ -393,7 +392,6 @@
SUBDIR += kf5-prison
SUBDIR += kgraphviewer
SUBDIR += kimageannotator
- SUBDIR += kimagemapeditor
SUBDIR += kipi-plugins
SUBDIR += klatexformula
SUBDIR += kludge3d
@@ -518,7 +516,6 @@
SUBDIR += linux-c7-tiff
SUBDIR += linux-c7-wayland
SUBDIR += lua-gd
- SUBDIR += luminance-qt5
SUBDIR += lximage-qt
SUBDIR += magnum
SUBDIR += magnum-examples
@@ -905,8 +902,6 @@
SUBDIR += py-zbar-py
SUBDIR += qcomicbook
SUBDIR += qcustomplot-qt5
- SUBDIR += qgis
- SUBDIR += qgis-ltr
SUBDIR += qiv
SUBDIR += qr-code-generator
SUBDIR += qt5-3d
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
index af9fb7bd3eae..94e05be18fb9 100644
--- a/graphics/cegui/Makefile
+++ b/graphics/cegui/Makefile
@@ -15,19 +15,21 @@ LICENSE= MIT
WRKSRC= ${WRKDIR}/${DISTNAME:S/2b/2/}
CONFIGURE_ENV+= TOLUA_INC="${LUA_INCDIR}"
CMAKE_ARGS= -DCEGUI_SAMPLES_ENABLED:BOOL=OFF \
- -DCEGUI_BUILD_TESTS=OFF
+ -DCEGUI_BUILD_TESTS=OFF \
+ -DCEGUI_BUILD_LUA_MODULE=OFF \
+ -DCEGUI_BUILD_LUA_GENERATOR=OFF
USE_LDCONFIG= yes
USES= cmake compiler:c++11-lib iconv localbase pkgconfig tar:bzip2
PORTDOCS= *
-OPTIONS_DEFINE= FREETYPE PCRE LUA FRIBIDI DOCS
+OPTIONS_DEFINE= FREETYPE PCRE FRIBIDI DOCS
OPTIONS_GROUP= XMLPARSER IMAGECODEC RENDERER
OPTIONS_GROUP_XMLPARSER= EXPAT XERCES LIBXML2 RAPIDXML TINYXML
OPTIONS_GROUP_IMAGECODEC= DEVIL FREEIMAGE SDL2
OPTIONS_GROUP_RENDERER= OPENGL OPENGL3 OGRE IRRLICHT
-OPTIONS_DEFAULT= FREETYPE PCRE LUA FRIBIDI
+OPTIONS_DEFAULT= FREETYPE PCRE FRIBIDI
OPTIONS_DEFAULT+= EXPAT LIBXML2 TINYXML
OPTIONS_DEFAULT+= DEVIL FREEIMAGE SDL2
OPTIONS_DEFAULT+= OPENGL OPENGL3 OGRE
@@ -40,10 +42,6 @@ FREETYPE_CMAKE_OFF= -DCEGUI_HAS_FREETYPE=OFF
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
PCRE_CMAKE_ON= -DCEGUI_HAS_PCRE_REGEX=ON
PCRE_CMAKE_OFF= -DCEGUI_HAS_PCRE_REGEX=OFF
-LUA_USES= lua:51
-LUA_LIB_DEPENDS= libtolua++-${LUA_VER}.so:lang/tolua++
-LUA_CMAKE_ON= -DCEGUI_BUILD_LUA_MODULE=ON -DCEGUI_BUILD_LUA_GENERATOR=ON
-LUA_CMAKE_OFF= -DCEGUI_BUILD_LUA_MODULE=OFF -DCEGUI_BUILD_LUA_GENERATOR=OFF
FRIBIDI_LIB_DEPENDS= libfribidi.so:converters/fribidi
FRIBIDI_CMAKE_ON= -DCEGUI_USE_FRIBIDI=ON
FRIBIDI_CMAKE_OFF= -DCEGUI_USE_FRIBIDI=OFF
diff --git a/graphics/cegui/pkg-plist b/graphics/cegui/pkg-plist
index e87b2dd7e1c4..2b942fe20654 100644
--- a/graphics/cegui/pkg-plist
+++ b/graphics/cegui/pkg-plist
@@ -1,4 +1,3 @@
-%%LUA%%bin/toluappcegui-0.8
include/cegui-0/CEGUI/Affector.h
include/cegui-0/CEGUI/Animation.h
include/cegui-0/CEGUI/AnimationInstance.h
@@ -160,8 +159,6 @@ include/cegui-0/CEGUI/Scheme.h
include/cegui-0/CEGUI/SchemeManager.h
include/cegui-0/CEGUI/Scheme_xmlHandler.h
include/cegui-0/CEGUI/ScriptModule.h
-%%LUA%%include/cegui-0/CEGUI/ScriptModules/Lua/Functor.h
-%%LUA%%include/cegui-0/CEGUI/ScriptModules/Lua/ScriptModule.h
include/cegui-0/CEGUI/SimpleTimer.h
include/cegui-0/CEGUI/Singleton.h
include/cegui-0/CEGUI/Size.h
@@ -326,9 +323,6 @@ lib/libCEGUICommonDialogs-0.so.2.4.2
%%IRRLICHT%%lib/libCEGUIIrrlichtRenderer-0.so
%%IRRLICHT%%lib/libCEGUIIrrlichtRenderer-0.so.2
%%IRRLICHT%%lib/libCEGUIIrrlichtRenderer-0.so.2.4.2
-%%LUA%%lib/libCEGUILuaScriptModule-0.so
-%%LUA%%lib/libCEGUILuaScriptModule-0.so.2
-%%LUA%%lib/libCEGUILuaScriptModule-0.so.2.4.2
%%OGRE%%lib/libCEGUIOgreRenderer-0.so
%%OGRE%%lib/libCEGUIOgreRenderer-0.so.2
%%OGRE%%lib/libCEGUIOgreRenderer-0.so.2.4.2
@@ -336,7 +330,6 @@ lib/libCEGUICommonDialogs-0.so.2.4.2
%%ANYOPENGL%%lib/libCEGUIOpenGLRenderer-0.so.2
%%ANYOPENGL%%lib/libCEGUIOpenGLRenderer-0.so.2.4.2
%%IRRLICHT%%libdata/pkgconfig/CEGUI-0-IRRLICHT.pc
-%%LUA%%libdata/pkgconfig/CEGUI-0-LUA.pc
%%OGRE%%libdata/pkgconfig/CEGUI-0-OGRE.pc
%%OPENGL%%libdata/pkgconfig/CEGUI-0-OPENGL.pc
%%OPENGL3%%libdata/pkgconfig/CEGUI-0-OPENGL3.pc
diff --git a/graphics/digikam/Makefile b/graphics/digikam/Makefile
index d91821a199b2..909b3b1bf530 100644
--- a/graphics/digikam/Makefile
+++ b/graphics/digikam/Makefile
@@ -43,7 +43,7 @@ USE_KDE= archive auth bookmarks calendarcore codecs completion config \
USE_QT= concurrent core dbus declarative gui location network opengl \
printsupport sql webchannel widgets x11extras xml xmlpatterns \
sql-sqlite3_run \
- buildtools_build qmake_build
+ buildtools_build qmake_build webkit
USE_XORG= ice sm x11 xext
USE_LDCONFIG= yes
@@ -52,9 +52,10 @@ SHEBANG_FILES= core/data/scripts/digitaglinktree/digitaglinktree
# Disable kipiplugins, as they are built in their own port: graphics/kipiplugins.
# Remember to keep that port in sync with this one.
CMAKE_ON= DIGIKAMSC_COMPILE_DIGIKAM
+CMAKE_OFF= ENABLE_QWEBENGINE
-OPTIONS_DEFINE= DOCS DOXYGEN KDEPIM KVKONTAKTE MEDIAPLAYER MYSQL NLS WEBENGINE
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE:NWEBENGINE}
+OPTIONS_DEFINE= DOCS DOXYGEN KDEPIM KVKONTAKTE MEDIAPLAYER MYSQL NLS
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
OPTIONS_SUB= yes
DOCS_DESC= Digikam documentation
@@ -94,11 +95,6 @@ NLS_CMAKE_BOOL= DIGIKAMSC_COMPILE_PO
NLS_USES= gettext
NLS_USE= KDE=i18n
-WEBENGINE_DESC= Use Qt WebEngine instead of WebKit
-WEBENGINE_USE= QT=webengine
-WEBENGINE_USE_OFF= QT=webkit
-WEBENGINE_CMAKE_BOOL= ENABLE_QWEBENGINE
-
PLIST_SUB= SHLIB_VER=${DISTVERSION}
.include <bsd.port.mk>
diff --git a/graphics/kphotoalbum/Makefile b/graphics/kphotoalbum/Makefile
index 7ef4419f7d08..b083283c21c9 100644
--- a/graphics/kphotoalbum/Makefile
+++ b/graphics/kphotoalbum/Makefile
@@ -28,11 +28,4 @@ USE_QT= concurrent core dbus declarative gui location network phonon4 \
buildtools_build qmake_build
SHEBANG_FILES= scripts/open-raw.pl scripts/kpa-backup.sh
-OPTIONS_DEFINE= WEBENGINE
-OPTIONS_DEFAULT_amd64= WEBENGINE
-OPTIONS_DEFAULT_i386= WEBENGINE
-
-WEBENGINE_DESC= Add dependency on qt5-webengine
-WEBENGINE_USE= QT=webengine
-
.include <bsd.port.mk>
diff --git a/graphics/py-cairo/pkg-plist b/graphics/py-cairo/pkg-plist
index 02fce6c3bcb4..58e62942e0d0 100644
--- a/graphics/py-cairo/pkg-plist
+++ b/graphics/py-cairo/pkg-plist
@@ -1,16 +1,13 @@
-%%PYTHON2%%include/pycairo/pycairo.h
-%%PYTHON3%%include/pycairo/py3cairo.h
+include/pycairo/py3cairo.h
%%PYTHON_SITELIBDIR%%/cairo/__init__.py
%%PYTHON_SITELIBDIR%%/cairo/__init__.pyc
%%PYTHON_SITELIBDIR%%/cairo/__init__.pyi
%%PYTHON_SITELIBDIR%%/cairo/__init__.pyo
%%PYTHON_SITELIBDIR%%/cairo/_cairo%%PYTHON_EXT_SUFFIX%%.so
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/cairo/include/pycairo.h
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/cairo/include/py3cairo.h
+%%PYTHON_SITELIBDIR%%/cairo/include/py3cairo.h
%%PYTHON_SITELIBDIR%%/cairo/py.typed
%%PYTHON_SITELIBDIR%%/pycairo-%%PORTVER%%-py%%PYTHON_VER%%.egg-info/PKG-INFO
%%PYTHON_SITELIBDIR%%/pycairo-%%PORTVER%%-py%%PYTHON_VER%%.egg-info/SOURCES.txt
%%PYTHON_SITELIBDIR%%/pycairo-%%PORTVER%%-py%%PYTHON_VER%%.egg-info/dependency_links.txt
%%PYTHON_SITELIBDIR%%/pycairo-%%PORTVER%%-py%%PYTHON_VER%%.egg-info/top_level.txt
-%%PYTHON2%%libdata/pkgconfig/pycairo.pc
-%%PYTHON3%%libdata/pkgconfig/py3cairo.pc
+libdata/pkgconfig/py3cairo.pc
diff --git a/korean/ibus-hangul/pkg-plist b/korean/ibus-hangul/pkg-plist
index f65e8e19d7cc..4202c56da774 100644
--- a/korean/ibus-hangul/pkg-plist
+++ b/korean/ibus-hangul/pkg-plist
@@ -12,8 +12,6 @@ share/applications/ibus-setup-hangul.desktop
%%DATADIR%%/setup/keycapturedialog.pyc
%%DATADIR%%/setup/keycapturedialog.pyo
%%DATADIR%%/setup/main.py
-%%PYTHON2%%%%DATADIR%%/setup/main.pyc
-%%PYTHON2%%%%DATADIR%%/setup/main.pyo
%%DATADIR%%/setup/setup.ui
share/ibus/component/hangul.xml
share/icons/hicolor/64x64/apps/ibus-hangul.png
diff --git a/lang/Makefile b/lang/Makefile
index ece8905821dd..60166169116b 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -36,7 +36,6 @@
SUBDIR += clisp
SUBDIR += clojure
SUBDIR += clojure-mode.el
- SUBDIR += clover
SUBDIR += cmucl
SUBDIR += cmucl-extra
SUBDIR += cocor
@@ -45,7 +44,6 @@
SUBDIR += crystal
SUBDIR += csharp-mode.el
SUBDIR += cython
- SUBDIR += dlang-tools
SUBDIR += dlv
SUBDIR += duktape
SUBDIR += duktape-lib
@@ -152,7 +150,6 @@
SUBDIR += kturtle
SUBDIR += lafontaine
SUBDIR += lci
- SUBDIR += ldc
SUBDIR += lfe
SUBDIR += libhx
SUBDIR += libobjc2
@@ -267,15 +264,12 @@
SUBDIR += plexil
SUBDIR += pocl
SUBDIR += polyml
- SUBDIR += ponyc
SUBDIR += ptoc
SUBDIR += purescript
SUBDIR += py-hy
SUBDIR += py-lupa
SUBDIR += py-qt5-qml
SUBDIR += py-textX
- SUBDIR += pypy
- SUBDIR += pypy3
SUBDIR += python
SUBDIR += python-doc-html
SUBDIR += python-doc-pdf-a4
@@ -283,8 +277,6 @@
SUBDIR += python-doc-text
SUBDIR += python-mode.el
SUBDIR += python-tools
- SUBDIR += python2
- SUBDIR += python27
SUBDIR += python3
SUBDIR += python36
SUBDIR += python37
@@ -322,7 +314,6 @@
SUBDIR += sdcc
SUBDIR += see
SUBDIR += seed7
- SUBDIR += silq
SUBDIR += siod
SUBDIR += sisc
SUBDIR += sketchy
@@ -336,9 +327,6 @@
SUBDIR += snobol4
SUBDIR += solidity
SUBDIR += spidermonkey17
- SUBDIR += spidermonkey185
- SUBDIR += spidermonkey52
- SUBDIR += spidermonkey60
SUBDIR += spidermonkey78
SUBDIR += spl
SUBDIR += squeak
@@ -354,7 +342,6 @@
SUBDIR += tcl87
SUBDIR += tclX
SUBDIR += tolua
- SUBDIR += tolua++
SUBDIR += tuareg-mode.el
SUBDIR += twelf
SUBDIR += ucc
diff --git a/lang/cython/Makefile b/lang/cython/Makefile
index 4f633a24ffcf..e3ab51b3e366 100644
--- a/lang/cython/Makefile
+++ b/lang/cython/Makefile
@@ -14,7 +14,7 @@ COMMENT= Compiler for Writing C Extensions for the Python Language
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= compiler:c11 python:2.7+
+USES= compiler:c11 python
USE_PYTHON= allflavors autoplist concurrent distutils
post-install:
diff --git a/mail/Makefile b/mail/Makefile
index 963c8d257faa..1cb68b42fd91 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -202,7 +202,6 @@
SUBDIR += mailfront
SUBDIR += mailgraph
SUBDIR += mailhog
- SUBDIR += mailman
SUBDIR += mailman3
SUBDIR += mailscanner
SUBDIR += mailsync
diff --git a/math/Makefile b/math/Makefile
index 8593cf278257..5483a6455607 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -149,7 +149,6 @@
SUBDIR += arpack++
SUBDIR += arpack-ng
SUBDIR += ascent
- SUBDIR += aspcud
SUBDIR += asymptote
SUBDIR += atlas
SUBDIR += barvinok
@@ -321,7 +320,6 @@
SUBDIR += graphthing
SUBDIR += gretl
SUBDIR += gri
- SUBDIR += gringo
SUBDIR += grpn
SUBDIR += gsl
SUBDIR += half
@@ -376,7 +374,6 @@
SUBDIR += libnormaliz
SUBDIR += libocas
SUBDIR += liborigin
- SUBDIR += libpgmath
SUBDIR += libpoly
SUBDIR += libqalculate
SUBDIR += libranlip
@@ -416,7 +413,6 @@
SUBDIR += mingw32-libgmp
SUBDIR += minisat
SUBDIR += minizinc
- SUBDIR += minizinc-ide
SUBDIR += miracl
SUBDIR += mlpack
SUBDIR += moab
@@ -825,7 +821,6 @@
SUBDIR += py-pplpy
SUBDIR += py-primme
SUBDIR += py-pyFFTW
- SUBDIR += py-pyasp
SUBDIR += py-pybloom
SUBDIR += py-pyclipper
SUBDIR += py-pycosat
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
index faa51e4ccbc7..a758e6ab9e63 100644
--- a/math/kalgebra/Makefile
+++ b/math/kalgebra/Makefile
@@ -19,15 +19,10 @@ USE_KDE= auth codecs config configwidgets coreaddons doctools ecm i18n \
USE_QT= concurrent core dbus declarative gui location network opengl printsupport \
svg testlib webchannel widgets xml \
buildtools_build qmake_build
-CMAKE_ARGS= -DBUILD_mobile:BOOL=FALSE
+CMAKE_ARGS= -DBUILD_mobile:BOOL=FALSE \
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets:BOOL=false
-OPTIONS_DEFINE= DOCS WEBENGINE
-OPTIONS_DEFAULT_amd64= WEBENGINE
-OPTIONS_DEFAULT_i386= WEBENGINE
+OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
-WEBENGINE_DESC= Add dependency on qt5-webengine
-WEBENGINE_USE= QT=webengine
-WEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
-
.include <bsd.port.mk>
diff --git a/math/kalgebra/pkg-plist b/math/kalgebra/pkg-plist
index 3ef784a5d970..6556ad9b4d48 100644
--- a/math/kalgebra/pkg-plist
+++ b/math/kalgebra/pkg-plist
@@ -1,7 +1,5 @@
bin/calgebra
-%%WEBENGINE%%bin/kalgebra
bin/kalgebramobile
-%%WEBENGINE%%share/applications/org.kde.kalgebra.desktop
share/applications/org.kde.kalgebramobile.desktop
share/icons/hicolor/64x64/apps/kalgebra.png
share/icons/hicolor/scalable/apps/kalgebra.svgz
@@ -25,8 +23,6 @@ share/kalgebramobile/plugins/widgets/KAlgebraMobile.qml
share/kalgebramobile/plugins/widgets/KAlgebraPage.qml
share/kalgebramobile/plugins/widgets/RealInput.qml
share/kalgebramobile/plugins/widgets/qmldir
-%%WEBENGINE%%share/katepart5/syntax/kalgebra.xml
-%%WEBENGINE%%share/kservices5/graphsplasmoid.desktop
share/locale/ar/LC_MESSAGES/kalgebra.mo
share/locale/bg/LC_MESSAGES/kalgebra.mo
share/locale/bg/LC_MESSAGES/plasma_applet_kalgebraplasmoid.mo
@@ -145,8 +141,4 @@ share/locale/zh_CN/LC_MESSAGES/plasma_applet_kalgebraplasmoid.mo
share/locale/zh_TW/LC_MESSAGES/kalgebra.mo
share/locale/zh_TW/LC_MESSAGES/kalgebramobile.mo
share/locale/zh_TW/LC_MESSAGES/plasma_applet_kalgebraplasmoid.mo
-%%WEBENGINE%%share/metainfo/org.kde.kalgebra.appdata.xml
share/metainfo/org.kde.kalgebramobile.appdata.xml
-%%WEBENGINE%%share/plasma/plasmoids/org.kde.graphsplasmoid/contents/ui/config.ui
-%%WEBENGINE%%share/plasma/plasmoids/org.kde.graphsplasmoid/contents/ui/main.qml
-%%WEBENGINE%%share/plasma/plasmoids/org.kde.graphsplasmoid/metadata.desktop
diff --git a/misc/Makefile b/misc/Makefile
index 3e4aebf60530..14ad38b47e9a 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -274,7 +274,6 @@
SUBDIR += opennn
SUBDIR += openr2
SUBDIR += openvdb
- SUBDIR += orange3
SUBDIR += orion
SUBDIR += orville-write
SUBDIR += osinfo-db
@@ -345,7 +344,6 @@
SUBDIR += p5-Tie-DxHash
SUBDIR += p5-Zen-Koans
SUBDIR += p5-asterisk-perl
- SUBDIR += parley
SUBDIR += pastebinit
SUBDIR += patchutils
SUBDIR += pauker
@@ -389,11 +387,6 @@
SUBDIR += py-mxnet
SUBDIR += py-onnx
SUBDIR += py-onnx-tf
- SUBDIR += py-orange3-associate
- SUBDIR += py-orange3-datafusion
- SUBDIR += py-orange3-educational
- SUBDIR += py-orange3-network
- SUBDIR += py-orange3-timeseries
SUBDIR += py-palettable
SUBDIR += py-pexpect
SUBDIR += py-powerline-status
diff --git a/misc/kdeedu/Makefile b/misc/kdeedu/Makefile
index 91f85ae16e21..740748476d78 100644
--- a/misc/kdeedu/Makefile
+++ b/misc/kdeedu/Makefile
@@ -11,10 +11,10 @@ USES= kde:5 metaport
OPTIONS_DEFINE= ARTIKULATE BLINKEN CANTOR KALGEBRA KALZIUM KANAGRAM KBRUCH KGEOGRAPHY \
KHANGMAN KIG KITEN KLETTRES KMPLOT KTOUCH KTURTLE \
- KWORDQUIZ MARBLE PAIRS PARLEY ROCS STEP
+ KWORDQUIZ MARBLE PAIRS ROCS STEP
OPTIONS_DEFAULT= ARTIKULATE BLINKEN CANTOR KALGEBRA KALZIUM KANAGRAM KBRUCH KGEOGRAPHY \
KHANGMAN KITEN KLETTRES KMPLOT KTOUCH KTURTLE \
- KWORDQUIZ MARBLE PAIRS PARLEY ROCS STEP
+ KWORDQUIZ MARBLE PAIRS ROCS STEP
OPTIONS_DEFAULT_amd64= KIG
OPTIONS_DEFAULT_i386= KIG
@@ -63,9 +63,6 @@ KWORDQUIZ_RUN_DEPENDS= kwordquiz>=${KDE_APPLICATIONS_VERSION}:misc/kwordquiz
MARBLE_DESC= Virtual globe and world atlas
MARBLE_RUN_DEPENDS= marble>=${KDE_APPLICATIONS_VERSION}:astro/marble
-PARLEY_DESC= Vocabulary trainer
-PARLEY_RUN_DEPENDS= parley>=${KDE_APPLICATIONS_VERSION}:misc/parley
-
ROCS_DESC= Graph teory IDE
ROCS_RUN_DEPENDS= rocs>=${KDE_APPLICATIONS_VERSION}:math/rocs
diff --git a/misc/py-tqdm/Makefile b/misc/py-tqdm/Makefile
index 372653754f0d..27072eeccf74 100644
--- a/misc/py-tqdm/Makefile
+++ b/misc/py-tqdm/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE_MIT= ${WRKSRC}/LICENCE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4:devel/py-setuptools_scm@${PY_FLAVOR}
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/multimedia/Makefile b/multimedia/Makefile
index c93b56dfca4e..16bf8aa6ae5a 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -61,7 +61,6 @@
SUBDIR += ffaudioconverter
SUBDIR += ffdec
SUBDIR += ffmpeg
- SUBDIR += ffmpeg2theora
SUBDIR += ffmpegthumbnailer
SUBDIR += ffms2
SUBDIR += flvmeta
@@ -75,7 +74,6 @@
SUBDIR += gdialog
SUBDIR += get_iplayer
SUBDIR += gmerlin
- SUBDIR += gmimms
SUBDIR += gmmlib
SUBDIR += gmp-api
SUBDIR += gmtk
@@ -130,7 +128,6 @@
SUBDIR += gstreamer1-validate
SUBDIR += gstreamermm
SUBDIR += gtk-youtube-viewer
- SUBDIR += gxine
SUBDIR += handbrake
SUBDIR += harvid
SUBDIR += hypnotix
@@ -224,7 +221,6 @@
SUBDIR += makemkv
SUBDIR += mediainfo
SUBDIR += mencoder
- SUBDIR += mimms
SUBDIR += minisatip
SUBDIR += minitube
SUBDIR += mjpegtools
diff --git a/net-im/Makefile b/net-im/Makefile
index 127a9a680324..cb9a2e441ad4 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -36,11 +36,8 @@
SUBDIR += jicofo
SUBDIR += jitsi-videobridge
SUBDIR += kaccounts-integration
- SUBDIR += kaccounts-providers
SUBDIR += kaidan
- SUBDIR += kde-telepathy
SUBDIR += kopete
- SUBDIR += ktp-accounts-kcm
SUBDIR += ktp-approver
SUBDIR += ktp-auth-handler
SUBDIR += ktp-call-ui
@@ -51,7 +48,6 @@
SUBDIR += ktp-filetransfer-handler
SUBDIR += ktp-kded-module
SUBDIR += ktp-send-file
- SUBDIR += ktp-text-ui
SUBDIR += libaccounts-glib
SUBDIR += libaccounts-qt5
SUBDIR += libmesode
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 1a200738fbe1..97f75e4f6286 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -94,7 +94,6 @@
SUBDIR += icingaweb2-module-idoreports
SUBDIR += icingaweb2-module-ipl
SUBDIR += icingaweb2-module-map
- SUBDIR += icingaweb2-module-pdfexport
SUBDIR += icingaweb2-module-reactbundle
SUBDIR += icingaweb2-module-reporting
SUBDIR += icingaweb2-module-vsphere
diff --git a/net-mgmt/icingaweb2-module-reporting/Makefile b/net-mgmt/icingaweb2-module-reporting/Makefile
index 3fadb3cc58df..611f3cd6509c 100644
--- a/net-mgmt/icingaweb2-module-reporting/Makefile
+++ b/net-mgmt/icingaweb2-module-reporting/Makefile
@@ -3,7 +3,7 @@
PORTNAME= icingaweb2-module-reporting
DISTVERSIONPREFIX= v
DISTVERSION= 0.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt www
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
@@ -22,11 +22,6 @@ USES= php:web,flavors
USE_GITHUB= yes
GH_ACCOUNT= icinga
-OPTIONS_DEFINE= PDF
-PDF_DESC= Use Chromium to export PDFs
-OPTIONS_DEFAULT= PDF
-PDF_RUN_DEPENDS= icingaweb2-module-pdfexport${PHP_PKGNAMESUFFIX}>=0.9:net-mgmt/icingaweb2-module-pdfexport@${PHP_FLAVOR}
-
NO_BUILD= yes
NO_ARCH= yes
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 4b92fd1fc4a6..65cd971b3ce9 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -33,13 +33,4 @@ WORKSPACE_USE= KDE=plasma-workspace
WORKSPACE_DESC= Shutdown on completion support
WORKSPACE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_LibKWorkspace
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == i386
-PLIST_SUB+= WEBENGINE=""
-USE_QT+= webengine
-.else
-PLIST_SUB+= WEBENGINE="@comment "
-.endif
-
.include <bsd.port.mk>
diff --git a/net-p2p/ktorrent/pkg-plist b/net-p2p/ktorrent/pkg-plist
index f9b5656381ea..2a90cac98f34 100644
--- a/net-p2p/ktorrent/pkg-plist
+++ b/net-p2p/ktorrent/pkg-plist
@@ -13,28 +13,18 @@ lib/libktcore.so.16.0.0
%%QT_PLUGINDIR%%/ktorrent/ktorrent_scanfolder.so
%%QT_PLUGINDIR%%/ktorrent/ktorrent_scanforlostfiles.so
%%QT_PLUGINDIR%%/ktorrent/ktorrent_scripting.so
-%%WEBENGINE%%%%QT_PLUGINDIR%%/ktorrent/ktorrent_search.so
%%WORKSPACE%%%%QT_PLUGINDIR%%/ktorrent/ktorrent_shutdown.so
%%QT_PLUGINDIR%%/ktorrent/ktorrent_stats.so
-%%WEBENGINE%%%%QT_PLUGINDIR%%/ktorrent/ktorrent_syndication.so
%%QT_PLUGINDIR%%/ktorrent/ktorrent_upnp.so
%%QT_PLUGINDIR%%/ktorrent/ktorrent_zeroconf.so
share/applications/org.kde.ktorrent.desktop
share/icons/hicolor/128x128/apps/ktorrent.png
-%%WEBENGINE%%share/icons/hicolor/16x16/actions/kt-add-feeds.png
-%%WEBENGINE%%share/icons/hicolor/16x16/actions/kt-add-filters.png
-%%WEBENGINE%%share/icons/hicolor/16x16/actions/kt-remove-feeds.png
-%%WEBENGINE%%share/icons/hicolor/16x16/actions/kt-remove-filters.png
share/icons/hicolor/16x16/actions/kt-stop-all.png
share/icons/hicolor/16x16/actions/kt-stop.png
share/icons/hicolor/16x16/actions/kt-upnp.png
share/icons/hicolor/16x16/apps/ktorrent.png
-%%WEBENGINE%%share/icons/hicolor/22x22/actions/kt-add-feeds.png
-%%WEBENGINE%%share/icons/hicolor/22x22/actions/kt-add-filters.png
share/icons/hicolor/22x22/actions/kt-magnet.png
share/icons/hicolor/22x22/actions/kt-pause.png
-%%WEBENGINE%%share/icons/hicolor/22x22/actions/kt-remove-feeds.png
-%%WEBENGINE%%share/icons/hicolor/22x22/actions/kt-remove-filters.png
share/icons/hicolor/22x22/actions/kt-remove.png
share/icons/hicolor/22x22/actions/kt-set-max-download-speed.png
share/icons/hicolor/22x22/actions/kt-set-max-upload-speed.png
@@ -44,14 +34,10 @@ share/icons/hicolor/22x22/actions/kt-start.png
share/icons/hicolor/22x22/actions/kt-stop-all.png
share/icons/hicolor/22x22/actions/kt-stop.png
share/icons/hicolor/22x22/apps/ktorrent.png
-%%WEBENGINE%%share/icons/hicolor/32x32/actions/kt-add-feeds.png
-%%WEBENGINE%%share/icons/hicolor/32x32/actions/kt-add-filters.png
share/icons/hicolor/32x32/actions/kt-info-widget.png
share/icons/hicolor/32x32/actions/kt-magnet.png
share/icons/hicolor/32x32/actions/kt-pause.png
share/icons/hicolor/32x32/actions/kt-queue-manager.png
-%%WEBENGINE%%share/icons/hicolor/32x32/actions/kt-remove-feeds.png
-%%WEBENGINE%%share/icons/hicolor/32x32/actions/kt-remove-filters.png
share/icons/hicolor/32x32/actions/kt-remove.png
share/icons/hicolor/32x32/actions/kt-set-max-download-speed.png
share/icons/hicolor/32x32/actions/kt-set-max-upload-speed.png
@@ -91,14 +77,6 @@ share/icons/hicolor/scalable/actions/kt-set-max-download-speed.svgz
share/icons/hicolor/scalable/actions/kt-set-max-upload-speed.svgz
share/icons/hicolor/scalable/actions/kt-speed-limits.svgz
share/knotifications5/ktorrent.notifyrc
-%%WEBENGINE%%%%DATADIR%%/opensearch/btdb.in/favicon.ico
-%%WEBENGINE%%%%DATADIR%%/opensearch/btdb.in/opensearch.xml
-%%WEBENGINE%%%%DATADIR%%/opensearch/btdig.com/favicon.ico
-%%WEBENGINE%%%%DATADIR%%/opensearch/btdig.com/opensearch.xml
-%%WEBENGINE%%%%DATADIR%%/opensearch/duckduckgo.com/favicon.ico
-%%WEBENGINE%%%%DATADIR%%/opensearch/duckduckgo.com/opensearch.xml
-%%WEBENGINE%%%%DATADIR%%/opensearch/torrentproject.se/favicon.ico
-%%WEBENGINE%%%%DATADIR%%/opensearch/torrentproject.se/opensearch.xml
%%DATADIR%%/scripts/auto_remove/auto_remove.desktop
%%DATADIR%%/scripts/auto_remove/auto_remove.py
%%DATADIR%%/scripts/auto_remove/auto_remove.ui
@@ -110,28 +88,12 @@ share/knotifications5/ktorrent.notifyrc
%%DATADIR%%/scripts/email_notifications/emailconfig.ui
%%DATADIR%%/scripts/tracker_groups/tracker_groups.desktop
%%DATADIR%%/scripts/tracker_groups/tracker_groups.py
-%%WEBENGINE%%%%DATADIR%%/search/home/body-background.jpg
-%%WEBENGINE%%%%DATADIR%%/search/home/box-bottom-left.png
-%%WEBENGINE%%%%DATADIR%%/search/home/box-bottom-middle.png
-%%WEBENGINE%%%%DATADIR%%/search/home/box-bottom-right.png
-%%WEBENGINE%%%%DATADIR%%/search/home/box-center.png
-%%WEBENGINE%%%%DATADIR%%/search/home/box-middle-left.png
-%%WEBENGINE%%%%DATADIR%%/search/home/box-middle-right.png
-%%WEBENGINE%%%%DATADIR%%/search/home/box-top-left.png
-%%WEBENGINE%%%%DATADIR%%/search/home/box-top-middle.png
-%%WEBENGINE%%%%DATADIR%%/search/home/box-top-right.png
-%%WEBENGINE%%%%DATADIR%%/search/home/home.css
-%%WEBENGINE%%%%DATADIR%%/search/home/home.html
-%%WEBENGINE%%%%DATADIR%%/search/home/ktorrent-icon.png
-%%WEBENGINE%%%%DATADIR%%/search/home/ktorrent_infopage.css
share/kxmlgui5/ktorrent/ktorrent_bwschedulerui.rc
share/kxmlgui5/ktorrent/ktorrent_downloadorderui.rc
share/kxmlgui5/ktorrent/ktorrent_magnetgeneratorui.rc
share/kxmlgui5/ktorrent/ktorrent_mediaplayerui.rc
share/kxmlgui5/ktorrent/ktorrent_scriptingui.rc
-%%WEBENGINE%%share/kxmlgui5/ktorrent/ktorrent_searchui.rc
%%WORKSPACE%%share/kxmlgui5/ktorrent/ktorrent_shutdownui.rc
-%%WEBENGINE%%share/kxmlgui5/ktorrent/ktorrent_syndicationui.rc
share/kxmlgui5/ktorrent/ktorrentui.rc
share/kxmlgui5/ktorrent/kttorrentactivityui.rc
share/locale/ar/LC_MESSAGES/ktorrent.mo
diff --git a/net/Makefile b/net/Makefile
index 3519b62de8a4..d5940f209c09 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -13,7 +13,6 @@
SUBDIR += addrwatch
SUBDIR += afpfs-ng
SUBDIR += aget
- SUBDIR += akonadi-calendar
SUBDIR += akonadi-contacts
SUBDIR += akonadi-mime
SUBDIR += akonadi-notes
@@ -73,7 +72,6 @@
SUBDIR += bwn-firmware-kmod
SUBDIR += bwping
SUBDIR += c3270
- SUBDIR += calendarsupport
SUBDIR += ccxstream
SUBDIR += ceph14
SUBDIR += cf
@@ -145,7 +143,6 @@
SUBDIR += erlang-ranch
SUBDIR += eternalterminal
SUBDIR += evans
- SUBDIR += eventviews
SUBDIR += exabgp4
SUBDIR += fb303
SUBDIR += fbzmq
@@ -258,7 +255,6 @@
SUBDIR += iipsrv
SUBDIR += ilbc
SUBDIR += imapproxy
- SUBDIR += incidenceeditor
SUBDIR += inlets
SUBDIR += intel-em-kmod
SUBDIR += intel-ix-kmod
@@ -307,12 +303,10 @@
SUBDIR += kget
SUBDIR += kidentitymanagement
SUBDIR += kimap
- SUBDIR += kio-gdrive
SUBDIR += kippo
SUBDIR += kissd
SUBDIR += kitinerary
SUBDIR += kldap
- SUBDIR += kmailtransport
SUBDIR += kmbox
SUBDIR += kmime
SUBDIR += knc
@@ -359,8 +353,6 @@
SUBDIR += libilbc
SUBDIR += libiscsi
SUBDIR += libjson-rpc-cpp
- SUBDIR += libkgapi
- SUBDIR += libksieve
SUBDIR += libkvkontakte
SUBDIR += liblinphone
SUBDIR += libmaia
@@ -387,7 +379,6 @@
SUBDIR += libproxy
SUBDIR += libproxy-gnome3
SUBDIR += libproxy-kde
- SUBDIR += libproxy-mozjs
SUBDIR += libproxy-perl
SUBDIR += libproxy-python
SUBDIR += libproxy-webkit3
@@ -425,7 +416,6 @@
SUBDIR += macchanger
SUBDIR += mad_fcl
SUBDIR += madonctl
- SUBDIR += mailcommon
SUBDIR += mailimporter
SUBDIR += malo-firmware-kmod
SUBDIR += mcjoin
@@ -434,7 +424,6 @@
SUBDIR += mediastreamer
SUBDIR += megacmd
SUBDIR += megatools
- SUBDIR += messagelib
SUBDIR += mgen
SUBDIR += micro_inetd
SUBDIR += micro_proxy
@@ -524,7 +513,6 @@
SUBDIR += ocserv
SUBDIR += olsrd
SUBDIR += omnitty
- SUBDIR += onedrive
SUBDIR += onenetd
SUBDIR += onioncat
SUBDIR += ooni-mini
@@ -533,7 +521,6 @@
SUBDIR += open-isns
SUBDIR += openbgpd
SUBDIR += openbgpd6
- SUBDIR += openggsn
SUBDIR += openldap24-client
SUBDIR += openldap24-sasl-client
SUBDIR += openldap24-server
diff --git a/net/kamailio/pkg-plist b/net/kamailio/pkg-plist
index b5747a23aef1..1de77fed5efd 100644
--- a/net/kamailio/pkg-plist
+++ b/net/kamailio/pkg-plist
@@ -394,8 +394,8 @@
%%PRESENCE%%lib/kamailio/modules/rls.so
%%PRESENCE%%lib/kamailio/modules/xcap_client.so
%%PRESENCE%%lib/kamailio/modules/xcap_server.so
-%%PYTHON3%%%%PORTDOCS%%%%DOCSDIR%%/modules/README.app_python3
-%%PYTHON3%%lib/kamailio/modules/app_python3.so
+%%PORTDOCS%%%%DOCSDIR%%/modules/README.app_python3
+lib/kamailio/modules/app_python3.so
%%RADIUS%%%%PORTDOCS%%%%DOCSDIR%%/modules/README.acc_radius
%%RADIUS%%%%PORTDOCS%%%%DOCSDIR%%/modules/README.auth_radius
%%RADIUS%%%%PORTDOCS%%%%DOCSDIR%%/modules/README.misc_radius
diff --git a/print/Makefile b/print/Makefile
index 73e28ac41ff8..1fea0c585607 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -30,7 +30,6 @@
SUBDIR += cups-pk-helper
SUBDIR += cups-smb-backend
SUBDIR += deforaos-pdfviewer
- SUBDIR += derelict-ft
SUBDIR += detex
SUBDIR += dot2tex
SUBDIR += dvi2tty
@@ -178,7 +177,6 @@
SUBDIR += py-fonttools
SUBDIR += py-fonttools3
SUBDIR += py-fpdf
- SUBDIR += py-frescobaldi
SUBDIR += py-pdf
SUBDIR += py-pdf2
SUBDIR += py-pollyreports
diff --git a/russian/Makefile b/russian/Makefile
index 28a29244092c..876e27d87a42 100644
--- a/russian/Makefile
+++ b/russian/Makefile
@@ -8,7 +8,6 @@
SUBDIR += bugzilla44
SUBDIR += d1489
SUBDIR += emkatic
- SUBDIR += eric6
SUBDIR += gd
SUBDIR += hunspell
SUBDIR += hyphen
diff --git a/science/py-dlib/Makefile b/science/py-dlib/Makefile
index 8a3fe703ca2f..3616dce5ba7d 100644
--- a/science/py-dlib/Makefile
+++ b/science/py-dlib/Makefile
@@ -49,6 +49,4 @@ AVX_VARS_OFF= avxargs="--no USE_AVX_INSTRUCTIONS"
PYDISTUTILS_BUILDARGS= --set BOOST_PYTHON_SUFFIX:STRING=${PYTHON_SUFFIX} ${X11ARGS} ${JPEGARGS} ${PNGARGS} ${GIFARGS} ${SQLITEARGS} ${BLASLAPACKARGS} ${AVXARGS} ${BLASLAPACK}
-PLIST_SUB= PYTHON2="@comment " PYTHON3=""
-
.include <bsd.port.mk>
diff --git a/science/py-dlib/pkg-plist b/science/py-dlib/pkg-plist
index 6dd59d547748..cca765735f7f 100644
--- a/science/py-dlib/pkg-plist
+++ b/science/py-dlib/pkg-plist
@@ -1,5 +1,3 @@
%%PYTHON_SITELIBDIR%%/dlib/__init__.py
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/dlib/__init__.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/dlib/__init__.pyo
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/dlib/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/dlib/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/dlib/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/dlib/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
diff --git a/sysutils/Makefile b/sysutils/Makefile
index f533053d3b0d..42c24483dd77 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1416,7 +1416,6 @@
SUBDIR += ucspi-unix
SUBDIR += udfclient
SUBDIR += uefi-edk2-bhyve
- SUBDIR += uefi-edk2-bhyve-csm
SUBDIR += uefi-edk2-qemu
SUBDIR += ufetch
SUBDIR += ufs_copy
@@ -1432,7 +1431,6 @@
SUBDIR += uptimed
SUBDIR += usb_modeswitch
SUBDIR += usbhid-dump
- SUBDIR += usbhotkey
SUBDIR += usbtop
SUBDIR += usbutils
SUBDIR += uschedule
diff --git a/sysutils/bhyve-firmware/Makefile b/sysutils/bhyve-firmware/Makefile
index 8a725dc39af3..7c9515332fe8 100644
--- a/sysutils/bhyve-firmware/Makefile
+++ b/sysutils/bhyve-firmware/Makefile
@@ -11,9 +11,5 @@ COMMENT= Collection of Firmware for bhyve
RUN_DEPENDS= uefi-edk2-bhyve>=0:sysutils/uefi-edk2-bhyve
USES= metaport
-OPTIONS_DEFINE= CSM
-OPTIONS_DEFAULT= CSM
-CSM_DESC= Include firmware with Compatibility Support Module
-CSM_RUN_DEPENDS= uefi-edk2-bhyve-csm>=0:sysutils/uefi-edk2-bhyve-csm
.include <bsd.port.mk>
diff --git a/sysutils/plasma5-libksysguard/Makefile b/sysutils/plasma5-libksysguard/Makefile
index b3dda94af0d2..90b1c25e5b1c 100644
--- a/sysutils/plasma5-libksysguard/Makefile
+++ b/sysutils/plasma5-libksysguard/Makefile
@@ -15,11 +15,6 @@ USE_KDE= auth codecs completion config configwidgets coreaddons \
USE_QT= concurrent core dbus declarative gui network script webkit \
widgets x11extras xml \
buildtools_build qmake_build
-
-OPTIONS_DEFINE= WEBENGINE
-
-WEBENGINE_USE= QT=webengine
-WEBENGINE_DESC= HTML-based GUI ksysguard library based on Qt5WebEngine
-WEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
+CMAKE_ARGS= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets:BOOL=false
.include <bsd.port.mk>
diff --git a/sysutils/py-salt-2019/pkg-plist b/sysutils/py-salt-2019/pkg-plist
index 8af3d8958fa3..64e13fed1a50 100644
--- a/sysutils/py-salt-2019/pkg-plist
+++ b/sysutils/py-salt-2019/pkg-plist
@@ -1,7 +1,5 @@
@sample %%ETCDIR%%/master.sample
@sample %%ETCDIR%%/minion.sample
%%PYTHON_SITELIBDIR%%/salt/_syspaths.py
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/salt/_syspaths.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/salt/_syspaths.pyo
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/salt/__pycache__/_syspaths.cpython-%%PYTHON_SUFFIX%%.pyc
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/salt/__pycache__/_syspaths.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/salt/__pycache__/_syspaths.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/salt/__pycache__/_syspaths.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
diff --git a/sysutils/py-salt/pkg-plist b/sysutils/py-salt/pkg-plist
index 8af3d8958fa3..64e13fed1a50 100644
--- a/sysutils/py-salt/pkg-plist
+++ b/sysutils/py-salt/pkg-plist
@@ -1,7 +1,5 @@
@sample %%ETCDIR%%/master.sample
@sample %%ETCDIR%%/minion.sample
%%PYTHON_SITELIBDIR%%/salt/_syspaths.py
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/salt/_syspaths.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/salt/_syspaths.pyo
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/salt/__pycache__/_syspaths.cpython-%%PYTHON_SUFFIX%%.pyc
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/salt/__pycache__/_syspaths.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/salt/__pycache__/_syspaths.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/salt/__pycache__/_syspaths.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
diff --git a/textproc/Makefile b/textproc/Makefile
index 9677bb5ede9d..2a28ff5fc910 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -329,8 +329,6 @@
SUBDIR += kf5-kcodecs
SUBDIR += kf5-sonnet
SUBDIR += kf5-syntax-highlighting
- SUBDIR += kibana6
- SUBDIR += kibana7
SUBDIR += kiss-templates
SUBDIR += kmfl-european-latin
SUBDIR += kmfl-khmer
@@ -1144,7 +1142,6 @@
SUBDIR += p5-podlators
SUBDIR += p5-xmltv
SUBDIR += pa-aspell
- SUBDIR += pageedit
SUBDIR += par
SUBDIR += pdfgrep
SUBDIR += pdfoutline
@@ -1762,7 +1759,6 @@
SUBDIR += sgrep
SUBDIR += sgrep2
SUBDIR += sift
- SUBDIR += sigil
SUBDIR += sk-aspell
SUBDIR += sk-hunspell
SUBDIR += sk-hyphen
diff --git a/textproc/py-markupsafe/Makefile b/textproc/py-markupsafe/Makefile
index ca177cd3eb66..13653809333c 100644
--- a/textproc/py-markupsafe/Makefile
+++ b/textproc/py-markupsafe/Makefile
@@ -15,7 +15,7 @@ COMMENT= Implements XML/HTML/XHTML Markup safe string for Python
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.rst
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
post-install:
diff --git a/textproc/py-pygments-25/Makefile b/textproc/py-pygments-25/Makefile
index ed7d83e26879..c598f37bc057 100644
--- a/textproc/py-pygments-25/Makefile
+++ b/textproc/py-pygments-25/Makefile
@@ -16,7 +16,7 @@ COMMENT= Syntax highlighter written in Python
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:2.7+
+USES= python
USE_PYTHON= distutils concurrent autoplist
CONFLICTS_INSTALL= py??-pygments
diff --git a/textproc/py-toml/Makefile b/textproc/py-toml/Makefile
index 2ef4da6b61a3..cf85279d69fe 100644
--- a/textproc/py-toml/Makefile
+++ b/textproc/py-toml/Makefile
@@ -13,7 +13,7 @@ COMMENT= Python library for parsing and creating TOML
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/www/Makefile b/www/Makefile
index 9d77d5570ec1..ed46dc4a91ec 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -38,8 +38,6 @@
SUBDIR += asql
SUBDIR += authelia
SUBDIR += awffull
- SUBDIR += aws
- SUBDIR += aws-demos
SUBDIR += awstats
SUBDIR += axis2
SUBDIR += bacula-web
@@ -79,7 +77,6 @@
SUBDIR += choqok
SUBDIR += chpasswd
SUBDIR += chrome-gnome-shell
- SUBDIR += chromium
SUBDIR += ckeditor
SUBDIR += cl-lml
SUBDIR += cl-lml-sbcl
@@ -155,7 +152,6 @@
SUBDIR += erlang-mochiweb-basho
SUBDIR += erlang-webmachine
SUBDIR += fabio
- SUBDIR += falkon
SUBDIR += fancybox
SUBDIR += faup
SUBDIR += fcgi
@@ -412,7 +408,6 @@
SUBDIR += mod_xmlns
SUBDIR += mod_xsendfile
SUBDIR += mohawk
- SUBDIR += moinmoin
SUBDIR += moinmoincli
SUBDIR += mongoose
SUBDIR += mongrel2
@@ -458,8 +453,6 @@
SUBDIR += nibbleblog
SUBDIR += nift
SUBDIR += node
- SUBDIR += node10
- SUBDIR += node12
SUBDIR += node14
SUBDIR += nostromo
SUBDIR += novnc
@@ -467,8 +460,6 @@
SUBDIR += npapi-xine
SUBDIR += npc
SUBDIR += npm
- SUBDIR += npm-node10
- SUBDIR += npm-node12
SUBDIR += npm-node14
SUBDIR += nspluginwrapper
SUBDIR += oauth2-proxy
@@ -1774,7 +1765,6 @@
SUBDIR += qdecoder
SUBDIR += qhttpengine
SUBDIR += qt5-webchannel
- SUBDIR += qt5-webengine
SUBDIR += qt5-webglplugin
SUBDIR += qt5-webkit
SUBDIR += qt5-websockets
@@ -2303,8 +2293,6 @@
SUBDIR += yabb
SUBDIR += yanopaste
SUBDIR += yarn
- SUBDIR += yarn-node10
- SUBDIR += yarn-node12
SUBDIR += yarn-node14
SUBDIR += yaws
SUBDIR += you-get
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 616a2e431d51..3850ad520507 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -20,14 +20,12 @@ NO_ARCH= yes
NO_BUILD= yes
REINPLACE_ARGS= -i ''
-CONFLICTS_INSTALL?= npm-node10 npm-node12 npm-node14
+CONFLICTS_INSTALL?= npm-node14
OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE NODE10 NODE12 NODE14
+OPTIONS_SINGLE_BACKEND= NODE NODE14
OPTIONS_DEFAULT=NODE
NODE_DESC= Use Node.js 15.x (www/node) as backend
-NODE10_DESC= Use Node.js 10.x (www/node10) as backend
-NODE12_DESC= Use Node.js 12.x (www/node12) as backend
NODE14_DESC= Use Node.js 14.x (www/node14) as backend
CPE_VENDOR= npmjs
@@ -37,8 +35,6 @@ SHEBANG_GLOB= *.py
SHEBANG_FILES= lib/node_modules/npm/node_modules/node-gyp/gyp/samples/samples
NODE_RUN_DEPENDS= node>=0.8.0:www/node
-NODE10_RUN_DEPENDS= node10>=0.8.0:www/node10
-NODE12_RUN_DEPENDS= node12>=0.8.0:www/node12
NODE14_RUN_DEPENDS= node14>=0.8.0:www/node14
.include <bsd.port.pre.mk>
diff --git a/www/otter-browser/Makefile b/www/otter-browser/Makefile
index b7322bc3cd61..7360c73e9f9c 100644
--- a/www/otter-browser/Makefile
+++ b/www/otter-browser/Makefile
@@ -32,17 +32,11 @@ GH_ACCOUNT= OtterBrowser
# GH_TAGNAME= 22de58d # For intermediate versions only
OPTIONS_MULTI= BACKEND
-OPTIONS_MULTI_BACKEND= QTWEBENGINE QTWEBKIT
+OPTIONS_MULTI_BACKEND= QTWEBKIT
OPTIONS_DEFAULT= QTWEBKIT
-OPTIONS_DEFAULT_amd64= QTWEBENGINE
-OPTIONS_DEFAULT_i386= QTWEBENGINE
-QTWEBENGINE_DESC= Build QtWebEngine backend
QTWEBKIT_DESC= Build QtWebKit backend
-QTWEBENGINE_USE= qt=declarative,location,webchannel,webengine
-QTWEBENGINE_CMAKE_BOOL= ENABLE_QTWEBENGINE
-
QTWEBKIT_USE= qt=webkit
QTWEBKIT_CMAKE_BOOL= ENABLE_QTWEBKIT
diff --git a/www/py-html5lib/Makefile b/www/py-html5lib/Makefile
index 04c44ce6dbbd..6e2aeb974c56 100644
--- a/www/py-html5lib/Makefile
+++ b/www/py-html5lib/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}webencodings>0:converters/py-webencodings@${PY_FLAVOR}
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/www/qt5-webview/Makefile b/www/qt5-webview/Makefile
index a77637da3d53..3072cae01384 100644
--- a/www/qt5-webview/Makefile
+++ b/www/qt5-webview/Makefile
@@ -14,13 +14,4 @@ USE_GL= gl
USE_QT= core declarative gui location network webchannel \
buildtools_build
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64 || ${ARCH} == i386
-PLIST_SUB+= WEBENGINE=""
-USE_QT+= webengine
-.else
-PLIST_SUB+= WEBENGINE="@comment "
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/qt5-webview/pkg-plist b/www/qt5-webview/pkg-plist
index 75774743f10b..8493fa99280d 100644
--- a/www/qt5-webview/pkg-plist
+++ b/www/qt5-webview/pkg-plist
@@ -16,7 +16,6 @@
%%QT_INCDIR%%/QtWebView/qwebview_global.h
%%QT_CMAKEDIR%%/Qt5WebView/Qt5WebViewConfig.cmake
%%QT_CMAKEDIR%%/Qt5WebView/Qt5WebViewConfigVersion.cmake
-%%WEBENGINE%%%%QT_CMAKEDIR%%/Qt5WebView/Qt5WebView_QWebEngineWebViewPlugin.cmake
%%QT_LIBDIR%%/libQt5WebView.prl
%%QT_LIBDIR%%/libQt5WebView.so
%%QT_LIBDIR%%/libQt5WebView.so.5
@@ -25,7 +24,6 @@
%%DEBUG%%%%QT_LIBDIR%%/libQt5WebView.so.%%FULLVER%%.debug
%%QT_MKSPECDIR%%/modules/qt_lib_webview.pri
%%QT_MKSPECDIR%%/modules/qt_lib_webview_private.pri
-%%WEBENGINE%%%%QT_PLUGINDIR%%/webview/libqtwebview_webengine.so
%%DEBUG%%%%QT_PLUGINDIR%%/webview/libqtwebview_webengine.so.debug
%%QT_QMLDIR%%/QtWebView/libdeclarative_webview.so
%%DEBUG%%%%QT_QMLDIR%%/QtWebView/libdeclarative_webview.so.debug
diff --git a/www/qutebrowser/Makefile b/www/qutebrowser/Makefile
index 3f8050c51761..0c45ac00cd60 100644
--- a/www/qutebrowser/Makefile
+++ b/www/qutebrowser/Makefile
@@ -31,15 +31,10 @@ PLIST_FILES= share/applications/${PORTNAME}-${PYTHON_VER}.desktop
EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
OPTIONS_MULTI= BACKEND
-OPTIONS_MULTI_BACKEND= WEBKIT WEBENGINE
+OPTIONS_MULTI_BACKEND= WEBKIT
OPTIONS_DEFAULT= WEBKIT
-OPTIONS_DEFAULT_amd64= WEBENGINE
-OPTIONS_DEFAULT_i386= WEBENGINE
-
-WEBENGINE_DESC= WebEngine webpage renderer support
WEBKIT_USE= PYQT=webkit,webkitwidgets
-WEBENGINE_USE= PYQT=webengine,webchannel
.include <bsd.port.pre.mk>
diff --git a/www/sahi/Makefile b/www/sahi/Makefile
index 3f3ca208ce63..306c952e00d3 100644
--- a/www/sahi/Makefile
+++ b/www/sahi/Makefile
@@ -3,8 +3,7 @@
PORTNAME= sahi
PORTVERSION= 3.5.${SAHI_BUILD}
-#PORTREVISION= 0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-v${PORTVERSION:R:R:R:S,.,,}/${SAHI_BUILD:S,.,,g}/
DISTNAME= ${PORTNAME}_${SAHI_BUILD:S,.,,g}
@@ -25,11 +24,10 @@ JAVA_RUN= yes
NO_BUILD= yes
OPTIONS_DEFINE= DOCS
-OPTIONS_DEFAULT= CHROME
+OPTIONS_DEFAULT= FIREFOX
OPTIONS_SINGLE= BROWSER
-OPTIONS_SINGLE_BROWSER= CHROME FIREFOX OPERA
+OPTIONS_SINGLE_BROWSER= FIREFOX OPERA
-CHROME_DESC= Use Chrome as default browser
FIREFOX_DESC= Use Firefox as default browser
OPERA_DESC= Use Opera as default browser
@@ -54,7 +52,6 @@ post-patch:
@${FIND} ${WRKSRC} -type f \( -name "*.sh" -or -name "linux.xml" \
-or -name "sahi.properties" \) -print0 \
| ${XARGS} -0 ${REINPLACE_CMD} -E \
- -e 's,%%CHROME%%,${LOCALBASE}/bin/chrome,g' \
-e 's,%%DATADIR%%,${DATADIR},g' \
-e 's,%%FIREFOX%%,${LOCALBASE}/bin/firefox,g' \
-e 's,%%JAVA%%,${JAVA},g' \
@@ -80,11 +77,6 @@ do-install:
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MCHROME}
-BROWSER= chrome
-RUN_DEPENDS+= chrome:www/chromium
-.endif
-
.if ${PORT_OPTIONS:MFIREFOX}
BROWSER= firefox
RUN_DEPENDS+= firefox:www/firefox
diff --git a/www/yarn/Makefile b/www/yarn/Makefile
index 5cf89a222587..2a474a3021fc 100644
--- a/www/yarn/Makefile
+++ b/www/yarn/Makefile
@@ -12,24 +12,20 @@ COMMENT= Package manager for node, alternative to npm
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-CONFLICTS_INSTALL?= yarn-node14 yarn-node12 yarn-node10
+CONFLICTS_INSTALL?= yarn-node14
OPTIONS_DEFINE= HADOOPCOMPAT
OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE10 NODE12 NODE14 NODE
+OPTIONS_SINGLE_BACKEND= NODE14 NODE
OPTIONS_DEFAULT= NODE
HADOOPCOMPAT_DESC= hadoop2 compatibility, the yarn script is excluded
NODE_DESC= Use www/node as backend
NODE14_DESC= Use www/node14 as backend
-NODE12_DESC= Use www/node12 as backend
-NODE10_DESC= Use www/node10 as backend
OPTIONS_SUB= yes
NODE_RUN_DEPENDS= node>=0.8.0:www/node
NODE14_RUN_DEPENDS= node14>=14.0.0:www/node14
-NODE12_RUN_DEPENDS= node12>=12.0.0:www/node12
-NODE10_RUN_DEPENDS= node10>=10.0.0:www/node10
HADOOPCOMPAT_CONFLICTS_INSTALL_OFF= hadoop2*
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index b1664d2b23bb..c60451f4d4b2 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -12,7 +12,6 @@
SUBDIR += fsv2
SUBDIR += gentoo
SUBDIR += gprename
- SUBDIR += konqueror
SUBDIR += krusader2
SUBDIR += librfm
SUBDIR += libtubo
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 3cac756048d4..e3da66e7e7f9 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -36,7 +36,6 @@
SUBDIR += gtk30
SUBDIR += gtkada
SUBDIR += gtkada3
- SUBDIR += gtkd
SUBDIR += gtkdatabox
SUBDIR += gtkextra
SUBDIR += gtkglarea2
@@ -171,7 +170,6 @@
SUBDIR += py-tktreectrl
SUBDIR += py-wxPython40
SUBDIR += py-xlib
- SUBDIR += pypy-tkinter
SUBDIR += qml-box2d
SUBDIR += qt5-charts
SUBDIR += qt5-datavis3d
diff --git a/x11-toolkits/plasma5-kdeplasma-addons/Makefile b/x11-toolkits/plasma5-kdeplasma-addons/Makefile
index 913704e7f4e4..f937382fa5a3 100644
--- a/x11-toolkits/plasma5-kdeplasma-addons/Makefile
+++ b/x11-toolkits/plasma5-kdeplasma-addons/Makefile
@@ -18,19 +18,13 @@ USE_KDE= activities archive attica auth bookmarks codecs completion \
USE_QT= concurrent core dbus declarative graphicaleffects gui location network \
printsupport script webchannel widgets x11extras xml \
buildtools_build qmake_build
-
-OPTIONS_DEFINE= PURPOSE QTWEBENGINE
+CMAKE_ARSG= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine:BOOL=false
+OPTIONS_DEFINE= PURPOSE
OPTIONS_DEFAULT= PURPOSE
-OPTIONS_DEFAULT_amd64= QTWEBENGINE
-OPTIONS_DEFAULT_i386= QTWEBENGINE
OPTIONS_SUB= YES
PURPOSE_DESC= Enable 'QuickShare' applet
PURPOSE_USE= KDE=purpose
PURPOSE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_KF5Purpose
-QTWEBENGINE_DESC= Add dependency on qt5-webengine
-QTWEBENGINE_USE= qt=webengine
-QTWEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine
-
.include <bsd.port.mk>
diff --git a/x11-toolkits/plasma5-kdeplasma-addons/pkg-plist b/x11-toolkits/plasma5-kdeplasma-addons/pkg-plist
index b68ece49d838..cdf188ab008a 100644
--- a/x11-toolkits/plasma5-kdeplasma-addons/pkg-plist
+++ b/x11-toolkits/plasma5-kdeplasma-addons/pkg-plist
@@ -39,9 +39,6 @@ lib/libplasmapotdprovidercore.so.1.0.0
%%QT_PLUGINDIR%%/potd/plasma_potd_unsplashprovider.so
%%QT_PLUGINDIR%%/potd/plasma_potd_wcpotdprovider.so
%%QT_QMLDIR%%/org/kde/plasma/private/colorpicker/libcolorpickerplugin.so
-%%QTWEBENGINE%%%%QT_QMLDIR%%/org/kde/plasma/private/colorpicker/qmldir
-%%QTWEBENGINE%%%%QT_QMLDIR%%/org/kde/plasma/private/dict/libdictplugin.so
-%%QTWEBENGINE%%%%QT_QMLDIR%%/org/kde/plasma/private/dict/qmldir
%%QT_QMLDIR%%/org/kde/plasma/private/diskquota/libdiskquotaplugin.so
%%QT_QMLDIR%%/org/kde/plasma/private/diskquota/qmldir
%%QT_QMLDIR%%/org/kde/plasma/private/fifteenpuzzle/libfifteenpuzzleplugin.so
@@ -62,7 +59,6 @@ lib/libplasmapotdprovidercore.so.1.0.0
%%QT_QMLDIR%%/org/kde/plasma/private/weather/qmldir
%%QT_QMLDIR%%/org/kde/plasmacalendar/astronomicaleventsconfig/libplasmacalendarastronomicaleventsconfig.so
%%QT_QMLDIR%%/org/kde/plasmacalendar/astronomicaleventsconfig/qmldir
-%%QTWEBENGINE%%share/icons/hicolor/scalable/apps/accessories-dictionary.svgz
share/icons/hicolor/scalable/apps/fifteenpuzzle.svgz
share/kdevappwizard/templates/plasmapotdprovider.tar.bz2
share/knsrcfiles/comic.knsrc
@@ -96,8 +92,6 @@ share/kservices5/plasma-applet-org.kde.plasma.systemloadviewer.desktop
share/kservices5/plasma-applet-org.kde.plasma.timer.desktop
share/kservices5/plasma-applet-org.kde.plasma.userswitcher.desktop
share/kservices5/plasma-applet-org.kde.plasma.weather.desktop
-%%QTWEBENGINE%%share/kservices5/plasma-applet-org.kde.plasma.webbrowser.desktop
-%%QTWEBENGINE%%share/kservices5/plasma-applet-org.kde.plasma_applet_dict.desktop
share/kservices5/plasma-applet-org.kde.plasma.nightcolorcontrol.desktop
share/kservices5/plasma-dataengine-comic.desktop
share/kservices5/plasma-dataengine-konsoleprofiles.desktop
@@ -1726,7 +1720,6 @@ share/locale/zh_TW/LC_MESSAGES/plasma_wallpaper_org.kde.potd.mo
share/metainfo/org.kde.haenau.appdata.xml
share/metainfo/org.kde.hunyango.appdata.xml
share/metainfo/org.kde.plasma.activitypager.appdata.xml
-%%QTWEBENGINE%%share/metainfo/org.kde.plasma_applet_dict.appdata.xml
share/metainfo/org.kde.plasma.binaryclock.appdata.xml
share/metainfo/org.kde.plasma.calculator.appdata.xml
share/metainfo/org.kde.plasma.colorpicker.appdata.xml
@@ -1747,7 +1740,6 @@ share/metainfo/org.kde.plasma.systemloadviewer.appdata.xml
share/metainfo/org.kde.plasma.timer.appdata.xml
share/metainfo/org.kde.plasma.userswitcher.appdata.xml
share/metainfo/org.kde.plasma.weather.appdata.xml
-%%QTWEBENGINE%%share/metainfo/org.kde.plasma.webbrowser.appdata.xml
share/metainfo/org.kde.potd.appdata.xml
share/plasma/desktoptheme/default/weather/wind-arrows.svgz
share/plasma/desktoptheme/default/widgets/timer.svgz
@@ -1907,17 +1899,6 @@ share/plasma/plasmoids/org.kde.plasma.weather/contents/ui/config/WeatherStationP
share/plasma/plasmoids/org.kde.plasma.weather/contents/ui/main.qml
share/plasma/plasmoids/org.kde.plasma.weather/metadata.desktop
share/plasma/plasmoids/org.kde.plasma.weather/metadata.json
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma.webbrowser/contents/config/config.qml
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma.webbrowser/contents/config/main.xml
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma.webbrowser/contents/ui/ConfigGeneral.qml
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma.webbrowser/contents/ui/main.qml
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma.webbrowser/metadata.desktop
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma.webbrowser/metadata.json
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma_applet_dict/contents/config/config.qml
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma_applet_dict/contents/ui/ConfigDictionaries.qml
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma_applet_dict/contents/ui/main.qml
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma_applet_dict/metadata.desktop
-%%QTWEBENGINE%%share/plasma/plasmoids/org.kde.plasma_applet_dict/metadata.json
share/plasma/services/org.kde.plasma.dataengine.konsoleprofiles.operations
share/plasma/wallpapers/org.kde.haenau/contents/ui/BackgroundElement.qml
share/plasma/wallpapers/org.kde.haenau/contents/ui/BottomBackgroundElement.qml
diff --git a/x11-toolkits/py-tkinter/Makefile b/x11-toolkits/py-tkinter/Makefile
index 8f14609bdab9..8156480b390f 100644
--- a/x11-toolkits/py-tkinter/Makefile
+++ b/x11-toolkits/py-tkinter/Makefile
@@ -16,7 +16,7 @@ LICENSE= PSFL
PORTSCOUT= ignore:1
-USES= compiler:c11 python:2.7+ tar:xz tk
+USES= compiler:c11 python tar:xz tk
USE_PYTHON= distutils autoplist allflavors
DIST_SUBDIR= python
@@ -25,13 +25,7 @@ WRKSRC= ${WRKDIR}/Python-${PORTVERSION}/Modules
PYDISTUTILS_INSTALLARGS+= --install-lib ${PYTHON_LIBDIR}/lib-dynload
-.include <bsd.port.pre.mk>
-
post-extract:
-.if ${PYTHON_REL} < 3000
- @${SED} -e "s|%%TK_VER%%|${TK_VER}|" ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-.else
@${SED} -e "s|%%TK_VER%%|${TK_VER}|" ${FILESDIR}/setup3.py > ${WRKSRC}/setup.py
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/Makefile b/x11/Makefile
index fbf5c4da7d60..3b5980745923 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -286,7 +286,6 @@
SUBDIR += qt5-qev
SUBDIR += qt5-x11extras
SUBDIR += qterminal
- SUBDIR += radare-cutter
SUBDIR += remontoire
SUBDIR += rendercheck
SUBDIR += rgb
@@ -339,7 +338,6 @@
SUBDIR += thinglaunch
SUBDIR += thingylaunch
SUBDIR += tilda
- SUBDIR += tilix
SUBDIR += tint
SUBDIR += trayer
SUBDIR += tycoon
diff --git a/x11/kde-baseapps/Makefile b/x11/kde-baseapps/Makefile
index 44e781bd1855..8982f4bf3240 100644
--- a/x11/kde-baseapps/Makefile
+++ b/x11/kde-baseapps/Makefile
@@ -17,7 +17,6 @@ RUN_DEPENDS= dolphin>=${KDE_APPLICATIONS_VERSION}:x11-fm/dolphin \
keditbookmarks>=${KDE_APPLICATIONS_VERSION}:deskutils/keditbookmarks \
khelpcenter>=${KDE_APPLICATIONS_VERSION}:sysutils/khelpcenter \
konsole>=${KDE_APPLICATIONS_VERSION}:x11/konsole \
- konqueror>=${KDE_APPLICATIONS_VERSION}:x11-fm/konqueror \
okular>=${KDE_APPLICATIONS_VERSION}:graphics/okular
.include <bsd.port.mk>
diff --git a/x11/kde5/Makefile b/x11/kde5/Makefile
index ffd83c3b7c37..f1b893f61781 100644
--- a/x11/kde5/Makefile
+++ b/x11/kde5/Makefile
@@ -18,7 +18,7 @@ USE_QT= # empty
OPTIONS_DEFINE= KDEADMIN KDEEDU \
KDEGAMES KDEGRAPHICS KDEMULTIMEDIA KDENETWORK \
- KDEPIM KDEUTILS \
+ KDEUTILS \
PULSEAUDIO
OPTIONS_DEFAULT=${OPTIONS_DEFINE:NPULSEAUDIO}
@@ -41,9 +41,6 @@ KDEMULTIMEDIA_RUN_DEPENDS= kdemultimedia>=${KDE_APPLICATIONS_VERSION}:multimedia
KDENETWORK_DESC= Network-related programs
KDENETWORK_RUN_DEPENDS= kdenetwork>=${KDE_APPLICATIONS_VERSION}:net/kdenetwork
-KDEPIM_DESC= Personal information management
-KDEPIM_RUN_DEPENDS= kdepim>=${KDE_APPLICATIONS_VERSION}:deskutils/kdepim
-
KDEUTILS_DESC= Collection of utilities for KDE
KDEUTILS_RUN_DEPENDS= kdeutils>=${KDE_APPLICATIONS_VERSION}:misc/kdeutils
diff --git a/x11/py-xcffib/pkg-plist b/x11/py-xcffib/pkg-plist
index e8aaecab66f0..49af87ad0541 100644
--- a/x11/py-xcffib/pkg-plist
+++ b/x11/py-xcffib/pkg-plist
@@ -1,5 +1,3 @@
%%PYTHON_SITELIBDIR%%/xcffib/_ffi.py
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/xcffib/_ffi.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/xcffib/_ffi.pyo
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/xcffib/__pycache__/_ffi.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/xcffib/__pycache__/_ffi.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/xcffib/__pycache__/_ffi.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/xcffib/__pycache__/_ffi.cpython-%%PYTHON_SUFFIX%%.pyc

Event Timeline

rene created this object in space S1 Global.
rene changed the title of this paste from Ports (recursively) depending on lang/python27 to Simplified diff (i.e. without removed ports themselves) of no-py27 against r564738, INDEX builds.Mon, Feb 8, 9:30 PM
rene edited the content of this paste. (Show Details)
rene changed the title of this paste from Simplified diff (i.e. without removed ports themselves) of no-py27 against r564738, INDEX builds to Simplified diff (i.e. without removed ports themselves) of no-py27 against r564895, INDEX builds.Wed, Feb 10, 9:14 PM
rene edited the content of this paste. (Show Details)
rene changed the title of this paste from Simplified diff (i.e. without removed ports themselves) of no-py27 against r564895, INDEX builds to Simplified diff (i.e. without removed ports themselves) of no-py27 against r565250, INDEX builds.Sun, Feb 14, 7:12 PM
rene edited the content of this paste. (Show Details)
rene changed the title of this paste from Simplified diff (i.e. without removed ports themselves) of no-py27 against r565250, INDEX builds to Simplified diff (i.e. without removed ports themselves) of no-py27 against r565260, INDEX builds.Sun, Feb 14, 8:02 PM
rene edited the content of this paste. (Show Details)
rene changed the title of this paste from Simplified diff (i.e. without removed ports themselves) of no-py27 against r565260, INDEX builds to Simplified diff (i.e. without removed ports themselves) of no-py27 against r566185, INDEX builds (for real).Sat, Feb 20, 9:11 PM
rene edited the content of this paste. (Show Details)