Page MenuHomeFreeBSD

xen/intr: rename evtchn_cpu_(un)?mask_port() to xen_intr_*()
Needs ReviewPublic

Authored by ehem_freebsd_m5p.com on Aug 29 2021, 9:39 PM.

Details

Reviewers
royger
Summary

Having these named evtchn_*() hints they are part of the core event
channel code, rather than part of the interrupt portion. This can
confuse when trying to do adjustments strictly effecting the interrupt
portion.

Diff Detail

Repository
rS FreeBSD src repository - subversion
Lint
Lint OK
Unit
No Unit Test Coverage
Build Status
Buildable 41254
Build 38143: arc lint + arc unit

Event Timeline

This was split off of D30743. This one doesn't fit that well with the rest. This is also much lower value and not urgently needed.