Page MenuHomeFreeBSD

Revert meld upgrade, version 3.21.0 fails to run
ClosedPublic

Authored by madpilot on Oct 14 2020, 8:36 AM.

Details

Summary

In r550494 meld was updated to version 3.21.0. Unluckily that version requires pygobject 3.30 or higher and fails to run with an error stating that: "Meld requires pygobject 3.30 or higher."

I've created a atch reverting the update for this port and bumping PORTEPOCH. I'm not directly committing this as "fixit blanket" because, before bumping portepoch, I'd rather get some feedback, maybe a better fix is on the way.

Otherwise I'd like to commit this ASAP.

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Lint Not Applicable
Unit
Tests Not Applicable

Event Timeline

please MFH as well! thank you

This revision is now accepted and ready to land.Oct 14 2020, 11:38 AM

For future reference, this software follows GNOME's even-odd version split; 3.21 is a development release. May want to add the appropriate PORTSCOUT line.