Page MenuHomeFreeBSD

Upgrade to openiked-2.1.
ClosedPublic

Authored by marcel on Jan 20 2019, 11:23 PM.

Details

Summary

Changes since 1.10:
o Fix bug FreeBSD/229654: properly generate man pages on FreeBSD.
o Fix Issue #14: properly create iked.conf.5
o Support OpenSSL 1.1 and newer.
o Support for OpenSSL 1.0 has been retained with compatibility defines.

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

marcel created this revision.Jan 20 2019, 11:23 PM
marcel edited the summary of this revision. (Show Details)Jan 20 2019, 11:39 PM
mat added a comment.Jan 23 2019, 8:27 AM

Note that FreeBSD 11 still has OpenSSL 1.0, so you need to keep support for it until the end of 2021.

security/openiked/Makefile
4 ↗(On Diff #53043)

Does this 2.0a means 2.0 alpha, or is it a version after 2.0?

marcel added inline comments.Jan 26 2019, 12:32 AM
security/openiked/Makefile
4 ↗(On Diff #53043)

It's a fixup of 2.0.

marcel updated this revision to Diff 53239.Jan 26 2019, 6:19 AM
marcel edited the summary of this revision. (Show Details)

Upgrade to openiked-2.1

marcel retitled this revision from Upgrade to openiked-2.0a to Upgrade to openiked-2.1..Jan 26 2019, 6:21 AM
marcel edited the summary of this revision. (Show Details)

Thanks for pointing out that OpenSSL 1.0.x needs to be supported.
OpenIKED 2.1 has support for OpenSSL 1.0.x and OpenSSL 1.1.x.

mat accepted this revision.Jan 26 2019, 8:23 AM
This revision is now accepted and ready to land.Jan 26 2019, 8:23 AM
This revision was automatically updated to reflect the committed changes.