Page MenuHomeFreeBSD

audio/liblastfm: Update to 1.0.9-5-g4433165, FLAVOR-ize qt4/qt5 versions
AbandonedPublic

Authored by jhale on Mar 12 2018, 3:53 PM.

Details

Reviewers
None
Group Reviewers
portmgr
Summary
  • Add a qt5 FLAVOR required by the Qt 5 version of audio/clementine-player (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226530)
  • Update to last commit from 2 years ago which allows Qt 4 and Qt 5 versions to be co-installable
  • Add a few more patches to fix the library with the current last.fm website (now requiring https)
  • Workaround a bug in poudriere dependency handling
Test Plan
  • Standard poudriere tests done
  • Unit tests pass

Diff Detail

Repository
rP FreeBSD ports repository
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 15519
Build 15560: arc lint + arc unit

Event Timeline

jhale created this revision.Mar 12 2018, 3:53 PM
mat added a comment.Mar 13 2018, 10:46 AM

We do not currently accept flavors that add new packages.

mat added a comment.Mar 13 2018, 10:51 AM

To expand a bit on my earlier comment, this change will be able to go in when ports-mgmt/poudriere is updated to 3.3.

qca and qjson have been flavorized now: D14650 / rP467317

I guess flavors are accepted now? :)

jhale abandoned this revision.Apr 17 2018, 11:29 PM

Forget it. Going with slave port for now.