Page MenuHomeFreeBSD

remove portaudit from handbook, as it has been removed from portstree
ClosedPublic

Authored by jgh on Dec 12 2014, 11:01 PM.

Details

Reviewers
wblock
remko
bcr
Summary

remove portaudit from handbook, as it has been removed from portstree

Diff Detail

Lint
Lint Skipped
Unit
Unit Tests Skipped

Event Timeline

jgh updated this revision to Diff 2725.Dec 12 2014, 11:01 PM
jgh retitled this revision from to remove portaudit from handbook, as it has been removed from portstree.
jgh updated this object.
jgh edited the test plan for this revision. (Show Details)
jgh added reviewers: remko, bcr, wblock.
jgh set the repository for this revision to rD FreeBSD doc repository.
remko edited edge metadata.Dec 12 2014, 11:03 PM

Removing the outdated information seems fine, can you clarify whether the pkg audit command is listed already ? if not, then we should not remove this, but replace this with ''pkg audit''.

Thanks
Remko

wblock edited edge metadata.Dec 13 2014, 1:28 AM

Seems like that whole section on portaudit should be reworked to cover pkg-audit.

ports/chapter.xml
201

Why "uri"? The <link> tag does this with less duplication:

<link xlink:href="http://vuxml.freebsd.org/"></link>

1116

As above, use <link>.

1122

"the manual page for" is redundant, just say "refer to ...". However, this should include the man page for pkg-audit:

refer to &man.pkg-audit.8; and &man.periodic.8;.

(I don't know if there is an entity for pkg-audit yet, might need to add one.)

jgh updated this revision to Diff 3501.Jan 28 2015, 7:18 PM
jgh edited edge metadata.

concerns addressed....

wblock added inline comments.Jan 29 2015, 4:47 AM
ports/chapter.xml
12

I think Phabricator is showing an incorrect diff here, but the link to the rendered version does not show the new changes.

security/chapter.xml
29

"pkg port" is somewhat redundant and confusing. I suggest not calling it a port, but just referring to it as an application. Maybe also specify that it it is really "pkg audit" that is doing the polling and database stuff. There are also a couple of sentences combined that should be separate. For example:

"The &os; Security Team updates and maintains a database of security issues. Security auditing code in <application>pkg</application> checks this database for known problems."

34

Needs a comma before "please". But a less-hesitant sentence can be made by rearranging it into instructions rather than an if/then:

"Please refer to <> for instructions on installing pkg."

38

s/will be/are/ (active rather than passive)

Also, it's not clear which functionality that next sentence is talking about. Not the config files...

46

"any time" is two words.

48

It is redundant to say "invoking pkg:". Might as well just say "invoking:" and let the full command speak for itself.

54

This is kind of confusing. Rather than have the separate note, why not include the explanation before the manual command?

"The database is automatically updated during the periodic run. To manually update the database and check for problems, invoke:"

58

s/will display/displays/ (active rather than passive)

59

"any installed vulnerable packages" has three adjectives in a row. Maybe "any known vulnerabilities in installed packages:"

62

Looks like another Phabricator disjointed diff.

bcr accepted this revision.Jan 31 2015, 4:34 PM
bcr edited edge metadata.
This revision is now accepted and ready to land.Jan 31 2015, 4:34 PM
jgh updated this revision to Diff 4462.Mar 27 2015, 3:35 PM
jgh edited edge metadata.

addressed comments

This revision now requires review to proceed.Mar 27 2015, 3:35 PM
wblock added inline comments.Mar 27 2015, 3:51 PM
security/chapter.xml
30

See the previous comment about breaking this into two sentences. Either way, the important thing should be stated first, that pkg checks a database for security issues. The aside about it being maintained by the security team is secondary and interrupts the main point.

Also, "known security issue" is redundant.

39

s/providing an/provides a/
s/programatic/programmatic/

40

"up-to-date" is kind of a Britishism. How about "updated"?

55

Nice!

jgh updated this revision to Diff 4466.Mar 27 2015, 3:59 PM
jgh edited edge metadata.

addressed comments

wblock accepted this revision.Mar 27 2015, 6:26 PM
wblock edited edge metadata.

Remember to build-test before commit. Thanks!

This revision is now accepted and ready to land.Mar 27 2015, 6:26 PM
jgh closed this revision.Mar 27 2015, 7:00 PM