Page MenuHomeFreeBSD

Rename sdhci_cam_start_slot() into sdhci_start_slot()
ClosedPublic

Authored by kibab on Sep 23 2017, 8:12 AM.

Details

Summary

This allows to just call sdhci_start_slot() in SDHCI drivers
and not to think about which stack handles the operation.

As a side effect, this will also fix MMCCAM with sdhci_acpi driver.

Test Plan

Compile GENERIC and GENERIC-MMCCAM on amd64, IMX6 and BEAGLEBONE with
and without MMCCAM on arm.

Diff Detail

Repository
rS FreeBSD src repository - subversion
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.