www/yarn: Updating to version 1.0.1
ClosedPublic

Authored by pizzamig on Tue, Sep 12, 7:46 AM.

Details

Summary

www/yarn: Update to version 1.0.1
Adding an option to avoid the installation of the yarn script, that collides with a hadoop2 utility

portlint is not happy, but I dunno how to solve it.

Test Plan

poudriere build on 10.3 11.0 11.1 on i386 and amd64
Installation on a system with hadoop2, to verify conflicts

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
pizzamig created this revision.Tue, Sep 12, 7:46 AM
lme added a comment.Tue, Sep 12, 7:57 AM

Can you show portlint's output please?

portlint claims:

WARN: Makefile: HADOOPCOMPAT is listed in OPTIONS_DEFINE, but no PORT_OPTIONS:MHADOOPCOMPAT appears.

olivier accepted this revision.Wed, Sep 13, 9:33 AM

It's okay, portlint is just an helper tool and didn't catch this port complexity.

This revision is now accepted and ready to land.Wed, Sep 13, 9:33 AM
This revision was automatically updated to reflect the committed changes.
jlduran_gmail.com added inline comments.
head/www/yarn/Makefile
40

I'm not sure if the -f flag in Linux's readlink means the same as in FreeBSD.