Page MenuHomeFreeBSD

brnrd (Bernard Spil)
User

Projects

User Details

User Since
May 23 2015, 5:25 PM (181 w, 4 d)

Recent Activity

Tue, Nov 13

brnrd committed rP484896: databases/mariadb102-server: Update to 10.2.19.
databases/mariadb102-server: Update to 10.2.19
Tue, Nov 13, 6:50 PM

Mon, Nov 12

brnrd committed rP484821: security/openssl: Security update for CVE-2018-5407.
security/openssl: Security update for CVE-2018-5407
Mon, Nov 12, 8:19 PM
brnrd committed rP484820: security/vuxml: Document openssl vulnerability.
security/vuxml: Document openssl vulnerability
Mon, Nov 12, 8:18 PM
brnrd committed rP484810: databases/mariadb103-server: Fix linking issue.
databases/mariadb103-server: Fix linking issue
Mon, Nov 12, 4:59 PM
brnrd added inline comments to D17834: Mk/Uses/ssl.mk: Automate BROKEN for 12+.
Mon, Nov 12, 1:41 PM

Sat, Nov 10

brnrd committed rP484613: databases/mariadb103-server: Remove XTRADB option.
databases/mariadb103-server: Remove XTRADB option
Sat, Nov 10, 2:12 PM
brnrd committed rP484612: security/vuxml: Update latest openssl entry.
security/vuxml: Update latest openssl entry
Sat, Nov 10, 2:02 PM
brnrd committed rP484607: databases/mariadb101-server: Fix stage-qa.
databases/mariadb101-server: Fix stage-qa
Sat, Nov 10, 12:54 PM
brnrd added a reviewer for D17834: Mk/Uses/ssl.mk: Automate BROKEN for 12+: mat.
Sat, Nov 10, 11:22 AM
brnrd retitled D17834: Mk/Uses/ssl.mk: Automate BROKEN for 12+ from Mk/Uses/ssl.mk: Chase removal of openssl-devel to Mk/Uses/ssl.mk: Automate BROKEN for 12+.
Sat, Nov 10, 11:22 AM
brnrd updated the diff for D17834: Mk/Uses/ssl.mk: Automate BROKEN for 12+.

Update after rP484599

Sat, Nov 10, 11:18 AM
brnrd abandoned D17136: Update BROKEN_SSL in ports.

Fixed with rP484599

Sat, Nov 10, 11:15 AM

Thu, Nov 8

brnrd committed rP484467: www/mod_http2-devel: Update to 1.11.4.
www/mod_http2-devel: Update to 1.11.4
Thu, Nov 8, 5:50 PM
brnrd added inline comments to D17834: Mk/Uses/ssl.mk: Automate BROKEN for 12+.
Thu, Nov 8, 5:32 PM
brnrd committed rP484465: security/vuxml: Mark MariaDB 10.3.10 vulnerable.
security/vuxml: Mark MariaDB 10.3.10 vulnerable
Thu, Nov 8, 5:29 PM

Sun, Nov 4

brnrd retitled D17136: Update BROKEN_SSL in ports from Rename security/openssl-devel to openssl110 to Update BROKEN_SSL in ports.
Sun, Nov 4, 1:38 PM
brnrd updated the diff for D17136: Update BROKEN_SSL in ports.

Refresh diff after removal of security/openssl-devel

Sun, Nov 4, 1:35 PM
brnrd committed rP483982: databases/mariadb101-server: 12 not broken with security/openssl.
databases/mariadb101-server: 12 not broken with security/openssl
Sun, Nov 4, 9:47 AM
brnrd created D17834: Mk/Uses/ssl.mk: Automate BROKEN for 12+.
Sun, Nov 4, 9:10 AM

Sat, Nov 3

brnrd committed rP483888: databases/mariadb101-server: Security update to 10.1.37.
databases/mariadb101-server: Security update to 10.1.37
Sat, Nov 3, 12:00 PM

Thu, Nov 1

brnrd committed rP483658: security/vuxml: Update latest OpenSSL entry.
security/vuxml: Update latest OpenSSL entry
Thu, Nov 1, 12:16 PM
brnrd committed rP483657: databases/mariadb100-server: Security update to 10.0.37.
databases/mariadb100-server: Security update to 10.0.37
Thu, Nov 1, 12:09 PM

Wed, Oct 31

brnrd committed rP483601: MFH: r483493.
MFH: r483493
Wed, Oct 31, 5:50 PM
brnrd committed rP483598: databases/mariadb103-client: Fix mariadb_config output.
databases/mariadb103-client: Fix mariadb_config output
Wed, Oct 31, 5:35 PM

Tue, Oct 30

brnrd committed rP483493: security/openssl-devel: Move patches.
security/openssl-devel: Move patches
Tue, Oct 30, 3:06 PM
brnrd committed rP483469: MFH: r483393.
MFH: r483393
Tue, Oct 30, 11:36 AM
brnrd added a comment to D17136: Update BROKEN_SSL in ports.
In D17136#379137, @rene wrote:
In D17136#379090, @bapt wrote:

I think this is a bad idea, openssl 1.1.0 and 1.1.1 are binary compatible

So we can also just remove openssl-devel completely? Or upgrade and rename it to openssl111 to preserve history.

Tue, Oct 30, 11:29 AM
brnrd updated the summary of D17136: Update BROKEN_SSL in ports.
Tue, Oct 30, 11:29 AM

Mon, Oct 29

brnrd committed rP483396: security/openssl-devel: Fix vulnerabilities.
security/openssl-devel: Fix vulnerabilities
Mon, Oct 29, 6:39 PM
brnrd committed rP483393: security/openssl111: Fix vulnerabilities.
security/openssl111: Fix vulnerabilities
Mon, Oct 29, 6:07 PM
brnrd committed rP483391: security/vuxml: Document OpenSSL 1.1.x vulnerabilities.
security/vuxml: Document OpenSSL 1.1.x vulnerabilities
Mon, Oct 29, 5:51 PM

Sun, Oct 28

brnrd added a comment to D17136: Update BROKEN_SSL in ports.

Can I go ahead and change this throughout the ports tree?

Sun, Oct 28, 5:22 PM
brnrd added a reviewer for D17136: Update BROKEN_SSL in ports: miwi.
Sun, Oct 28, 5:21 PM
brnrd abandoned D17692: security/openssl*: Change SHLIBVER.

SHLIB versions in base were changed to avoid conflicts in rS339741: Update SHLIB_VERSION_NUMBER following the OpenSSL shared library

Sun, Oct 28, 5:20 PM
brnrd committed rP483302: security/openssl-devel: Fix SHARED option.
security/openssl-devel: Fix SHARED option
Sun, Oct 28, 2:52 PM
brnrd committed rP483243: MFH: r483172.
MFH: r483172
Sun, Oct 28, 8:54 AM
brnrd committed rP483238: MFH: r482974 r483143.
MFH: r482974 r483143
Sun, Oct 28, 8:27 AM

Sat, Oct 27

brnrd committed rP483173: devel/apr1: Update APR to 1.6.5.
devel/apr1: Update APR to 1.6.5
Sat, Oct 27, 9:47 PM
brnrd closed D17688: devel/apr1: Update APR to 1.6.5.
Sat, Oct 27, 9:47 PM
brnrd added a comment to D15412: Mk/bsd.sanity.mk: mark WITH_HTTP(S)_PORT notneeded.

From: brnrd@FreeBSD.org
To: umq@ueo.co.jp
CC: mat@FreeBSD.org
Subject: security/axTLSL: Removal of WITH_HTTP(S)_PORT

Sat, Oct 27, 9:06 PM
brnrd added a comment to D15412: Mk/bsd.sanity.mk: mark WITH_HTTP(S)_PORT notneeded.
In D15412#347910, @mat wrote:

Did it have an effect before it was removed?

For security/axTLS it looks like it set the default https port. Probably I should include changes to that port here. Will contact maintainer.
For www/apache24 it has already been removed.

Sat, Oct 27, 8:56 PM
brnrd committed rP483172: databases/mariadb55-server: Security update to 5.5.62.
databases/mariadb55-server: Security update to 5.5.62
Sat, Oct 27, 8:46 PM
brnrd committed rP483143: databases/mariadb103-server: Fix plist issues.
databases/mariadb103-server: Fix plist issues
Sat, Oct 27, 3:07 PM
brnrd committed rP483139: www/apache24: Update to 2.4.37.
www/apache24: Update to 2.4.37
Sat, Oct 27, 2:37 PM
brnrd closed D17668: www/apache24: Update to 2.4.37.
Sat, Oct 27, 2:37 PM

Thu, Oct 25

brnrd added a comment to D17668: www/apache24: Update to 2.4.37.

running the new release since yesterday on 12 hosts, all on 11-p4 and haven't seen any issues (the busiest hosts had round about 600.000 requests since the update).

OK, for me, but I will do a new test with the updated APR as soon my time permits the build/roll out

Thu, Oct 25, 4:25 PM
brnrd added a comment to D17688: devel/apr1: Update APR to 1.6.5.

haven't looked deeper into the mysql issue, but perhaps it is similar to fix like the postfix ports.
Full conversation on the postfix-devel list https://marc.info/?t=151955691300001&r=1&w=2

Thu, Oct 25, 4:24 PM
brnrd committed rP482974: databases/mariadb103-server: Update to 10.3.10.
databases/mariadb103-server: Update to 10.3.10
Thu, Oct 25, 3:59 PM

Wed, Oct 24

brnrd created D17692: security/openssl*: Change SHLIBVER.
Wed, Oct 24, 9:42 PM
brnrd updated the summary of D17688: devel/apr1: Update APR to 1.6.5.
Wed, Oct 24, 5:18 PM
brnrd created D17688: devel/apr1: Update APR to 1.6.5.
Wed, Oct 24, 5:02 PM
brnrd added inline comments to D17136: Update BROKEN_SSL in ports.
Wed, Oct 24, 1:47 PM

Tue, Oct 23

brnrd closed D17652: irc/weechat: Update to 2.3.

Closed by rP482861

Tue, Oct 23, 6:30 PM
brnrd committed rP482861: irc/weechat: Update to 2.3.
irc/weechat: Update to 2.3
Tue, Oct 23, 5:51 PM
brnrd accepted D17652: irc/weechat: Update to 2.3.

Works fine

Tue, Oct 23, 5:51 PM
brnrd updated the test plan for D17668: www/apache24: Update to 2.4.37.
Tue, Oct 23, 4:54 PM
brnrd updated the summary of D17668: www/apache24: Update to 2.4.37.
Tue, Oct 23, 4:40 PM
brnrd created D17668: www/apache24: Update to 2.4.37.
Tue, Oct 23, 4:36 PM
brnrd added a comment to D17652: irc/weechat: Update to 2.3.

Thanks for reporting. I have this in my local repo already, and am running Weechat 2.3 from my modified port.

Tue, Oct 23, 11:51 AM
brnrd updated the summary of D17652: irc/weechat: Update to 2.3.
Tue, Oct 23, 11:50 AM

Sat, Oct 20

brnrd committed rP482483: security/libressl: Update to 2.8.2.
security/libressl: Update to 2.8.2
Sat, Oct 20, 10:30 AM
brnrd committed rP482473: security/vuxml: Document 2018-10 MySQL vulnerabilities.
security/vuxml: Document 2018-10 MySQL vulnerabilities
Sat, Oct 20, 7:58 AM

Fri, Oct 19

brnrd committed rP482421: mail/nextcloud-mail: Update to 0.11.0.
mail/nextcloud-mail: Update to 0.11.0
Fri, Oct 19, 10:05 AM
brnrd committed rP482420: security/libressl-devel: Update to 2.8.2.
security/libressl-devel: Update to 2.8.2
Fri, Oct 19, 9:52 AM
brnrd committed rP482417: mail/up-imapproxy: Add OpenSSL 1.1 support.
mail/up-imapproxy: Add OpenSSL 1.1 support
Fri, Oct 19, 9:03 AM

Oct 15 2018

brnrd committed rP482155: www/nextcloud: Update to 14.0.3.
www/nextcloud: Update to 14.0.3
Oct 15 2018, 1:17 PM

Oct 14 2018

brnrd closed D17552: www/nextcloud: Fix fresh installs.
www/nextcloud: Fix fresh installs
Oct 14 2018, 4:07 PM
brnrd committed rP482045: www/nextcloud: Fix fresh installs.
www/nextcloud: Fix fresh installs
Oct 14 2018, 3:28 PM
brnrd updated the summary of D17552: www/nextcloud: Fix fresh installs.
Oct 14 2018, 11:05 AM
brnrd created D17552: www/nextcloud: Fix fresh installs.
Oct 14 2018, 11:00 AM

Oct 11 2018

brnrd committed rP481821: www/mod_http2-devel: Update to 1.11.3.
www/mod_http2-devel: Update to 1.11.3
Oct 11 2018, 12:50 PM

Oct 5 2018

brnrd committed rP481266: security/openssl111: Fix linking with lld on i386.
security/openssl111: Fix linking with lld on i386
Oct 5 2018, 9:17 AM
brnrd closed D17362: security/openssl111: Fix linking with lld on i386.
Oct 5 2018, 9:17 AM

Oct 1 2018

brnrd committed rP481016: databases/mariadb102-server: Update to 10.2.18.
databases/mariadb102-server: Update to 10.2.18
Oct 1 2018, 9:08 AM

Sep 30 2018

brnrd updated the summary of D17362: security/openssl111: Fix linking with lld on i386.
Sep 30 2018, 11:30 AM
brnrd retitled D17362: security/openssl111: Fix linking with lld on i386 from security/openssl111: Fix linking with lld to security/openssl111: Fix linking with lld on i386.
Sep 30 2018, 11:17 AM
brnrd updated the diff for D17362: security/openssl111: Fix linking with lld on i386.

Fix is needed for i386, not amd64

Sep 30 2018, 11:16 AM
brnrd updated the summary of D17362: security/openssl111: Fix linking with lld on i386.
Sep 30 2018, 11:13 AM
brnrd created D17362: security/openssl111: Fix linking with lld on i386.
Sep 30 2018, 11:12 AM

Sep 28 2018

brnrd committed rP480860: www/nextcloud: Fix APCU option, add INTL.
www/nextcloud: Fix APCU option, add INTL
Sep 28 2018, 1:52 PM

Sep 26 2018

brnrd abandoned D13111: www/apache25-devel: New port.

Abandoning this review. The main objective was to have an Apache that would work with OpenSSL 1.1 (and LibreSSL 2.7+) and support for TLSv1.3. Both these objectives have been/will be met by the 2.4 branch. As for the TLSv1.3 support, the discussions on apache httpd-dev mailing-list suggest that TLSv1.3 will land in a point-release of 2.4. Outlook on 2.6.x, for which 2.5 is the development branch, are that there won't be such a release soon.
2.4.x+TLSv1.3 branch (or git slave repo if you are so inclined)
Voting/discussion thread on http-dev mailing-list
Currently TLSv1.3 support is non-functional with released browsers, the browsers only support draft-13 and or 18. Testing requires BETA, nightly or canary builds. This will soon change.

Sep 26 2018, 1:41 PM
brnrd committed rP480732: security/vuxml: Add Apache 2.4 vulnerability.
security/vuxml: Add Apache 2.4 vulnerability
Sep 26 2018, 12:49 PM
brnrd committed rP480731: www/nextcloud-notes: Update to 2.4.2.
www/nextcloud-notes: Update to 2.4.2
Sep 26 2018, 12:07 PM
brnrd committed rP480730: www/nextcloud: Update to 14.0.1.
www/nextcloud: Update to 14.0.1
Sep 26 2018, 12:06 PM
brnrd committed rP480724: security/libressl-devel: Update to 2.8.1.
security/libressl-devel: Update to 2.8.1
Sep 26 2018, 9:34 AM

Sep 12 2018

brnrd updated the summary of D17136: Update BROKEN_SSL in ports.
Sep 12 2018, 5:38 PM
brnrd created D17136: Update BROKEN_SSL in ports.
Sep 12 2018, 5:34 PM
brnrd committed rP479614: security/openssl111: Re-add OpenSSL 1.1.1 port.
security/openssl111: Re-add OpenSSL 1.1.1 port
Sep 12 2018, 4:11 PM
brnrd committed rP479613: security/openssl111: Prepare for repocopy from openssl-devel.
security/openssl111: Prepare for repocopy from openssl-devel
Sep 12 2018, 4:08 PM
brnrd committed rP479602: security/openssl111: Re-add OpenSSL 1.1.1 port.
security/openssl111: Re-add OpenSSL 1.1.1 port
Sep 12 2018, 1:54 PM
brnrd committed rP479600: security/Makefile: Unbreak index, remove openssl111.
security/Makefile: Unbreak index, remove openssl111
Sep 12 2018, 1:20 PM
brnrd committed rP479599: security/openssl111: Redo using repocopy.
security/openssl111: Redo using repocopy
Sep 12 2018, 12:45 PM
brnrd committed rP479597: security/openssl111: Default enable DES.
security/openssl111: Default enable DES
Sep 12 2018, 11:55 AM
brnrd committed rP479596: security/Makefile: Fix openssl-devel removal mistake.
security/Makefile: Fix openssl-devel removal mistake
Sep 12 2018, 11:42 AM
brnrd committed rP479595: Chase CONFLICTS after addition of security/openssl111.
Chase CONFLICTS after addition of security/openssl111
Sep 12 2018, 11:36 AM
brnrd committed rP479592: security/openssl111: Add new OpenSSL port.
security/openssl111: Add new OpenSSL port
Sep 12 2018, 10:09 AM

Sep 10 2018

brnrd committed rP479451: www/nextcloud-contacts: Update to 2.1.6.
www/nextcloud-contacts: Update to 2.1.6
Sep 10 2018, 8:18 PM
brnrd committed rP479450: www/nextcloud-calendar: Update to 1.6.2.
www/nextcloud-calendar: Update to 1.6.2
Sep 10 2018, 8:17 PM
brnrd committed rP479449: security/nextcloud-twofactor_u2f: Update to 1.6.1.
security/nextcloud-twofactor_u2f: Update to 1.6.1
Sep 10 2018, 8:16 PM
brnrd committed rP479448: security/nextcloud-twofactor_totp: Update to 1.5.0.
security/nextcloud-twofactor_totp: Update to 1.5.0
Sep 10 2018, 8:15 PM