Page MenuHomeFreeBSD

D28131.id82976.diff
No OneTemporary

D28131.id82976.diff

diff --git a/documentation/content/en/books/handbook/disks/_index.adoc b/documentation/content/en/books/handbook/disks/_index.adoc
--- a/documentation/content/en/books/handbook/disks/_index.adoc
+++ b/documentation/content/en/books/handbook/disks/_index.adoc
@@ -1006,6 +1006,92 @@
The disk is now ready for use. To use the floppy, mount it with man:mount_msdosfs[8]. One can also install and use package:emulators/mtools[] from the Ports Collection.
+[[using-ntfs]]
+== Using NTFS Disks
+
+This section explains how to mount NTFS disks in FreeBSD.
+
+NTFS (New Technology File System) is a proprietary journaling file system
+developed by Microsoft(R). It has been the default file system in Microsoft
+Windows(R) for many years. FreeBSD can mount NTFS volumes using a FUSE file
+system. These file systems are implemented as user space programs which
+interact with the man:fusefs[5] kernel module via a well defined interface.
+
+[.procedure]
+====
+*Procedure: Steps to Mount a NTFS Disk*
+
+. Before using a FUSE file system we need to load the man:fusefs[5] kernel
+module:
++
+[source,bash]
+....
+# kldload fusefs
+....
++
+Add this line to /etc/rc.conf to load the module at startup:
++
+[.programlisting]
+....
+kld_list="fusefs"
+....
+
+. Install the actual NTFS file system from packages as in the example (see
+crossref:ports[pkgng-intro,Using pkg for Binary Package Management]) or from
+ports (see crossref:ports[ports-using,Using the Ports Collection]):
++
+[source,bash]
+....
+# pkg install fusefs-ntfs
+....
+
+. Last we need to create a directory where the file system will be mounted:
++
+[source,bash]
+....
+# mkdir /mnt/usb
+....
+
+. Suppose a USB disk is plugged in. The disk partition information can be
+viewed with man:gpart[8]:
++
+[source,bash]
+....
+# gpart show da0
+=> 63 1953525105 da0 MBR (932G)
+ 63 1953525105 1 ntfs (932G)
+....
+
+. We can mount the disk using the following command:
++
+[source,bash]
+....
+# ntfs-3g /dev/da0s1 /mnt/usb/
+....
+The disk is now ready to use.
++
+. Additionally, an entry can be added to /etc/fstab:
++
+[.programlisting]
+....
+/dev/da0s1 /mnt/usb ntfs mountprog=/usr/local/bin/ntfs-3g,noauto,rw 0 0
+....
++
+Now the disk can be now mounted with:
++
+[source,bash]
+....
+# mount /mnt/usb
+....
+
+. The disk can be unmounted with:
+
+[source,bash]
+....
+umount /mnt/usb/
+....
+====
+
[[backup-basics]]
== Backup Basics

File Metadata

Mime Type
text/plain
Expires
Wed, Jan 8, 11:25 PM (4 h, 17 m)
Storage Engine
blob
Storage Format
Raw Data
Storage Handle
15727275
Default Alt Text
D28131.id82976.diff (2 KB)

Event Timeline