The current default is to pick up any directory in /boot with a 'kernel' regular file inside of it. This adds a lot of stat() calls (1x for each fileis eliminates a lot of stat() calls that happen when lualoader renders the menu with the default settings, 2x for each directory) when most folks will really only have those following the standard-ish naming convention:and greatly speeds up rendering on my laptop.
- kernel
- kernel.old
- kernel.${KERNCONF}ftype is nil if loader/loader.efi hasn't been updated yet, falling back to lfs.attributes() to test.
Add a new "strict" option that doesn't bother with any stat() unless the entry in /boot starts with "kernel", yielding a pretty significant speedup on systems with slower I/O for whatever reason. Switch to it as the defaultThis is technically incompatible with lfs, and folks wanting the existing behavior can override it to "yes" as it previously defaulted tobut not in a particularly terrible way.