HomeFreeBSD

games/flightgear: set LLD_UNSAFE

Description

games/flightgear: set LLD_UNSAFE

Prevent Flightgear from linking using lld as it fails with errors like:

/usr/bin/ld: error: cannot preempt symbol: alcGetIntegerv

defined in /usr/local/lib/libopenal.so
referenced by audio_openal.c

audio_openal.c.o:(openal_input)

due to preemption of symbols with protected visibility in a shared object.

See also PR #219089 for more details.

PR: 226980
Submitted by: emaste

Details

Committed
martymacMar 31 2018, 4:26 PM
Parents
rP466062: emulators/dolphin-emu: set LLD_UNSAFE
Branches
Unknown
Tags
Unknown