Page MenuHomeFreeBSD

me_igalic.co (Mina Galić)
User

Projects

User Details

User Since
Nov 7 2020, 6:11 PM (10 w, 1 d)

Recent Activity

Sat, Jan 16

me_igalic.co accepted D28190: pkgbase: default to installing all specified kernels.

yes, please

Sat, Jan 16, 4:10 AM

Thu, Jan 14

me_igalic.co added a comment to D28152: Split out the NODEBUG options to a common file.

is there an equivalent std.debug file for stable branches?

Thu, Jan 14, 5:22 PM

Fri, Jan 8

me_igalic.co added a comment to D27411: add altlog_jaillist to syslogd's rc script.

address @0mp's comments.

Fri, Jan 8, 9:00 PM · manpages, rc
me_igalic.co updated the diff for D27411: add altlog_jaillist to syslogd's rc script.
Fri, Jan 8, 8:57 PM · manpages, rc
me_igalic.co added a comment to D27962: rc: ignore .pkgsave files.

addressed @swills' concerns.

Fri, Jan 8, 8:36 PM · pkgbase, rc
me_igalic.co updated the diff for D27962: rc: ignore .pkgsave files.
Fri, Jan 8, 8:35 PM · pkgbase, rc
me_igalic.co added a watcher for pkgbase: me_igalic.co.
Fri, Jan 8, 7:56 PM
me_igalic.co added a watcher for rc: me_igalic.co.
Fri, Jan 8, 7:56 PM
me_igalic.co added a member for rc: me_igalic.co.
Fri, Jan 8, 7:56 PM
me_igalic.co added a member for pkgbase: me_igalic.co.
Fri, Jan 8, 7:54 PM
me_igalic.co added inline comments to D27962: rc: ignore .pkgsave files.
Fri, Jan 8, 2:57 PM · pkgbase, rc

Thu, Jan 7

me_igalic.co accepted D28021: gammy/Makefile: Update to 0.9.61.

aah, very good

Thu, Jan 7, 3:37 PM

Wed, Jan 6

me_igalic.co updated the diff for D27959: kldxref: skip .pkgsave files.

fix @emaste's formatting remarks from IRC

Wed, Jan 6, 8:36 PM
me_igalic.co commandeered D27847: rc scripts vs. .pkgsave.

i'm getting this message on boot / shutdown:

Wed, Jan 6, 8:28 PM

Tue, Jan 5

me_igalic.co updated the diff for D27959: kldxref: skip .pkgsave files.
Tue, Jan 5, 10:06 PM
me_igalic.co added a comment to D27959: kldxref: skip .pkgsave files.

same functionality, written in C instead of python style C. thanks to RhodiumToad:

Tue, Jan 5, 6:36 PM
me_igalic.co added a comment to D27959: kldxref: skip .pkgsave files.

alternatively, we could say: if it has >= 2 '.', skip it

Yes I think that's reasonable if you're up for updating this review with that change (or I'll take this one as is).

Tue, Jan 5, 12:57 PM

Mon, Jan 4

me_igalic.co added a comment to D27959: kldxref: skip .pkgsave files.

LGTM even though we're probably close to the point where it makes sense to have a loop with a list of extensions to ignore.

Mon, Jan 4, 10:46 PM
me_igalic.co requested review of D27962: rc: ignore .pkgsave files.
Mon, Jan 4, 9:48 PM · pkgbase, rc
me_igalic.co requested review of D27959: kldxref: skip .pkgsave files.
Mon, Jan 4, 9:29 PM

Wed, Dec 30

me_igalic.co added a comment to D27847: rc scripts vs. .pkgsave.

this almost works 😬

Wed, Dec 30, 6:52 PM

Sun, Dec 27

me_igalic.co added inline comments to D27495: Implement strerror_l()..
Sun, Dec 27, 10:26 AM

Sat, Dec 26

me_igalic.co added inline comments to D27495: Implement strerror_l()..
Sat, Dec 26, 11:06 PM
me_igalic.co added a comment to D27495: Implement strerror_l()..

this change makes my build world (in poudriere) fail

Sat, Dec 26, 12:50 PM

Thu, Dec 24

me_igalic.co added a reviewer for D27690: rename PKGSIGNKEY to PKG_REPO_SIGNING_KEY: pkgbase.
Thu, Dec 24, 12:17 PM · manpages, pkgbase

Sun, Dec 20

me_igalic.co added a comment to D27690: rename PKGSIGNKEY to PKG_REPO_SIGNING_KEY.

address @yuripv's comments.

Sun, Dec 20, 8:19 PM · manpages, pkgbase
me_igalic.co updated the diff for D27690: rename PKGSIGNKEY to PKG_REPO_SIGNING_KEY.
Sun, Dec 20, 8:18 PM · manpages, pkgbase
me_igalic.co requested review of D27690: rename PKGSIGNKEY to PKG_REPO_SIGNING_KEY.
Sun, Dec 20, 7:23 PM · manpages, pkgbase

Dec 13 2020

me_igalic.co added a reviewer for D27411: add altlog_jaillist to syslogd's rc script: rc.
Dec 13 2020, 9:16 PM · manpages, rc
me_igalic.co added projects to D27411: add altlog_jaillist to syslogd's rc script: rc, manpages.
Dec 13 2020, 9:14 PM · manpages, rc

Dec 10 2020

me_igalic.co added a comment to D27462: add new port: accessibility/gammy as alternative to accessibility/redshift.

lgtm, should I commit it?

Dec 10 2020, 5:44 AM

Dec 9 2020

me_igalic.co added a comment to D27462: add new port: accessibility/gammy as alternative to accessibility/redshift.

address (most of?) @tcberner's review

Dec 9 2020, 9:13 PM
me_igalic.co updated the diff for D27462: add new port: accessibility/gammy as alternative to accessibility/redshift.

address @tcberner's review

Dec 9 2020, 8:55 PM

Dec 5 2020

me_igalic.co updated the diff for D27411: add altlog_jaillist to syslogd's rc script.
Dec 5 2020, 10:45 PM · manpages, rc
me_igalic.co added inline comments to D27411: add altlog_jaillist to syslogd's rc script.
Dec 5 2020, 10:41 PM · manpages, rc
me_igalic.co updated the diff for D27411: add altlog_jaillist to syslogd's rc script.

address @yuripv's review: by removing additional lints from rc.conf.5

Dec 5 2020, 10:34 PM · manpages, rc

Dec 4 2020

me_igalic.co updated the diff for D27411: add altlog_jaillist to syslogd's rc script.

add explanation that "-H" is needed for altlog_jaillist

Dec 4 2020, 1:29 PM · manpages, rc
me_igalic.co added a comment to D27411: add altlog_jaillist to syslogd's rc script.

So, another test round.
This works fine with syslogd_flags="-s" and syslogd_flags="-ss"; however, only when we add -H to the flags, do the syslog entries become more useful, because we get the host.hostname of the jail in our logs.
so I'll add that to that to the rc.conf man page.

Dec 4 2020, 1:11 PM · manpages, rc
me_igalic.co added a comment to D27462: add new port: accessibility/gammy as alternative to accessibility/redshift.

result of portlint -CANv:

Dec 4 2020, 1:03 PM

Dec 3 2020

me_igalic.co added a comment to D27462: add new port: accessibility/gammy as alternative to accessibility/redshift.

is there a way to make this easier searchable? should i mention "redshift"?

Dec 3 2020, 10:03 PM
me_igalic.co added a comment to D27411: add altlog_jaillist to syslogd's rc script.

i've now finally gotten around to testing this change ^_^;; and i'm quite happy with the results…

Dec 3 2020, 9:56 PM · manpages, rc
me_igalic.co requested review of D27462: add new port: accessibility/gammy as alternative to accessibility/redshift.
Dec 3 2020, 6:17 PM

Dec 2 2020

me_igalic.co updated the diff for D27411: add altlog_jaillist to syslogd's rc script.

address @dch and @yuripv review, moving rc.conf settings to rc.conf(5) and fixing most style issues

Dec 2 2020, 3:25 PM · manpages, rc

Nov 30 2020

me_igalic.co added a comment to D24570: Add support for jail.d.

I would love for there to be some way to include global config in jail.conf and per-jail config in jail.d/${jail}.conf. This is a good start in that direction.
Getting libucl to work properly with the current jail.conf format would be a nice way to handle that. I have opened an issue here for one of the limitations I see preventing this: https://github.com/vstakhov/libucl/issues/227

Nov 30 2020, 10:58 AM

Nov 29 2020

me_igalic.co updated the diff for D27161: growfs: use sysexits in place of err/errc/errx(1).

do *not* use sysexits, and document what we've done.

Nov 29 2020, 10:31 PM
me_igalic.co updated the diff for D27411: add altlog_jaillist to syslogd's rc script.

address @kevans's review; and document! fix almost all igor & mandoc concerns, except for this one:

Nov 29 2020, 9:35 PM · manpages, rc
me_igalic.co requested review of D27411: add altlog_jaillist to syslogd's rc script.
Nov 29 2020, 12:00 PM · manpages, rc

Nov 28 2020

me_igalic.co added a comment to D27408: Fix a copy-paste error.

Thanks @yuripv, fixed.

Nov 28 2020, 10:07 PM
me_igalic.co updated the diff for D27408: Fix a copy-paste error.

address @yuripv's comments

Nov 28 2020, 10:06 PM
me_igalic.co requested review of D27408: Fix a copy-paste error.
Nov 28 2020, 9:49 PM

Nov 20 2020

me_igalic.co added a comment to D26973: Switch C.UTF-8 as the default locales.

My issue appears to have been caused by building with WITHOUT_LOCALES=YES. Removing that makes perl happy again. Sort of odd that nothing else cared.

Nov 20 2020, 4:13 PM
me_igalic.co added a comment to D27161: growfs: use sysexits in place of err/errc/errx(1).

My suggestion is to change all the exit statuses that were changed to sysexits codes here to 2 instead.

"requested size %s is not larger than the current filesystem size %s" remains at 1 so that it can be checked for.

This results in a pattern much like grep(1) and test(1): the exit status is 0 if the file system has been or would be (with -N) enlarged, 1 if the file system is already at its maximum size and >1 if an error occurred. In practice, the ">1" is always 2, but this allows future expansion; scripts should check for the value 1, not for the value 2.

Nov 20 2020, 11:58 AM

Nov 18 2020

me_igalic.co added a comment to D27161: growfs: use sysexits in place of err/errc/errx(1).

What was motivation for this? Do you have any use case for that?

Nov 18 2020, 10:46 PM

Nov 14 2020

me_igalic.co requested changes to D27128: jail: introduce per jail suser_enabled setting.

It looks to be working correctly on a quick run-through.

Nov 14 2020, 7:09 AM

Nov 13 2020

me_igalic.co accepted D26973: Switch C.UTF-8 as the default locales.

👍

Nov 13 2020, 7:58 PM

Nov 11 2020

me_igalic.co added a comment to D27176: Discourage the use of sysexits(3) in new code.

I think only EX_TEMPFAIL (75) has a clear and reasonably generic purpose,

Nov 11 2020, 8:52 PM

Nov 10 2020

me_igalic.co updated the diff for D27161: growfs: use sysexits in place of err/errc/errx(1).

add context

Nov 10 2020, 8:25 AM
me_igalic.co requested review of D27161: growfs: use sysexits in place of err/errc/errx(1).
Nov 10 2020, 8:14 AM

Nov 9 2020

me_igalic.co added a comment to D27128: jail: introduce per jail suser_enabled setting.

I may be handy to allow jailed root to control its own security.bsd.suser_enabled.

1: It could either work one-way, with the ability to set clear one's own permission bit but not set it (except in the case of prison0).
2: More flexible but complicated, there could be separate suser_enabled and allow.suser bits, though that's only useful in the probably-rare case of wanting to regain suser ability.

I like option 2 better: easier to code, easier for admins to understand, less likely to cause a problem.

Nov 9 2020, 7:34 PM