Page MenuHomeFreeBSD

Delete the now expired postgresql90 ports. Upstream support for postgresql-9.0.x was declared EoL in September 2015.
ClosedPublic

Authored by matthew on Jun 20 2016, 6:29 AM.
Tags
None
Referenced Files
Unknown Object (File)
Wed, May 22, 10:24 AM
Unknown Object (File)
Sat, May 11, 10:07 PM
Unknown Object (File)
Sat, May 11, 6:52 AM
Unknown Object (File)
Sat, May 11, 6:52 AM
Unknown Object (File)
Sat, May 11, 6:52 AM
Unknown Object (File)
Sat, May 11, 6:52 AM
Unknown Object (File)
Tue, May 7, 10:38 PM
Unknown Object (File)
Tue, Apr 30, 2:56 PM
Subscribers

Details

Summary

Remove 9.0 from the list of postgresql versions available in ports

Disconnect postgresql90 ports from the build

Remove postgresql90-pgtcl port

Remove postgresql90-client port

Move the master postgreslXY-plperl makefile to postgresql95-plperl/Makefile.

Adjust include lines in other postgresqlXY-plperl ports

Delete postgresql90-plperl

Move the master postgreslXY-plpython/{Makefile,pkg-descr} to
postgresl95-plpython/{Makefile,pkg-descr}

Adjust all other postgresqlXY-plpython/Makefile to include the new master

Remove postgresql90-server

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Lint Not Applicable
Unit
Tests Not Applicable

Event Timeline

matthew retitled this revision from to Delete the now expired postgresql90 ports. Upstream support for postgresql-9.0.x was declared EoL in September 2015..
matthew updated this object.
matthew edited the test plan for this revision. (Show Details)
matthew added reviewers: crees, jgh, girgen.

Hi Matthew,

Thanks for doing this. You should also add lines to MOVED for the removed ports?

Did you run a make index to check it?

Chris

matthew edited edge metadata.

Add MOVED entries

  • Remove 9.0 from the list of postgresql versions available in ports
  • Disconnect postgresql90 ports from the build
  • Remove postgresql90-pgtcl port
  • Remove postgresql90-client port
  • Move the master postgreslXY-plperl makefile to postgresql95-plperl/Makefile.
  • Move the master postgreslXY-plpython/{Makefile,pkg-descr} to
  • Remove postgresql90-server
  • Add MOVED entries for the deleted ports.

Updating D6898: Delete the now expired postgresql90 ports. Upstream support for

postgresql-9.0.x was declared EoL in September 2015.

I can confirm that 'make index' runs without problems.

bapt added a reviewer: bapt.
This revision is now accepted and ready to land.Jul 1 2016, 6:57 AM
crees edited edge metadata.
This revision was automatically updated to reflect the committed changes.