Page MenuHomeFreeBSD

Update Ruby to latest version
AbandonedPublic

Authored by mmoll on Dec 21 2015, 2:05 PM.

Details

Reviewers
sunpoet
Group Reviewers
Ruby
portmgr
Summary
  • Update lang/ruby{20,21,22} to 2.0.0p648, 2.1.8 and 2.2.4
  • Add LICENSE_FILE
  • Use USES=autoreconf instead of USE_AUTOTOOLS=autoconf
  • Use USES=libedit
  • Use USES=tar:xz (for lang/ruby20)
  • Silence patch and build messages
Test Plan

exp-run

Diff Detail

Repository
rP FreeBSD ports repository
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 1769
Build 1775: arc lint + arc unit

Event Timeline

sunpoet updated this revision to Diff 11519.Dec 21 2015, 2:05 PM
sunpoet retitled this revision from to Update Ruby to latest version.
sunpoet updated this object.
sunpoet edited the test plan for this revision. (Show Details)
sunpoet added reviewers: Ruby, portmgr.
sunpoet updated this object.Dec 21 2015, 2:09 PM
sunpoet edited edge metadata.
mmoll accepted this revision.Dec 21 2015, 11:07 PM
mmoll added a reviewer: mmoll.
mmoll added a subscriber: mmoll.

seems to work just fine, also on armv6hf and sparc64

mmoll commandeered this revision.Dec 24 2015, 4:36 PM
mmoll edited reviewers, added: sunpoet; removed: mmoll.

comandeer to close

mmoll abandoned this revision.Dec 24 2015, 4:36 PM