diff --git a/documentation/content/en/books/handbook/bsdinstall/_index.adoc b/documentation/content/en/books/handbook/bsdinstall/_index.adoc --- a/documentation/content/en/books/handbook/bsdinstall/_index.adoc +++ b/documentation/content/en/books/handbook/bsdinstall/_index.adoc @@ -216,7 +216,7 @@ + [source,shell] .... -# dd if=FreeBSD-13.0-RELEASE-amd64-memstick.img of=/dev/da0 bs=1M conv=sync +# dd if=FreeBSD-13.1-RELEASE-amd64-memstick.img of=/dev/da0 bs=1M conv=sync .... + If this command fails, verify that the USB stick is not mounted and that the device name is for the disk, not a partition. diff --git a/documentation/content/en/books/handbook/cutting-edge/_index.adoc b/documentation/content/en/books/handbook/cutting-edge/_index.adoc --- a/documentation/content/en/books/handbook/cutting-edge/_index.adoc +++ b/documentation/content/en/books/handbook/cutting-edge/_index.adoc @@ -257,11 +257,11 @@ Refer to <> for instructions on how to get a copy of the [.filename]#GENERIC# kernel. ==== -The following command, when run on a FreeBSD 9.0 system, will upgrade it to FreeBSD 9.1: +The following command, when run on a FreeBSD 13.0 system, will upgrade it to FreeBSD 13.1: [source,shell] .... -# freebsd-update -r 9.1-RELEASE upgrade +# freebsd-update -r 13.1-RELEASE upgrade .... After the command has been received, `freebsd-update` will evaluate the configuration file and current system in an attempt to gather the information necessary to perform the upgrade. @@ -271,7 +271,7 @@ [source,shell] .... Looking up update.FreeBSD.org mirrors... 1 mirrors found. -Fetching metadata signature for 9.0-RELEASE from update1.FreeBSD.org... done. +Fetching metadata signature for 13.0-RELEASE from update1.FreeBSD.org... done. Fetching metadata index... done. Inspecting system... done. @@ -296,7 +296,7 @@ [source,shell] .... WARNING: This system is running a "MYKERNEL" kernel, which is not a -kernel configuration distributed as part of FreeBSD 9.0-RELEASE. +kernel configuration distributed as part of FreeBSD 13.0-RELEASE. This kernel will not be updated: you MUST update the kernel manually before running "/usr/sbin/freebsd-update install" .... @@ -794,15 +794,16 @@ [source,shell] .... # uname -r -10.3-RELEASE +13.1-RELEASE .... -Based on <>, the source used to update `10.3-RELEASE` has a repository path of `releng/10.3`. That path is used when checking out the source: +Based on <>, the source used to update `13.1-RELEASE` has a repository path of `releng/13.1`. +That path is used when checking out the source: [source,shell] .... # mv /usr/src /usr/src.bak <.> -# git clone --branch releng/10.3 https://git.FreeBSD.org/src.git /usr/src <.> +# git clone --branch releng/13.1 https://git.FreeBSD.org/src.git /usr/src <.> .... <.> Move the old directory out of the way. If there are no local modifications in this directory, it can be deleted. diff --git a/documentation/content/en/books/handbook/jails/_index.adoc b/documentation/content/en/books/handbook/jails/_index.adoc --- a/documentation/content/en/books/handbook/jails/_index.adoc +++ b/documentation/content/en/books/handbook/jails/_index.adoc @@ -335,11 +335,11 @@ To upgrade the jail to a new major or minor version, first upgrade the host system as described in crossref:cutting-edge[freebsdupdate-upgrade,“Performing Major and Minor Version Upgrades”]. Once the host has been upgraded and rebooted, the jail can then be upgraded. -For example to upgrade from 12.0-RELEASE to 12.1-RELEASE, on the host run: +For example to upgrade from 12.2-RELEASE to 12.3-RELEASE, on the host run: [source,shell] .... -# freebsd-update -b /here/is/the/jail --currently-running 12.0-RELEASE -r 12.1-RELEASE upgrade +# freebsd-update -b /here/is/the/jail --currently-running 12.2-RELEASE -r 12.3-RELEASE upgrade # freebsd-update -b /here/is/the/jail install # service jail restart myjail # freebsd-update -b /here/is/the/jail install @@ -720,7 +720,7 @@ . To Populate the Jail with FreeBSD-RELEASE + For a basejail based on the FreeBSD RELEASE matching that of the host computer, use `install`. -For example, on a host computer running FreeBSD 10-STABLE, the latest RELEASE version of FreeBSD -10 will be installed in the jail): +For example, on a host computer running FreeBSD 13-STABLE, the latest RELEASE version of FreeBSD 13 will be installed in the jail) + [source,shell] .... @@ -902,14 +902,14 @@ [source,shell] .... # file /usr/jails/basejail/bin/sh -/usr/jails/basejail/bin/sh: ELF 64-bit LSB executable, x86-64, version 1 (FreeBSD), dynamically linked (uses shared libs), for FreeBSD 9.3, stripped +/usr/jails/basejail/bin/sh: ELF 64-bit LSB executable, x86-64, version 1 (FreeBSD), dynamically linked, interpreter /libexec/ld-elf.so.1, for FreeBSD 13.0, FreeBSD-style, stripped .... -Now use this information to perform the upgrade from `9.3-RELEASE` to the current version of the host system: +Now use this information to perform the upgrade from `13.0-RELEASE` to the current version of the host system: [source,shell] .... -# ezjail-admin update -U -s 9.3-RELEASE +# ezjail-admin update -U -s 13.0-RELEASE .... After updating the basejail, man:mergemaster[8] must be run to update each jail's configuration files. diff --git a/documentation/content/en/books/handbook/virtualization/_index.adoc b/documentation/content/en/books/handbook/virtualization/_index.adoc --- a/documentation/content/en/books/handbook/virtualization/_index.adoc +++ b/documentation/content/en/books/handbook/virtualization/_index.adoc @@ -608,8 +608,8 @@ [source,shell] .... -# fetch ftp://ftp.freebsd.org/pub/FreeBSD/releases/ISO-IMAGES/12.2/FreeBSD-12.2-RELEASE-amd64-bootonly.iso -FreeBSD-12.2-RELEASE-amd64-bootonly.iso 100% of 230 MB 570 kBps 06m17s +# fetch https://download.freebsd.org/releases/ISO-IMAGES/13.1/FreeBSD-13.1-RELEASE-amd64-bootonly.iso +FreeBSD-13.1-RELEASE-amd64-bootonly.iso 366 MB 16 MBps 22s .... FreeBSD comes with an example script for running a virtual machine in bhyve. @@ -620,7 +620,7 @@ [source,shell] .... -# sh /usr/share/examples/bhyve/vmrun.sh -c 1 -m 1024M -t tap0 -d guest.img -i -I FreeBSD-12.2-RELEASE-amd64-bootonly.iso guestname +# sh /usr/share/examples/bhyve/vmrun.sh -c 1 -m 1024M -t tap0 -d guest.img -i -I FreeBSD-13.1-RELEASE-amd64-bootonly.iso guestname .... The virtual machine will boot and start the installer. @@ -1028,7 +1028,7 @@ [source,shell] .... -# fetch ftp://ftp.freebsd.org/pub/FreeBSD/releases/ISO-IMAGES/12.0/FreeBSD-12.0-RELEASE-amd64-bootonly.iso -o freebsd.iso +# fetch https://download.freebsd.org/releases/ISO-IMAGES/13.1/FreeBSD-13.1-RELEASE-amd64-bootonly.iso -o freebsd.iso .... A ZFS volume of 20 GB called [.filename]#xendisk0# is created to serve as the disk space for the VM.