diff --git a/share/man/man4/tcp_bbr.4 b/share/man/man4/tcp_bbr.4 --- a/share/man/man4/tcp_bbr.4 +++ b/share/man/man4/tcp_bbr.4 @@ -24,19 +24,13 @@ .\" .\" $FreeBSD$ .\" -.Dd September 24, 2020 +.Dd September 12, 2022 .Dt TCP_BBR 4 .Os .Sh NAME .Nm tcp_bbr .Nd TCP Bottleneck Bandwidth and Round-Trip Time Algorithm .Sh SYNOPSIS -To use this TCP stack you have to place the following line in your -kernel configuration file: -.Bd -ragged -offset indent -.Cd "options TCPHPTS" -.Ed -.Pp To load the driver as a module at boot time, place the following line in .Xr loader.conf 5 : .Bd -literal -offset indent diff --git a/sys/amd64/conf/GENERIC b/sys/amd64/conf/GENERIC --- a/sys/amd64/conf/GENERIC +++ b/sys/amd64/conf/GENERIC @@ -37,6 +37,7 @@ options TCP_BLACKBOX # Enhanced TCP event logging options TCP_HHOOK # hhook(9) framework for TCP options TCP_RFC7413 # TCP Fast Open +options TCPHPTS # TCP High Precision Timer Support options SCTP_SUPPORT # Allow kldload of SCTP options KERN_TLS # TLS transmit & receive offload options FFS # Berkeley Fast Filesystem diff --git a/sys/arm64/conf/std.arm64 b/sys/arm64/conf/std.arm64 --- a/sys/arm64/conf/std.arm64 +++ b/sys/arm64/conf/std.arm64 @@ -19,6 +19,7 @@ options TCP_OFFLOAD # TCP offload options TCP_HHOOK # hhook(9) framework for TCP options TCP_RFC7413 # TCP Fast Open +options TCPHPTS # TCP High Precision Timer Support options SCTP_SUPPORT # Allow kldload of SCTP options KERN_TLS # TLS transmit & receive offload options FFS # Berkeley Fast Filesystem diff --git a/sys/conf/kern.opts.mk b/sys/conf/kern.opts.mk --- a/sys/conf/kern.opts.mk +++ b/sys/conf/kern.opts.mk @@ -57,11 +57,9 @@ __DEFAULT_NO_OPTIONS = \ BHYVE_SNAPSHOT \ - EXTRA_TCP_STACKS \ INIT_ALL_PATTERN \ INIT_ALL_ZERO \ KERNEL_RETPOLINE \ - RATELIMIT \ REPRODUCIBLE_BUILD # Some options are totally broken on some architectures. We disable diff --git a/sys/conf/kern.post.mk b/sys/conf/kern.post.mk --- a/sys/conf/kern.post.mk +++ b/sys/conf/kern.post.mk @@ -34,10 +34,6 @@ MKMODULESENV+= WITH_CTF="${WITH_CTF}" .endif -.if defined(WITH_EXTRA_TCP_STACKS) -MKMODULESENV+= WITH_EXTRA_TCP_STACKS="${WITH_EXTRA_TCP_STACKS}" -.endif - .if !empty(KCSAN_ENABLED) MKMODULESENV+= KCSAN_ENABLED="yes" .endif diff --git a/sys/modules/tcp/Makefile b/sys/modules/tcp/Makefile --- a/sys/modules/tcp/Makefile +++ b/sys/modules/tcp/Makefile @@ -9,10 +9,8 @@ ${_tcp_rack} \ ${_tcpmd5} \ -.if ${MK_EXTRA_TCP_STACKS} != "no" || defined(ALL_MODULES) _tcp_bbr= bbr _tcp_rack= rack -.endif .if (${MK_INET_SUPPORT} != "no" || ${MK_INET6_SUPPORT} != "no") || \ defined(ALL_MODULES) diff --git a/tools/build/options/WITH_EXTRA_TCP_STACKS b/tools/build/options/WITH_EXTRA_TCP_STACKS deleted file mode 100644 --- a/tools/build/options/WITH_EXTRA_TCP_STACKS +++ /dev/null @@ -1,2 +0,0 @@ -.\" $FreeBSD$ -Build extra TCP stack modules.