Index: en_US.ISO8859-1/books/handbook/jails/chapter.xml
===================================================================
--- en_US.ISO8859-1/books/handbook/jails/chapter.xml
+++ en_US.ISO8859-1/books/handbook/jails/chapter.xml
@@ -686,7 +686,9 @@
the latest -RELEASE branch using the instructions in . Additionally, this template uses the
sysutils/cpdup package or port and
- portsnap will be used to download
+ portsnap (if running &rel114.current;
+ or &rel121.current;) or Subversion
+ (if running &os.current;) will be used to download
the &os; Ports Collection.
@@ -707,10 +709,30 @@
well as a &os; source tree, which is required for
mergemaster:
- &prompt.root; cd /home/j/mroot
-&prompt.root; mkdir usr/ports
-&prompt.root; portsnap -p /home/j/mroot/usr/ports fetch extract
-&prompt.root; cpdup /usr/src /home/j/mroot/usr/src
+
+
+ &prompt.root; cd /home/j/mroot
+&prompt.root; mkdir usr/ports
+
+
+ Use portsnap (if running
+ &os; &rel114.current; or &rel121.current;) or
+ Subversion (if running
+ &os.current;) to download the ports
+ tree:
+
+
+ &prompt.root; portsnap -p /home/j/mroot/usr/ports auto
+
+
+ &prompt.root; svn co https://svn.freebsd.org/ports/head /home/j/mroot/usr/ports
+
+
+
+
+ &prompt.root; cpdup /usr/src /home/j/mroot/usr/src
+
+
@@ -817,7 +839,7 @@
jail_mail_rootdir="/usr/home/j/mail"
jail_mail_devfs_enable="YES"
jail_www_hostname="www.example.org"
-jail_www_ip="62.123.43.14"
+jail_www_ip="192.168.3.19"
jail_www_rootdir="/usr/home/j/www"
jail_www_devfs_enable="YES"
@@ -875,7 +897,7 @@
JID IP Address Hostname Path
3 192.168.3.17 ns.example.org /home/j/ns
2 192.168.3.18 mail.example.org /home/j/mail
- 1 62.123.43.14 www.example.org /home/j/www
+ 1 192.168.3.19 www.example.org /home/j/www
At this point, it should be possible to log onto each
jail, add new users, or configure daemons. The
@@ -997,6 +1019,11 @@
+
+ This section and ezjail are not
+ applicable if using &os.current;.
+
+
Creating and managing multiple jails can quickly become
tedious and error-prone. Dirk Engling's
ezjail automates and greatly
Index: en_US.ISO8859-1/books/handbook/mirrors/chapter.xml
===================================================================
--- en_US.ISO8859-1/books/handbook/mirrors/chapter.xml
+++ en_US.ISO8859-1/books/handbook/mirrors/chapter.xml
@@ -121,7 +121,7 @@
Subversion is generally a
- developer tool. Users may prefer to use
+ developer tool. Users not running &os.current; may prefer to use
freebsd-update () to update
the &os; base system, and portsnap (Using the Ports Collection
The Ports Collection is a set of
- Makefiles, patches, and description files.
+ Makefiles, patches, and description files.
Each set of these files is used to compile and install an
individual application on &os;, and is called a
port.
@@ -848,7 +848,8 @@
The base system of &os; includes
Portsnap. This is a fast and
user-friendly tool for retrieving the Ports Collection and
- is the recommended choice for most users. This utility
+ is the recommended choice for most users not running
+ &os.current;. This utility
connects to a &os; site, verifies the secure key, and
downloads a new copy of the Ports Collection. The key is used
to verify the integrity of all downloaded files.
@@ -890,7 +891,7 @@
Subversion MethodIf more control over the ports tree is needed or if local
- changes need to be maintained,
+ changes need to be maintained, or if running &os.current;,
Subversion can be used to obtain
the Ports Collection. Refer to the
@@ -1563,52 +1564,54 @@
amd64. The default is the
architecture shown by uname.
- &prompt.root; poudriere jail -c -j 10amd64 -v 10.0-RELEASE
-====>> Creating 10amd64 fs... done
-====>> Fetching base.txz for FreeBSD 10.0-RELEASE amd64
-/poudriere/jails/10amd64/fromftp/base.txz 100% of 59 MB 1470 kBps 00m42s
-====>> Extracting base.txz... done
-====>> Fetching src.txz for FreeBSD 10.0-RELEASE amd64
-/poudriere/jails/10amd64/fromftp/src.txz 100% of 107 MB 1476 kBps 01m14s
-====>> Extracting src.txz... done
-====>> Fetching games.txz for FreeBSD 10.0-RELEASE amd64
-/poudriere/jails/10amd64/fromftp/games.txz 100% of 865 kB 734 kBps 00m01s
-====>> Extracting games.txz... done
-====>> Fetching lib32.txz for FreeBSD 10.0-RELEASE amd64
-/poudriere/jails/10amd64/fromftp/lib32.txz 100% of 14 MB 1316 kBps 00m12s
-====>> Extracting lib32.txz... done
-====>> Cleaning up... done
-====>> Jail 10amd64 10.0-RELEASE amd64 is ready to be used
+ &prompt.root; poudriere jail -c -j 11amd64 -v 11.4-RELEASE
+[00:00:00] Creating 11amd64 fs at /poudriere/jails/11amd64... done
+[00:00:00] Using pre-distributed MANIFEST for FreeBSD 11.4-RELEASE amd64
+[00:00:00] Fetching base for FreeBSD 11.4-RELEASE amd64
+/poudriere/jails/11amd64/fromftp/base.txz 125 MB 4110 kBps 31s
+[00:00:33] Extracting base... done
+[00:00:54] Fetching src for FreeBSD 11.4-RELEASE amd64
+/poudriere/jails/11amd64/fromftp/src.txz 154 MB 4178 kBps 38s
+[00:01:33] Extracting src... done
+[00:02:31] Fetching lib32 for FreeBSD 11.4-RELEASE amd64
+/poudriere/jails/11amd64/fromftp/lib32.txz 24 MB 3969 kBps 06s
+[00:02:38] Extracting lib32... done
+[00:02:42] Cleaning up... done
+[00:02:42] Recording filesystem state for clean... done
+[00:02:42] Upgrading using ftp
+/etc/resolv.conf -> /poudriere/jails/11amd64/etc/resolv.conf
+Looking up update.FreeBSD.org mirrors... 3 mirrors found.
+Fetching public key from update4.freebsd.org... done.
+Fetching metadata signature for 11.4-RELEASE from update4.freebsd.org... done.
+Fetching metadata index... done.
+Fetching 2 metadata files... done.
+Inspecting system... done.
+Preparing to download files... done.
+Fetching 124 patches.....10....20....30....40....50....60....70....80....90....100....110....120.. done.
+Applying patches... done.
+Fetching 6 files... done.
+The following files will be added as part of updating to
+11.4-RELEASE-p1:
+/usr/src/contrib/unbound/.github
+/usr/src/contrib/unbound/.github/FUNDING.yml
+/usr/src/contrib/unbound/contrib/drop2rpz
+/usr/src/contrib/unbound/contrib/unbound_portable.service.in
+/usr/src/contrib/unbound/services/rpz.c
+/usr/src/contrib/unbound/services/rpz.h
+/usr/src/lib/libc/tests/gen/spawnp_enoexec.sh
+The following files will be updated as part of updating to
+11.4-RELEASE-p1:
+[…]
+Installing updates...Scanning //usr/share/certs/blacklisted for certificates...
+Scanning //usr/share/certs/trusted for certificates...
+ done.
+11.4-RELEASE-p1
+[00:04:06] Recording filesystem state for clean... done
+[00:04:07] Jail 11amd64 11.4-RELEASE-p1 amd64 is ready to be used
- &prompt.root; poudriere ports -c -p local
-====>> Creating local fs... done
-====>> Extracting portstree "local"...
-Looking up portsnap.FreeBSD.org mirrors... 7 mirrors found.
-Fetching public key from ec2-eu-west-1.portsnap.freebsd.org... done.
-Fetching snapshot tag from ec2-eu-west-1.portsnap.freebsd.org... done.
-Fetching snapshot metadata... done.
-Fetching snapshot generated at Tue Feb 11 01:07:15 CET 2014:
-94a3431f0ce567f6452ffde4fd3d7d3c6e1da143efec76100% of 69 MB 1246 kBps 00m57s
-Extracting snapshot... done.
-Verifying snapshot integrity... done.
-Fetching snapshot tag from ec2-eu-west-1.portsnap.freebsd.org... done.
-Fetching snapshot metadata... done.
-Updating from Tue Feb 11 01:07:15 CET 2014 to Tue Feb 11 16:05:20 CET 2014.
-Fetching 4 metadata patches... done.
-Applying metadata patches... done.
-Fetching 0 metadata files... done.
-Fetching 48 patches.
-(48/48) 100.00% done.
-done.
-Applying patches...
-done.
-Fetching 1 new ports or files... done.
-/poudriere/ports/tester/CHANGES
-/poudriere/ports/tester/COPYRIGHT
-
-[...]
-
-Building new INDEX files... done.
+ &prompt.root; poudriere ports -c -p local -m svn+https
+[00:00:00] Creating local fs at /poudriere/ports/local... done
+[00:00:00] Checking out the ports tree... doneOn a single computer, poudriere
can build ports with multiple configurations, in multiple
@@ -1625,13 +1628,13 @@
>/usr/local/etc/poudriere.d.
The filename in this example is created by combining the jail
name, port name, and set name:
- 10amd64-local-workstation-make.conf.
+ 11amd64-local-workstation-make.conf.
The system make.conf and this new file
are combined at build time to create the
make.conf used by the build jail.Packages to be built are entered in
- 10amd64-local-workstation-pkglist:
+ 11amd64-local-workstation-pkglist:editors/emacs
devel/git
@@ -1641,12 +1644,12 @@
Options and dependencies for the specified ports are
configured:
- &prompt.root; poudriere options -j 10amd64 -p local -z workstation -f 10amd64-local-workstation-pkglist
+ &prompt.root; poudriere options -j 10amd64 -p local -z workstation -f 11amd64-local-workstation-pkglistFinally, packages are built and a package
repository is created:
- &prompt.root; poudriere bulk -j 10amd64 -p local -z workstation -f 10amd64-local-workstation-pkglist
+ &prompt.root; poudriere bulk -j 11amd64 -p local -z workstation -f 11amd64-local-workstation-pkglistWhile running, pressing Ctrlt
@@ -1684,18 +1687,18 @@
Usually it is easiest to serve a poudriere repository to
the client machines via HTTP. Set up a webserver to serve up
the package directory, for instance:
- /usr/local/poudriere/data/packages/10amd64,
- where 10amd64
+ /usr/local/poudriere/data/packages/11amd64,
+ where 11amd64
is the name of the build.If the URL to the package repository is:
- http://pkg.example.com/10amd64, then the
+ http://pkg.example.com/11amd64, then the
repository configuration file in
/usr/local/etc/pkg/repos/custom.conf
would look like:custom: {
- url: "http://pkg.example.com/10amd64",
+ url: "http://pkg.example.com/11amd64",
enabled: yes,
}