I have to say, I prefer the longer name. Do we want to open this up to defining more common vendor names beyond just INVALID? Traditionally we haven't done that. In the case of drivers that have a bunch of other PCI_VENDOR_foo (like the bhnd_id.s file) having just PCIV_INTEL and then PCI_VENDOR_<foo> for the rest kind of sticks out like a sore thumb.
Weird this isn't using PCIC_*