Page MenuHomeFreeBSD

Install ecurity/cyrus-sasl2-gssapi if GSSAPI
AbandonedPublic

Authored by dereks_lifeofadishwasher.com on Apr 28 2017, 4:41 AM.

Details

Reviewers
None
Summary

Due to security/cyrus-sasl2-gssapi being split from
security/cyrus-sasl2 GSS auth does not work.

  • Install security/cyrus-sasl2-gssapi if GSSAPI_NONE is not selected
  • Imply SASL for GSSAPI
  • Move duplicate --with-gss to a single GSSAPI_NONE_CONFIGURE_OFF

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=218899

Test Plan

Confirm mutt-1.8.2.txz dependencies include cyrus-sasl and cyrus-sasl-gssapi via 'pkg info -dF .../mutt-1.8.2.txz

Diff Detail

Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 8945
Build 9337: arc lint + arc unit